Selecting Components

This section describes how to select components interactively in the 3D views. With components, selecting is sometimes also called tagging.

As an alternative to selecting interactively, you can select components using character strings (see Selecting by Name).

Some component selection techniques apply only to polygon mesh components. For more information about those techniques, see Selecting Polygon Mesh Components [Polygon Modeling].

 

You cannot select an object and components on the same object at the same time.

Overview of Selecting Components

Selecting components is a three-stage process:

1. Select one or more objects with components. These include polygon meshes, curves, surfaces, lattices, point clouds, and hair.

2. Activate a component selection filter and a selection tool. Alternatively, you can use a component selection mode that sets the most frequent combinations of filter and tool automatically.

- The component selection filters are described in Component Selection Filters.

- The selection tools are described in Using Selection Tools.

- The component selection modes are described in Component Selection Modes.

The selected objects are displayed in orange to show that they are active for component selection. You can select components only on active objects.

3. Use the mouse in the 3D views. The specific mouse buttons and modifier keys that you use to perform different actions — like selecting, adding to the selection, toggling, and deselecting — depend on the selection interaction model. For more complete details, see Selecting Components Using the Different Interaction Models.

Selected components are highlighted in red by default.

 

Using the Shift key and the selection modes, you can select different types of component at the same time.

Component Selection Modes

Selection modes are predefined pairs of the most commonly used combinations of selection filter and tool. They are all assigned to keys for quick and easy access.

To activate a component selection mode

Do one of the following:

• Choose one of the items from the Select > Modes menu.

or

• Press one of the following keys:

- T for Rectangle Point mode.

- E for Rectangle Edge mode.

- I for Raycast Edge mode.

- Y for Rectangle Polygon mode.

- U for Raycast Polygon mode.

- ' (apostrophe) for Rectangle Tip mode (for hair objects)

With any of the above keys, you can also use the Shift key for extended mode.

 

The extended modes are similar to the non-extended ones. The difference is that when you activate an extended mode, the components you have already selected are not removed from the selection. This lets you select different types of components at the same time.

If both Select > SI|3D Selection Model and Select > Extended Component Selection are off, then you must also press Shift while clicking to add components to the selection. If you do not press Shift, the newly-selected components replace the old selection.

Component Selection Filters

Component selection filters determine what type of component you can select on the active geometric objects. The most commonly-used filters are available as buttons on the Select panel, while more filters are available from the Filter menu below the buttons.

The component selection filters are context-sensitive: they change depending on what type of object is active. For example, if a polygon mesh object is selected, then the available filters include Edge, Polygon, and others; if a NURBS surface is selected, then the available filters include Subsurface, Isoline, and others.

 

A

Common filters are buttons.

B

Other filters are in the menu.

1

Curve Component Filters

2

Surface Component Filters

3

Polygon Component Filters

4

Hair Component Filters

5

Lattice Or Point Cloud Component Filter

 

There are additional filters on these menus that allow you to select, for example, border points or edges. These are examples of custom filters. For information about creating your own filters, see Custom Filter [SDK Guide].

Selecting a component filter restores the last-selected components of that type on the active objects. For example, if you select the Point filter, the most recently selected points on the active objects are automatically selected and highlighted.

 

To select two or more types of components at the same time, first select some components of one type and then press the Shift key while changing filters. The components you have already selected are not removed from the selection.

If both Select > SI|3D Selection Model and Select > Extended Component Selection are both off, then you must also press Shift while clicking to add components to the selection. If you do not press Shift, the newly-selected components replace the old selection.

Selecting Components Using the Different Interaction Models

When selecting components in the 3D views, Softimage can use either of two interaction models:

• The default Softimage selection model uses modifier keys like Shift and Control to extend the selection, toggle, deselect, and so on. In this respect, it is more consistent with other Windows applications. In addition, the right mouse button displays a context menu, so that you can keep the selection tool active and still have quick access to many commonly used commands.

• The SI|3D selection model uses the different mouse buttons to select (tag), deselect (untag), and toggle components just as in SOFTIMAGE|3D. It is intended for people who are familiar with or prefer this style of interaction. To display a context menu for components, you must use Alt+right-click on Windows, or Ctrl+Alt+right-click on Linux.

The interaction model for components is controlled by two options on the Select menu: SI|3D Selection Model and Extended Component Selection. The first one implies the second one, so it is possible to use the SI|3D selection model for just components with Extended Component Selection on, or for both objects and components with SI|3D Selection Model on.

The initial interaction model depends on the choice you made in the Interaction Model dialog box the first time you started Softimage. However, you can change it at any time and your change is remembered the next time you start Softimage.

To activate the Softimage selection model for components

• Make sure that both Select > SI|3D Selection Model and Select > Extended Component Selection are off.

To select components with the Softimage selection model

If both SI|3D Selection Model and Extended Component Selection are off in the Select menu in the main command area, use the following mouse and keyboard combinations to select components:

• To select new components and deselect any that are currently selected, don’t press any modifier keys.

• To add components to the selection, press the Shift key.

• To toggle-select, press the Ctrl key.

• To deselect, press Ctrl+Shift.

• To deselect all, click or click+drag over an empty area of a 3D view.

• With any of the above key combinations, use the left mouse button for components or the middle mouse button for clusters. You can also use the Cluster filter on the Select panel or press =. For more about cluster selection, see Selecting Clusters.

• To display a context menu showing commands that are applicable to the selection, right-click anywhere on the object with selected components.

To activate the SI|3D selection model for components

• Make sure that one or both of the Select > SI|3D Selection Model and Select > Extended Component Selection options are on.

To select components with the SI|3D selection model

If either the SI|3D Selection Model or the Extended Component Selection options are on in the Select menu in the Select panel, use the following mouse and keyboard combinations to select components:

• To add components to the selection, use the left mouse button.

• To deselect components, use the middle mouse button.

• To toggle-select components, use the right mouse button.

• To select clusters, use the Cluster filter on the Select panel or press =.

• To display a context menu showing commands that are applicable to the selection, Alt+right-click anywhere on the object with selected components in Windows (Ctrl+Alt+right-click on Linux).

Selecting Ranges and Loops of Components

Using the Alt (or Ctrl) key, you can select ranges or loops of components. Softimage tries to find a path between two components that you pick. In the case of ranges, it selects all components along the path between the picked components. In the case of loops, it extends the path, if possible, and selects all components along the entire path.

• For polygon meshes, you can select ranges or loops of points, edges, or polygons. Several strategies are used to find a path, but priority is given to borders and quadrilateral topology.

• For NURBS curves and surfaces, you can select ranges or loops of points, knots, or knot curves. Points and knots must lie in the same U or V row. In addition, paths and loops stop at junctions between subsurfaces on assembled surface meshes.

The procedure for selecting ranges and loops depends on the component selection model you are using. Each procedure is described in the sections that follow. For more information about the component selection models in general, including how to activate them, see Selecting Components Using the Different Interaction Models.

 

You cannot use the Paint selection tool to select ranges and loops.

Range Selection

You can select a range of components using the Alt key. This allows you to select the interconnected components that lie on a path between two components you pick.

 

1

First specify the anchor.

2

Then specify the end component to select the range of components in-between.

To select component ranges with the Softimage selection model

1. Select the first “anchor” component.

2. Alt+click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Alt key is pressed.

All components between the two components on a path become selected.

 

On Linux, Alt+click may not work if that combination is used by your window manager for another purpose. In these cases, you can modify your window manager to use a different combination. For more information, see Linux Systems and the Alt Key [Interface and Tools] or consult the documentation for your window manager.

3. Use the following key and mouse combinations to further refine the selection:

- Use Shift to add individual components to the selection as usual. If you want to add additional ranges or loops using Alt+Shift, the last component added to the selection is the new anchor. If you want to start a new range anchored at the end of the previous range, you must reselect the last component by Shift+clicking or Alt+Shift+clicking. Once you have selected a new anchor, you can Alt+Shift+click to add another range to the selection.

- Use Ctrl to toggle-select. Once you have selected a new anchor, you can Alt+Ctrl+click to toggle the selection of a range.

- Use Ctrl+Shift to deselect. Once you have selected a new anchor, you can Alt+Ctrl+Shift+click to deselect a range.

To select component ranges with the SI|3D selection model

1. Select the first “anchor” component.

2. Alt+click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Alt key is pressed.

All components between the two components on a path become selected.

3. Use the following mouse buttons to further refine the selection:

- Use the left mouse button to add to the selection. The last selected component becomes the anchor for any new range. If you want to start a new range anchored at the end of the previous range, you must reselect the last component by clicking or Alt+clicking. Once you have selected a new anchor, you can Alt+click to add another range to the selection.

- Use the middle mouse button to deselect. Once you have selected a new anchor, you can Alt+middle-click to deselect a range.

- Use the right mouse button to toggle-select. Once you have selected a new anchor, you can Alt+right-click to toggle the selection of a range.

Loop Selection

When you select a loop of components, Softimage finds a path between two components that you pick. It then extends the path in both directions, if it is possible, and selects all components along the extended path.

 

1

First specify the anchor.

2

Then specify another component to select the entire loop of components.

 

For edge loops on polygon meshes, there are some other commands that use stricter criteria. See Selecting Edge Loops [Polygon Modeling].

To select component loops with the Softimage selection model

1. Do one of the following:

- Select the first “anchor” component, then Alt+middle-click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Alt key is pressed.

or

- Alt+middle-click to select two adjacent components in a single mouse movement.

All components on an extended path connecting the two components become selected.

Note that for edges, the direction is implied so you only need to Alt+middle-click on a single edge. However, for parallel edge loops, you still need to specify two edges as described previously.

2. Use the following key and mouse combinations to further refine the selection:

- Use Shift to add individual components to the selection as usual. If you want to add additional ranges or loops using Alt+Shift, the last component added to the selection is the new anchor. The last selected component becomes the anchor for any new loop. Once you have selected a new anchor, you can Alt+Shift+middle-click to add another loop to the selection.

- Use Ctrl to toggle-select. Once you have selected a new anchor, you can Alt+Ctrl+middle-click to toggle the selection of a loop.

- Use Ctrl+Shift to deselect. Once you have selected a new anchor, you can Alt+Ctrl+Shift+middle-click to deselect a loop.

To select component loops with the SI|3D selection model

1. Do one of the following:

- Select the first “anchor” component, then Ctrl+click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Ctrl key is pressed.

or

- Ctrl+click to select two adjacent components in a single mouse movement.

All components on an extended path connecting the two components become selected.

Note that for edges, the direction is implied so you only need to Ctrl+click on a single edge. However, you still need to specify two edges for a parallel edge loop.

2. Use the following mouse buttons to further refine the selection:

- Use the left mouse button to add to the selection. The last selected component becomes the anchor for any new loop. Once you have selected a new anchor, you can Ctrl+click to add another loop to the selection.

- Use the middle mouse button to deselect. Once you have selected a new anchor, you can Ctrl+middle-click to deselect a loop.

- Use the right mouse button to toggle-select. Once you have selected a new anchor, you can Ctrl+right-click to toggle the selection of a loop.

Deselecting Components

Do one of the following:

• If both Select > SI|3D Selection Model and Select > Extended Component Selection are off, Ctrl+Shift+click on the components.

or

• If either option is on, middle-click on the components.

Navigating Component Selection

When point, edge, or polygon components are selected, you can use keyboard shortcuts to navigate among them. The order is based on the internal indices of the components; this is particularly useful for points on curves, where the index corresponds exactly to the position of the point along the curve.

Use this...

To do this...

Alt+up-arrow or
Alt+right-arrow

Select the next component.

Alt+down-arrow or
Alt+left-arrow

Select the previous component.

Alt+Home

Select the first component.

Alt+End

Select the last component.

Shift+Alt+up-arrow or
Shift+Alt+right-arrow

Add the next component to the selection.

Shift+Alt+down-arrow or
Shift+Alt+left-arrow

Add the previous component to the selection.

Shift+Alt+Home

Add the first component to the selection.

Shift+Alt+End

Add the last component to the selection.

Selecting Clusters of Components

Clusters are named groups of components on an object. To select them, see Selecting Clusters.



Autodesk Softimage 2011 Subscription Advantage Pack