Creating Raytraced Shadows

Raytracing involves calculating how light rays are reflected, refracted, and obstructed. It gives very realistic results, but it can be a time-consuming process. The more lights used to generate shadows, the longer the scene takes to render.

Creating Regular Raytraced Shadows

1. Select a light and choose Modify > Shader from the Render toolbar.

2. In the light shader’s property editor (soft_light by default), select Shadows Enabled.

3. Set the Umbra value with its slider.

This defines a transparency factor on the umbra (main) area of the shadow (default 0.75). It controls how the shadow blends with the material on which it is cast to create a more realistic shadow.

4. Before rendering, choose Render > Renderer Options from the Render toolbar to open the mental ray Render Options Property Editor for the current render pass.

5. On the Optimization tab, set Primary Rays to Raytracing.

6. On the Shadows tab, choose a rendering method for the Raytraced Type.

7. Select the objects whose shadows you want to cast and display their Visibility property editor. Click the Rendering tab and make sure that both Shadow Caster and Receiver options are enabled. For more information, see Shadow Casters and Receivers.

8. To view raytraced shadows in a render region, draw a region (press Q), choose Render > Regions> Active Viewport Options and select Use Current Pass Options.

Creating Soft Raytraced Shadows

You can tweak the softness of raytraced shadows for the lights in your scene without having to use shadow maps or the more expensive area light shadows.

 

• The default Soft Light shader allows you to set Softness and Samples parameters that apply a quality blur to raytraced shadow edges. See Raytraced Soft Shadows [Shader Reference].

• Alternatively, you can connect the Physical Sun (mia) shader to your lights and use the Shadow Softness and Samples parameters to blur the shadow edges.



Autodesk Softimage 2011 Subscription Advantage Pack