Rendering with Multiple Cameras

Nothing stops you from adding a second, third, or fourth camera to your scene. In fact, there is no limit to the number of cameras you can use to view your scene or render it. You can use multiple cameras to switch between them during a sequence, or to render the pass once from each camera’s point of view in a group of cameras.

No matter what you are trying to achieve, you must define which camera (or group of cameras) a pass will use for rendering. For information, see Setting and Showing the Render Pass Camera [Rendering].

Switching Cameras

Because you can create, edit, and animate as many cameras as you wish, you may need to switch from one camera to another during a sequence. For example, you may want to see your scene with Camera 1 from frames 1 to 80, use Camera 2 from frames 81 to 200, and then return to Camera 1 for frames 201 to 300.

The easiest way to switch cameras in a scene is by using passes. You can create as many passes as you wish from the same original scene. For more information, see Defining Render Passes [Rendering].

The following example can be applied to any Softimage scene. The first camera is the scene’s default camera. For this example, we used a 100-frame scene.

To switch camera views during a sequence

1. Open an explorer and expand the Camera Root. Select the camera and press H to display it (if necessary).

2. From an orthographic (Top, Right, Front) view, zoom out so you can see the camera.

3. Create another camera using the Get > Primitive > Camera > Perspective command on the Render toolbar. Name this camera Cam2.

4. Translate or rotate Cam2 so that it has a different angle than the default camera.

Each render pass has its own set of render options and settings. To switch from one camera to another, we define the default camera as the active camera for the default pass and Cam2 as the active camera for another render pass. Let’s create the second pass.

5. From the Render toolbar, choose Pass > Edit > New Pass > Empty. This creates a new, empty pass based on the existing scene. Notice how it becomes the active pass in the Pass combo box (leave this pass active).

6. In the new pass’s property editor, name the new pass Camera_Pass.

7. Click the lock icon in the corner of the property editor to keep it open.

8. In the explorer, select the Passes scope (press P). You should see both the Default Pass and the Camera_pass listed.

9. Click the icon for the Default pass to open its property editor.

You should now have the Render Options property editors for each render pass side by side.

10. In the Default Pass render options property editor, set the Start and End Frames at 1 and 40, respectively.

11. On the Format tab, make sure the default camera (named camera) is selected in the Output Camera field.

12. In the Camera_Pass render options property editor, set the Start and End Frames to 41 and 100, respectively.

13. On the Format tab, make sure to select the Cam2 camera in the Output Camera field.

You have just specified which camera renders at which frame. Of course, you can create as many passes as you wish to change camera as often as you like.

14. To see the final result, choose Render > Render > All Passes from the Render toolbar. The rendered sequence renders every pass you have defined.

 

You can also use the animation mixer as a way of switching cameras, by using a series of constraints or expressions from your source cameras to a master camera.

If you store the expressions/constraints (as well as any camera parameters you want to maintain) in actions for the mixer, you can sequence/mix as you like.

Creating Multi-Camera Passes

You can render a single pass with multiple cameras. You do this by putting the cameras in a group and setting the grouped cameras as the active camera for the render pass. The pass is rendered from the point of view of each camera in the group. It is important to note that if the render visibility is turned off for a particular camera (in other words, if the camera is hidden) it will not render as a part of the camera group.

1. Add the cameras that you need to your scene and set each of them up to show what you want to render.

2. Open an explorer and set its scope to Scene Root.

3. Expand the root node of each camera you want to put in the group.

4. Select the camera objects only (do not include the camera root nodes or any other part of the camera rig). Use the Ctrl key to add cameras to the selection. For example:

SelectObj "Camera1"
ToggleSelection "Camera2"
ToggleSelection "Camera3"

5. Click the Group button on the main command panel.

6. In the group property editor, name your group something that is easy to identify such as “CamerasGroup”. Leave the other options as default.

7. Open the property editor for the pass that you want to render using the grouped cameras.

8. On the Output tab, select the group of cameras (in this example, the group named “CamerasGroup”) from the Pass Camera menu.

9. Set the Render Channels Output to include the [Camera] token. For example, the file name could be defined with the following template:

[Pass]_[Framebuffer]_[Camera]

The [Camera] token returns the name of each camera being used in the render and uses it in the file name of each rendered frame so that they do not overwrite each other.

10. Render the pass. For this example, the output would be as follows:

Default_Pass_Main_Camera1.[1...5].jpg
Default_Pass_Main_Camera2.[1...5].jpg
Default_Pass_Main_Camera3.[1...5].jpg

 



Autodesk Softimage 2011 Subscription Advantage Pack