Playing Animations or Simulations

The main way of playing back animations or simulations is by dragging the playback cursor on the timeline or by using the playback controls below the timeline. You can also set the time range for playing back, play back in real time, and optimize the playback in different ways.

Before you start playing back, you should set up the time range, the time display format, and the timeline’s start and end frames.

 

On the top, the timeline determines which frames are played back.

On the bottom, the time range determines the global range of available frames, as well as which ones are displayed in the timeline.

Setting the Time Range for Playback

The time range lets you do two things:

• Set the global start and end frames of the scene.

• View and play back a smaller range of these frames in the timeline. For example, if you are working with an animation sequence that is very long, it’s useful to be able to focus on a smaller range of frames for specific tasks.

 

A

Start frame of the scene (Global In value).

B

Time range slider determines which frames are displayed in timeline for playback.

C

End frame of the scene (Global Out value).

To display or hide the time range

• Choose View > Optional Panels > Time Range Slider from the main menu.

The time range appears below the timeline, with the global start and end frames displayed at either of its ends and a time range slider in the middle.

To set the overall time range displayed

Do either of the following:

• Enter values in the Start and End frame boxes at either end of the time range.

or

• Set frames for the Global In/Out parameters in the Play Control property editor (choose Playback > Playback Options in the playback panel).

or

• Set the default preference for the Global In/Out parameters in the Animation Preferences property editor (choose File > Preferences from the main menu).

To change the range of frames displayed in the timeline

Changing the values of the time range slider determines which frames are displayed in the timeline.

• Drag the range slider’s left or right handles (vertical bars) to adjust the length of the frame range (compress or extend the range) displayed in the timeline. Doing this updates the timeline’s start and end frames.

 

• Drag in the middle of the range slider to shift the range of frames displayed in the timeline without changing the range’s length. Doing this updates the timeline’s start and end frames.

 

Setting the Scenes Start and End Frames

Before you play back an animation, you should set the appropriate start and end frames for the scene. These define the range of frames that you can play in the scene.

 

A

Start frame of the scene’s playback (Frame In value).

B

End frame of the scene’s playback (Frame Out value).

To set the scenes playback frames

Do either of the following:

• Set the frame numbers in the Start and End Frame boxes at either end of the timeline.

or

• Set the Frame In and Frame Out values in the Play Control property editor (choose Playback > Playback Options in the playback panel).

These values must be within the range of frames specified for the Global In/Out values (time range) in the same property editor.

Setting the Timeline Display Format

By default, the timeline is set to display frames but you can change this to display other options. When you change these settings, they also affect the timelines found in the animation editor (fcurve editor and the dopesheet) and the animation mixer.

To set the timeline display

1. Choose File > Preferences from the main menu.

2. In the explorer that appears, select Display or click its icon to open the Display property editor.

3. Click the Time Display Format tab and select either of these options:

- Select Display As Frames to do just that.

or

- Select Use Custom Display Format, then select a format from the Display Format list.

 

Playing Back in the Timeline

The timeline is used to display the current playback position of the animation and to manually move between different frames.

The current frame (or time position depending on the format) is indicated by the position of the playback cursor in the timeline, the frame number beside the playback cursor, and in the current frame box in the Playback panel.

The red playback cursor indicates which frame is currently displayed in the viewports. The frame number is displayed beside the cursor as well as in the current frame box beside the playback controls.

• Left-clicking anywhere in the timeline changes to the frame. You can also scrub (drag) the playback cursor back and forth (see Scrubbing the Animation for different scrubbing options) in the timeline.

• Middle-clicking+dragging the playback cursor moves to the selected frames but does not update the scene. The cursor and frame number beside it (and in the current frame box) turn green. To refresh the scene, click the cursor.

By middle-clicking+dragging a frame to another frame, you can copy the current values at this frame to any number of other frames and then set keys. For more information on this, see Keying the Current Values at a Different Frame [Animation].

• Right-clicking in the timeline opens the context menu used for editing keys in the timeline. For more information, see Editing Keys in the Timeline [Animation].

To hide or display the timeline

• Choose View > Optional Panels > Timeline from the main menu to toggle the display of the timeline.

Displaying the Current Frame Number

To display the current frame number in a viewport

1. Click the eye icon in a viewport and choose Visibility Options.

2. On the Stats page, select Show Current Time.

This uses the settings defined in the Output Format Preferences property editor.

 

If you want to capture the animation in your viewport (see Capturing Animation in a Viewport (Flipbook)), this option is useful for having the frame number appear on each captured frame.

Using the Playback Controls

The controls in the Playback panel below the timeline allow you to view and play animations, simulations, and audio in a variety of ways. See the following table for a description of each button:

 

A

Playback menu displays a menu of playback options for doing such things as setting playback preferences, selecting the playback viewport, opening the Playback Options property editor, setting the real-time playback percentage, selecting a playback update mode, and opening the flipbook.

 

Increment Backward moves the currently displayed frame backward by predefined increments (default is 1). You can also:

• Press the Left Arrow key.

• Choose Playback > Previous Frame.

 

Increment Forward moves the currently displayed frame forward by predefined increments (default is 1). You can also:

• Press the Right Arrow key.

• Choose Playback > Next Frame.

 

Start/First Frame displays (resets) the first frame at the beginning of the timeline. You can also:

• Press the Home key.

• Choose Playback > First Frame.

 

Play Backward plays/stops the animation or simulation in the backward direction (to the left on timeline). Note that you can only play simulations backwards if you have cached them.

• Click the Play Backward icon to play from the last frame on the timeline. Click it again to stop playback.

• Middle-click the Play Backward icon to play backward from the current frame.

 

Play Forward plays/stops the animation or simulation in the forward direction (to the right on timeline).

• Click the Play icon to play from the first frame on the timeline. Click it again to stop playback.

• Middle-click the Play icon to play forward from the current frame.

• Press the Up Arrow key to play forward from the current frame.

 

End/Last Frame displays the last frame at the end of the timeline. You can also:

• Press the End key.

• Choose Playback > Last Frame.

 

Loop repeats the animation or simulation in a continuous loop.

You can also choose Playback > Playback Options and select the Loop option in the Play Control property editor.

See Looping the Playback for more information.

 

Audio toggles sound on/off during playback. It is on by default. When the audio is off (muted), the icon appears highlighted.

See Audio and Animation [Nonlinear Animation] for more information.

B

Current frame box displays the current frame. You can also enter a number here to go to that frame.

 

All/RT toggles between playing back frame by frame (All) or in real time (RT).

See Playing Back All Frames or Playing in Real Time for more information.

To stop the playback

• Click or middle-click the Play or Play Backward icon again.

or

• Click any mouse button anywhere in the viewports or timeline.

or

• Press the Down Arrow key.

To execute a script whenever a frame is displayed

• Choose Playback > Playback Options and click the Update tab. Then enter the script name in the Command box.

Looping the Playback

With looping, you can play back the animation in a continuous loop. This can be handy when you want to test out a small area of the animation but don’t want to play back all of it.

There are different ways in which you can loop the animation, depending on how you’re working: you can set up loop markers in the timeline to delimit a range of frames or you can use the Quick Loop mode.

To activate looping

• Click the Loop icon in the Playback panel.

 

or

• Select the Loop option in the Play Control property editor (choose Playback > Playback Options in the playback panel).

Two yellow bars appear at either end of the timeline to indicate the start and end frames of the loop.

 

Setting the Looping Range

To set the loop playback range

• Drag the yellow loop markers at either end of the timeline to set the loop range, or Ctrl+click in the timeline at the frames where you want them.

or

• Set the Loop In and Loop Out values in the Play Control property editor.

By default, the loop in and out frames match the scene’s start and end frames. If the loop range matches the scene’s range and you change the scene’s start or end frame, the loop range automatically updates to match the scene’s new frame range.

Using Quick Loop

To quickly loop a range of frames around the playback cursor

1. Do either of the following:

- Choose Playback > Playback/Audio Preferences from the playback panel at the bottom of the Softimage window.

or

- Choose File > Preferences from the main menu. In the Preferences explorer that opens, select Interaction or click its icon.

2. In the Interaction Preferences property editor, click the Playback and Audio tab and select Enable Quick Loop Mode.

 

3. Set the number of Frames Before/After Cursor. This determines where and for how long you want the loop.

For example, you could set 1 for the Frames Before Cursor and 20 for the Frames After Cursor to loop the 20 frames of audio that occur after the position of the playback cursor in the timeline.

4. Move the playback cursor in the timeline to where you want to loop the animation and hold down the mouse button.

As long as you hold down the mouse button, the animation is looped back around the playback cursor according to the frames you have set for the Quick Loop mode.

5. When you release the mouse button, the looping stops. You can then click anywhere else in the timeline to continue to quickly loop other parts of the animation.

Scrubbing the Animation

Scrubbing means to drag the playback cursor back and forth in timeline. This is something that you need to do frequently as you check the animation in a segment. There are different modes that you can set for scrubbing, as well as the scrubbing playback rate.

To set options for scrubbing

1. Open the Interaction preferences property editor (see above) and click the Playback and Audio tab.

2. Set the options in the Scrubbing area of the tab. See Scrubbing [Properties Reference] for more information on these, which include audio options.

3. Drag the playback cursor in the timeline to scrub the animation using these settings.



Autodesk Softimage 2011 Subscription Advantage Pack