Creating a Filter

You can use a wizard to generate the code for a self-installing plug-in that contains a custom filter. In addition to generating the skeleton code for the plug-in and the filter, the wizard can also generate the code required to add the filter to a menu.

To create a self-installing filter

1. Click File > Plug-ins to open the Plug-in Manager.

 

In the Tools Development Environment layout, click the Plug-ins tab to switch to the Plug-in Manager view.

2. Do one of the following:

- To create the filter in the User location, click File > New > Filter.

- To create the filter in a different location (such as a workgroup or an Add-on directory), expand the location in the Plug-in Tree, right-click the Plugins folder and click New > Filter.

The custom filter wizard appears.

3. In the Name box, type a name for the plug-in.

4. In the File name box, type a valid file name (the extension and path are added automatically by the wizard).

5. From the Coding Language list, select the language you want to generate.

 

6. In the Filter > Name box, you can type a different name for the filter. By default, the plug-in name is used as the name of the filter.

The first character in the user filter name should be a letter. Subsequent characters can be letters, numbers, or underscore (_) characters.

7. From the Filter > Type list, select the type of filter you want to generate. The values in the list correspond to the siFilterType enum.

8. You can also choose to also generate any of the Filter > Optional Callbacks by checking any of these boxes:

- Subset

- IsApplicable

- Init

- Term

9. Click Generate Code.

 



Autodesk Softimage 2011