New Features for Softimage 2012 Subscription Advantage Pack (version 10.5)


Here is a detailed summary of the new features and enhancements available in Autodesk Softimage 2012 Subscription Advantage Pack:



Zoom on Cursor

The Zoom on Cursor preference now affects all navigation tools in all views that support zooming. There is a separate Zoom on Cursor preference for zooming with the mouse wheel. See Camera Preferences (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/property8524.htm).

Scene Elements

Annotation Objects

An annotation object is a text balloon that can be used to communicate messages to colleagues who are working on the same scenes and models. Annotation objects can be selected, transformed, and parented like any other 3D object in the scene, so the balloon can point at specific elements in the viewport. See Annotation Object (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/propref_Annotation_Object.htm).

Selecting

There have been several improvements for component selection:

  • You can Shift+double-click to select loops and ranges (Quick Loop). The Alt key workflow is still supported. See Selecting Ranges and Loops of Components (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/selectionpanel512.htm#WSFD84F4B920FCC144B4046CF6AB9A7198-0054).
  • You can double-click on a polygon to select a polygon island. Press Shift to add to the selection, Ctrl to toggle, and Ctrl+Shift to deselect. Note that Shift+double-clicking is also used to select ranges and loops. If a range or loop selection is possible in the circumstance, it will take precedence.
  • There are new commands on the Select > Select Loops menu. See Modifying Range and Loop Selections (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/selectionpanel512.htm#SECTION_C3A041130CDC4D4AB7B8BE37DDCA9824).
    • Loops From Selection extends the selection as far as possible in both directions. For border edges, it extends across junctions where three edges meet but stops at any other junction.
    • Loops From Selection (around corners) is similar to Loops From Selection, but in the case of border edges it selects the entire border.
    • Grow Loops extends the selection by one component in both directions if possible.
    • Shrink Loops reduces the selection by one component in both directions, until only one component remains. If a closed loop is completely selected, then an arbitrary component is deselected.
  • Select > Select Polygon Outline selects the edges on the outline of the selected polygons. See Selecting Polygon Outlines (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/poly_basic_SelectingPolygonMeshComponents.htm#SECTION_9E84D3C4F17A4FC5AF72C7BA4BDB4F1B).
  • Select > Island From Selection selects all components in the same island as the current selection. See Converting Selections to Islands (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/poly_basic_SelectingPolygonMeshComponents.htm#SECTION_867BF3C3428D4F00B337D020A587B17B).
  • Using the Rectangle tool and clicking without dragging selects the closest element. This was always the case for objects, but now it works for components as well. You must click and drag to select all elements under the pointer.
  • You can access the Selection Preferences from the Select menu. In addition, the Surround Edges, Surround Polygons, and Raycast in Shaded Mode options are all available as toggles directly on the menu.
  • The Include Backfacing Polygons preference is on by default.

Snapping

The Show Snap Targets preference toggles the display of points and other targets for snapping. See Snapping Preferences (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/property8501.htm).

Crosswalk

The FBX plug-in for Softimage uses version 2012.2 if the FBXSDK.

Polygon Modeling

Extrude Along Normal

The Extrude Normal operator extrudes, duplicates, and insets components while retaining proper mitering at corners. See Copying Components Along Their Normals (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/polys_ExtrudingDuplicatingandInsettingPolygonMeshComponents.htm#SECTION_5A14EF55E9F945478C62A2588868EFF0).

Image:GUID-052186FF-CAA8-482F-B8B1-BE47E0E4F30A-low.png

Apply Thickness

The Apply Thickness compound solidifies polygon mesh objects by adding thickness, similar to the Shell modifier in 3ds Max. See Apply Thickness (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Apply_Thickness.htm).

Image:GUID-0B40ABFE-B332-46DE-A69D-9E2ED63ECA2A-low.png

Spin Edges

Modify > Poly. Mesh > Spin Edges "rotates" edges by cycling their endpoints around the vertices of their two adjacent polygons. See SpinEdge Op (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/topomod_SpinEdge.htm).

Image:GUID-0EDA9D5D-F787-4029-B688-20F861AA92C2-low.png


Preserve Mesh Curvature

  • The Add Smooth Edge Loop tool (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/polys_AddingandEditingPolygonMeshComponents.htm#SECTION_A46E5483DF504E26A21ABDE878A23E1B) splits parallel edges across quad topology while preserving the original surface curvature continuity.
  • The SplitEdge (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/property8019.htm) and SubdivideEdge (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/property8002.htm) operators have options for Curvature Continuity.
Original object
Enlarge
Original object
Curvature Continuity = 1.0
Enlarge
Curvature Continuity = 1.0
Curvature Continuity = 0.0
Enlarge
Curvature Continuity = 0.0


Apply Slice Between Two Vertices

The Apply Slice Between Two Vertices compound adds a range of edges intersecting all other edges between two points on a polygon mesh. See Apply Slice Between Two Vertices (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Apply_Slice_Between_Two_Vertices.htm).

Image:GUID-6E6EE84C-CC19-4361-86B3-0FFA81760B41-low.png Image:GUID-FB623758-01EF-485E-9FF3-80CB79C388E1-low.png

Cap Hole

The Cap Hole compound fills a hole in a polygon mesh. See Cap Hole (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Cap_Hole.htm).

Animation

  • The new Include Animation Layers option in the Store Action dialog box allows you to bake animation layers into the base layer's animation when you store an action. See Collapsing or Storing the Animation Layers (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/animlayers_CollapsingtheAnimationLayers.htm) for more information.
  • The new Highlight Active Viewport and Timeline preference inAnimation Preferences (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/userprefs512.htm) lets you set a highlight around the active viewport and the timeline when autokey is on. You can also select the highlight color.

Image:GUID-A47C2085-404E-49D8-AE63-EA9019FBDE20-low.png

Character Animation

New Models

There are some new faces on the block! New polygon mesh character envelopes with predefined UVs are available in the Get > Primitive > Model menu: Mesh - Bull, Car, Fish, Horse, Lizard, Male, and T.rex.

Image:GUID-339215ED-9D4F-48D2-8D9B-6C1A3FBE84AC-low.png


Envelopes

There is a new option in the Brush Properties (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/property3507.htm) to turn off normalization when painting weights. It is also linked to the existing Normalize option in the weight paint panel. You can temporarily turn this off to remove some weight from an existing deformer in order to add weight for a new one.

ICE Basics

Compounds

  • You can define layouts groups for exposed input ports using the interface. See Grouping Ports in the Layout (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/ICE_compounds_ManagingExposedPorts.htm#SECTION_4C3F18DE8BA548FDB44E9AF5885C9D36).
  • You can define callbacks that get executed automatically when users open and interact with the compound's property page. See PPG Logic (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/ICE_compounds_SettingCompoundProperties.htm#SECTION_A98CF1DAA9E04C398D8A9B7C5B39EA83).
  • Randomize Around Value (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Randomize_Around_Value.htm) now works properly with non-scalar values and arrays.

Attributes

You can now set data on the EdgeCrease attribute.

ICE Simulation

  • The Particles > Create > Rigid Bodies command on the ICE toolbar now uses the Simulate Bullet Rigid Bodes node instead of the Simulate Rigid Bodies node.
  • ICE Simulation Subframe Sampling (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/GUID-04F54DC8-7FB3-4034-B563-53412C86908-929.htm) is now supported for both the Simulate Rigid Bodies and Simulate Bullet Rigid Bodies nodes.
  • There is now documentation for the Init Timers (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Init_Timers.htm) compound - see Setting Particle Timers (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/ICE_behavior_SettingParticleTimers.htm) for information on how to use it.

Bullet Physics for ICE Rigid Bodies

The Bullet physics engine (v2.78) has been integrated into ICE as the Simulate Bullet Rigid Bodies (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/GUID-0AE21DEF-E2CA-4D7A-8ABF-9AD0F9E8A34-2289.htm) node.

Image:GUID-15DD2AFA-4756-44B4-8A73-D5C79F20B3D0-low.png

This node is similar to the existing Simulate Rigid Bodies node (which uses the PhysX dynamics engine) except for the following:

  • You can use the actual shape of an obstacle object for its collision geometry - see Collision Geometry for Rigid Body Obstacles (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/ipart_rigidbody_CollisionGeometryforRigidBodyParticlesandObstacles.htm#GUID-58E576FA-8266-4DEA-9EE6-003E8A0D98C1)
  • You can use convex hull approximations of a particle's instanced shape's geometry as the collision geometry. You can also use a bounding box shape for quicker but less accurate collisions. See Collision Geometry for Instanced Shapes (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/ipart_rigidbody_CollisionGeometryforRigidBodyParticlesandObstacles.htm#GUID-F2D8D3A0-98F8-4728-93F0-07831091A75A).
  • A bounding cone shape is used on particles set with the Cone shape (bounding capsules are used for cones with the Simulate Rigid Bodies node) - see Collision Geometry for Basic Particle Shapes (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/ipart_rigidbody_CollisionGeometryforRigidBodyParticlesandObstacles.htm#GUID-A17EA0A7-04DF-4426-A3BE-7C61DD675222).
  • If Bullet detects a valid CUDA™-enabled GPU in your system, GPU acceleration is used for the broadphase collision detection process. This is available on Windows only. CUDA (Compute Unified Device Architecture) is NVIDIA's parallel computing architecture.
  • Static and dynamic friction are not recognized separately by Bullet: it combines the two to support just one friction value (Static Friction) - see Setting the Elasticity and Friction (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/ICE_rigidbody_SettingtheElasticityandFriction.htm).
  • The Elasticity value for collision objects can be higher than 1: it is not clamped to 1 as it is in the Simulate Rigid Bodies node. Values higher than 1 will create energy upon collision, which is an effect that you may or may not want. High values can sometimes create instabilities in the simulation.
  • Springs and dampers are not supported by Bullet.

ICE Modeling

Compounds

  • Create Extrusion Along Strands (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Create_Extrusion_Along_Strands.htm) has been updated with new options.
  • The new Deform Strand Extrusion (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Deform_Strand_Extrusion.htm) compound lets you use Create Extrusion Along Strands in one tree to create the geometry, and deform it in another tree. See Creating an Extrusion Along Strands (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/GUID-5E5E40D7-56D5-495B-BF7B-41EA8296633-1030.htm#SECTION_6B3B2A3D50254D4889D4FBBDCEFEA21A).
  • The default Transform Mode for Get Topology (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Get_Topology.htm) is now No Transform.
  • Merge Polygon Meshes (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Merge_Polygon_Meshes.htm) now has a Transform Mode option.
  • Apply Thickness (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Apply_Thickness.htm), Apply Slice Between Two Vertices (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Apply_Slice_Between_Two_Vertices.htm), and Cap Hole (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/iceref_Cap_Hole.htm) features are implemented with ICE compounds.

Sample Scenes

There are additional sample scenes with simple examples of ICE modeling in the XSI_SAMPLES\ICE directory:

  • Modeling_Building_Grids
  • Modeling_Materials
  • Modeling_Texture_Projection
  • Modeling_Cylinder
  • Modeling_Simple_Copy_Merge

Shaders

The transform port (Texture SRT parameter) of the Edit UV (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/shaderpresets188.htm) shader can now be driven by connections in the render tree.

Customization & SDK

Softimage 2012 Subscription Advantage Pack introduces a new set of commands, classes, methods and types to help developers use the SDK more conveniently and more efficiently. This page lists these new items.

New Commands

The following commands are added to this version of SoftImage:

  • CreateUserMotion (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/CreateUserMotion.html) - Creates a user motion property. User motions are used to control motion vectors on vertices of an object's geometry.
  • EditICECompoundPPGLogic (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/EditICECompoundPPGLogic.html) - Edits the ICE compound PPG Logic with a modal text editor.
  • EditICECompoundProperties (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/EditICECompoundProperties.html) - Modifies the properties of an ICE Compound, such as the version number, the description, the Category or Task (and therefore its location), the construction mode, etc.
  • GetICECompoundPortProperties (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/GetICECompoundPortProperties.html) - Returns an ICE compound port's properties.
  • GetICECompoundProperties (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/GetICECompoundProperties.html) - Returns an ICE compound's properties.
  • SpinEdgeBackward (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/SpinEdgeBackward.html) - Reorients the selected edges between the adjacent polygons.
  • SpinEdgeForward (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/SpinEdgeForward.html) - Reorients the selected edges between the adjacent polygons
  • SelectAllComponentLoops (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/SelectAllComponentLoops.html) - Extends an existing component selection to include component loops.
  • GrowSelectedLoops (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/GrowSelectedLoops.html) - Grows loops from the selected components.
  • ShrinkSelectedLoops (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/ShrinkSelectedLoops.html) - Shrinks selected component loops.
  • SelectPolygonOutline (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/SelectPolygonOutline.html) - Selects boundary edges on selected polygons.
  • SelectAllConnectedComponents (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/SelectAllConnectedComponents.html) - Selects an island from selected components.
  • ApplyThickness (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/ApplyThickness.html) - Applies thickness to a polygon mesh surface.
  • CapHole (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/CapHole.html) - Cap a hole on a polygon mesh.
  • ApplySliceBetweenTwoVertices (http://download.autodesk.com/global/docs/softimage2012/en_us/si_cmds/ApplySliceBetweenTwoVertices.html) - Apply a slice from one vertex to another.

New Classes (Object Model, C++)

The following classes are added to this version of SDK:

  • Annotation - The Annotation object is a specialized X3DObject used for inserting text annotation in a scene.
  • MemoCamera - The MemoCamera class represents a memo camera control in a view.
  • MemoCameraCollection - A collection of MemoCamera objects.

New Methods (C++)

The following C++ methods are introduced in Softimage 2012 Subscription Advantage Pack SDK:

  • CValue::operator > - The new 'greater than' operators in the C++ CValue class.
  • CValue::operator < - The new 'smaller than' operators in the C++ CValue class.
  • CValue::operator >= - The new 'greater than / equal' operators in the C++ CValue class.
  • CValue::operator <= - The new 'smaller than / equal' operators in the C++ CValue class.
  • Envelope.SetDeformerWeights2 - Sets the envelope weights for a given deformer without normalizing the weights.
  • View.GetMemoCameras - Returns an array of MemoCamera objects for a view.
  • HardwareShaderContext.GetDirtyParameters - Returns the parameters from the render tree which values have changed since the last shader evaluation.

New Methods (Object Model)

The following method is added to the SDK:

  • View.MemoCameras - Returns a collection of MemoCamera objects for a view.

New Types

The following three types are introduced in Softimage 2012 Subscription Advantage Pack for the first time:

  • siAnnotationImportance - Sets the importance of an annotation message.
  • siHWShaderForceAttributeUpdate - Boolean attribute used by hardware shaders to force a call to the GetAttributeList callback when a shader parameter is updated or a shader port is connected or disconnected in the render tree.
  • siHWShaderDirtyParameterUpdate - Boolean attribute used by hardware shaders to get the latest parameter updates from the render tree.

This page was last modified 19:16, 21 Mar 2012.
This page has been accessed 4608 times.

© Copyright 2009 Autodesk Inc. All Rights Reserved. Privacy Policy | Legal Notices and Trademarks | Report Piracy