New Features for Softimage 2013 (version 11.0)


Here is a detailed summary of the new features and enhancements available in Autodesk Softimage 2013:



Interface and Tools

License Time-out

Check Interval value in your General Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/prefref_general.htm) controls the interval in minutes between checks for the license time-out feature. If Softimage has been completely idle since the last check, it temporarily stops communicating with the license server. When activity resumes, Softimage starts communicating again.

If there has been no communication for a certain period of time (configured on the server), the server reclaims the license and makes it available for other users.

If the license has been lost when activity resumes, Softimage attempts to get another license from the server. If none are available, you are given an opportunity to save your work before exiting.

Softimage is not considered idle if there been any mouse or keyboard interaction, command or script running, or progress bar during the last check interval. Softimage is never idle in batch mode.

To disable the license time-out feature, set this value to 0.


Suites Interaction Modes

If your version of Softimage is part of an Autodesk suite, you can set the interaction mode for other components of the suite from within Softimage. See The First Time You Start Softimage (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/si3dmain3.htm).

3ds Max Interaction Mode

There is a new interaction mode for keyboard and mouse compatibility with 3ds Max. This includes an improved 3ds Max-compatible key map, as well as the middle mouse button to navigate in various views. Alt+left-mouse-button is used for many functions that use the middle mouse button in Softimage mode. See The First Time You Start Softimage (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/si3dmain3.htm).


Camera Navigation

There is a new preference: Use Middle Mouse Button for View Navigation like 3ds Max. When on, you can:

  • Middle-click and drag to pan or track.
  • Alt+middle-click and drag to orbit (3D views only).
  • Ctrl+Alt+middle-click and drag to zoom.

See Camera Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/property8524.htm).


Maya-compatible Key Map

The Maya-compatible key map has been improved with a few new keys.


Modifying the Transform Pivot

There's a new way to modify the transform pivot: with a transform tool active, right-click and choose one of the options Edit Pivot, Lock Pivot, or Reset Pivot. This technique may be more convenient if your Alt key is mapped to a different function.


Match Transforms

The Match commands on the Transform panel now work even when there are keys on an object's transformations.

Viewing and Playback

High Quality Viewport

High Quality display mode gives a close approximation of the final rendered image in the viewport, including soft shadows, bump and normal maps, light attenuation, environment, procedural textures, and more.

It works by compiling MetaSL code into CgFX instructions on-the-fly at runtime. It works with all the MetaSL shaders, as well as with many of the standard Softimage shaders for mental ray whose shader definitions have been adapted to support it. If a shader is not supported in High Quality display mode, it is ignored along with any shaders connected into it.

For more information, see Configuring the High Quality View (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-0FDB9324-E19C-49E0-9780-6B0429DA29A8.htm). In addition, be sure to take a look at the new HQV sample scene in the XSI_SAMPLES project.

Image:GUID-020A0BFF-C292-4547-B54B-5CDF2619ACFC-low.png

Activating High Quality Mode

  1. Make sure that Enable is checked in the High Quality Viewport Options on the General tab of your Display Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/userprefs522.htm), and that Shader Profile is set correctly for your graphics card and driver.
  2. Choose High Quality from the Display Mode menu of a viewport.
    Image:GUID-89DCD810-71CB-4C7C-97D6-734213DA5E3C-low.png
  3. Use the options on the High Quality (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/property1501.htm#SECTION_D6C2E2D0EB5E4199B48428CB3107A52F) tab of the viewport's Camera Display properties (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/property1501.htm) to adjust anti-aliasing, dithering, shadows, screen-space ambient occlusion, and depth of field.

Option to Start New Scenes with Maximized Viewport

There is a new option to show the camera view (viewport B) maximized when you start a new scene. See Start with maximized Viewport B when New Scene in Display Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/userprefs522.htm).

Viewport Capture

There is a new option in the Capture Viewport dialog box (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/flip26.htm): Return to Current Frame When Done returns to the current frame once capturing is complete. If this option is off, the current frame after capturing will be either the last frame of the captured sequence or the frame on which the capture process was stopped.

Two Sided Lighting

The Two Sided Lighting option on the Performance tab of viewports' Camera Display properties (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/property1501.htm) does not illuminate surfaces that are back-facing to light sources in shaded display modes. This option might not be supported depending on the shader profile of your graphics card and driver.


Transparency in Viewports

The transparency of an object in a viewport is now affected by its illumination shader's Transparency Scale value, in addition to its Transparency Mix color as before.

SSS Shaders in Viewports

Objects with SSS shaders now give a better indication of their surface color in shaded viewport display modes. The surface color is now a blend of the diffuse and epidermal colors, or a blend of diffuse with white if the epidermal color is textured, instead of the default gray.


Spot Light Manipulators

The cone manipulators for spot lights (B key) are now displayed in OpenGL realtime shader mode.


Hiding Elements

Groups, scene layers, and render pass partitions now display the letter H overlayed on their icons in the explorer when they are set to hide their members.

Data Management

Color Management

You can now apply gamma correction to the Fx Viewer using the FX Viewers setting on the Color Management (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/userprefs522.htm#WSC52E97AF964D6E4A85D54D15483CB299-002F) tab of the your Display Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/userprefs522.htm). The Lookup Table option in the Softimage|FX Viewer Settings Dialog Box (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/compositor11.htm) has been renamed to Override Color Management Preference.

FBX Import and Export

There are a number of updates to the FBX plug-in for Softimage.

  • It uses version 2013 of the FBXSDK.
  • There is a new import option. You can uncheck Materials and Textures to use the scene's default material.
  • There are a number of performance improvements.
  • User normals are properly supported when the topology changes.
  • FBX files with objects in multiple namespaces are supported.
  • On export, ICE-based materials, including Materials (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-503134A6-AC8D-4601-BEFF-8E492425244E.htm), MaterialID (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-73361AAF-5BFF-4E54-94F4-2081138B018C.htm), and attributes used as texture projections, are converted to cluster-based materials with explicit UVs.
  • The way that user normals are imported has changed to be more consistent with other Autodesk software:
    • If there is shape animation, and no hard edges or smoothing groups, then user normals are converted to hard edges.
    • If there are both shape animation and hard edges or smoothing groups, then user normals are discarded.

For more information, see Importing and Exporting FBX Files (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/import_export_xwalk4xsi_ImportingandExportingFBXFiles.htm).

Crosswalk

Softimage 2013 ships with Crosswalk 2013. This version of Crosswalk features various fixes and improvements.


Referenced Models

There have been a variety of fixes and improvements for referenced models. In particular, using expressions, linked parameters, and constraints with referenced models has been improved.

Modeling

GATOR Improvements

When transferring attributes with GATOR:

  • You can now select objects, points, edges, polygons, or clusters as the target. Previously, you could select only objects, polygons, and polygon clusters.
  • You can now use multiple GATOR operators to transfer envelopes from multiple objects. Each GATOR operator adds a separate envelope operator. Previously, you needed to use a single GATOR operator to transfer envelopes from all sources at once.
  • There is a new Envelope checkbox to disable the transfer of envelopes when the corresponding Transfer button is pressed.

Together, these changes make it easier to transfer envelopes from different objects to different areas of a single geometry.

Merging or Blending Polygon Meshes

When merging or blending polygon meshes, you can now transfer all clusters even if they don't have any properties (like local materials, weight maps, vertex colors, etc.).


Splitting Edges

The Split Edge tool has been improved to make it easier to split edges close to existing vertices. If you still have difficulty, try zooming the view.

Animation and Rigging

Drawing Implicit Bone Chains

You can now draw implicit bone chains using the Create Image:ac_menuaro.gif Skeleton Image:ac_menuaro.gif Draw Bones command from either the Model or Animate toolbar.

In previous versions, you could only get the implicit bone primitive from the Get Image:ac_menuaro.gif Primitive Image:ac_menuaro.gif Implicit Image:ac_menuaro.gif Bone command.

Many of the usual IK skeleton chain features apply to implicit bone chains, such as applying an envelope, using the Move Joint tool, duplicating the chain in symmetry, icon and shadow icon display, snapping, and using the bone selection filters.

See Drawing Implicit Bone Chains (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/skel_CreatingChains.htm#GUID-F636FC62-28D4-429E-8095-222B45EC82F6) for more information.

Retime Keys Tool for Fcurves

The new Retime Keys tool in the fcurve editor lets you easily retime animation directly on the fcurves. You create retime markers to mark any segment of the fcurves you want to retime, then drag the retime markers to squash, stretch, or shift the animation as you like.

Choose Edit Image:ac_menuaro.gif Transformation Tools Image:ac_menuaro.gif Retime Keys Tool or click the Retime Keys icon on the fcurve editor toolbar to activate the Retime Keys tool.

Image:GUID-1945AB9B-1EE6-496F-8030-1BDD4CEFAE7D-low.png

See Retiming Animation on Function Curves (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-8A7854B9-B257-4B02-806A-57BC1EF5BCFB.htm).

Image:GUID-53869199-3C94-4CB1-A269-565A3D9BB68D-low.png

Fcurve Editor Classic Mode

Classic mode is now the default mode for the fcurve editor.

To switch between Class and Suite modes, do any of the following:

  • Toggle the View Image:ac_menuaro.gif Classic Mode command from the fcurve editor toolbar.
  • Right-click in the fcurve graph area and toggle the View Image:ac_menuaro.gif Classic Mode option (if you're in Classic mode).
  • Open the Fcurve Editor Preferences property editor and toggle the Classic Mode option on the Editor tab.

Note: The profile curve editor (see The Profile Curve Editor (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/fcurves_TheProfileCurveEditor.htm)) is available only in Classic Mode.

Fcurve Editor Menu Command Changes

The fcurve editor has experienced some menu command name changes to make it more compatible with the fcurve editors in the other Autodesk 3D applications. Here's a brief summary:

  • The new Edit Image:ac_menuaro.gif Transformation menu now contains these commands:
    • Move Keys Tool (previously named Move Key Tool)
    • Region Keys Tool (previously named Region Tool)
    • Scale Keys Tool (previously named Stretch with Pivot Tool)
  • The Edit Image:ac_menuaro.gif Save Buffer command is now Curves Image:ac_menuaro.gif Buffer Curve Snapshot
  • The Edit Image:ac_menuaro.gif Swap Buffer command is now Curves Image:ac_menuaro.gif Swap Buffer Curve Snapshot
  • The Edit Image:ac_menuaro.gif Interactive Update command is now View Image:ac_menuaro.gif Interactive Update
  • The new Select menu contains all the Select and Deselect commands that were in the Edit menu.
  • The new Select Image:ac_menuaro.gif Navigate menu contains all navigation commands that were in the Edit menu.
  • The View Image:ac_menuaro.gif Auto Frame Curves command is now View Image:ac_menuaro.gif Frame Image:ac_menuaro.gif Auto Frame
  • The View Image:ac_menuaro.gif Frame Image:ac_menuaro.gif All Curves command is now named Frame All
  • The View Image:ac_menuaro.gif Frame Image:ac_menuaro.gif Selection command is now named Frame Selection
  • The View Image:ac_menuaro.gif Frame Image:ac_menuaro.gif Timeline command is now named Frame Playback Range
  • The View Image:ac_menuaro.gif Frame Image:ac_menuaro.gif Selected Keys command is now named Frame Selected Keys
  • The View Image:ac_menuaro.gif Frame Image:ac_menuaro.gif Selected Curves command is now named Frame Selected Curves
  • The View Image:ac_menuaro.gif Frame Image:ac_menuaro.gif Region command is now named Frame Region
  • The Curves Image:ac_menuaro.gif Resample command is now named Resample Curve
  • The Curves Image:ac_menuaro.gif Fit command is now named Simplify Curve
  • The Curves Image:ac_menuaro.gif Make Rotations Continuous command is now named Euler Filter
  • The Curves Image:ac_menuaro.gif Relative Cycle command is now Curves Image:ac_menuaro.gif Pre/Post Extrapolation Image:ac_menuaro.gif Cycle with Offset
  • The Curves Image:ac_menuaro.gif Gradient Extrapolation command is now Curves Image:ac_menuaro.gif Pre/Post Extrapolation Image:ac_menuaro.gif Linear
  • The Curves Image:ac_menuaro.gif Cycle, Curves Image:ac_menuaro.gif Freeze Cycle, and Curves Image:ac_menuaro.gif Constant commands are now in the Curves Image:ac_menuaro.gif Pre/Post Extrapolation menu.

Animation Editor Preference

The new Disable Auto Switch option in the Animation Editor Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/animeditor1.htm) prevents the animation editor from automatically switching to the expression, scripted operator, or fcurve editor based on the type of animation that's on the selected element.


Animation Mixer Updates

  • You can now drag and rectangle-select multiple clips using the default Select tool (press the space bar). Previously, you could do this only with the Rectangle Select tool. See Working with Clips (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/animmixer_WorkingwithClips.htm)
  • You can now change the order of the tracks by dragging and dropping them where you want - see Working with Tracks (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/animmixer_WorkingwithTracks.htm).
  • You can now drag multiple .preset, .xsi, or .eani action files at once from a file browser and drop them onto animation tracks in the mixer. The clips are created in the order that you selected the files, and follow each other consecutively on the track:
    • To load .preset action files, see Loading Action Source Presets (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/actions_CreatingActionSourcePresets.htm#WSA3B2924969ED704E813291282A376B72-013E).
    • To load or .xsi or .eani action files, see Importing Action Sources Files (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/actions_ImportingandExportingActionSources.htm#WSA3B2924969ED704E813291282A376B72-0152).
  • You can now change the color of any type of clip in the mixer - see Working with Clips (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/animmixer_WorkingwithClips.htm).

Image:GUID-C460AA6D-CC15-4EB3-820C-AC8F52E7E162-low.png

ICE Fundamentals


Navigating ICE Trees

You can quickly pan by clicking and dragging on the background of the view with the middle mouse button. Middle-clicking on a node still branch-selects.


Editing Compounds

  • You can now press I to edit the selected compound, and U to exit. In addition, the icon to exit a compound has changed to an up arrow and is now a little bigger.
  • The ICE tree editor remembers the last view when you enter and exit compounds.


Hiding Port Values in the Viewports

It's now easier to hide port values, even if you can't find the connection in the tree. For more information about displaying port values in general, see Displaying Port Values (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/ICE_trees_DebuggingICETrees.htm#WSB74EE070EB80114199F4C921243896F3-0092)


To hide all values in the current view

To hide all values shown for the current tree, or the current compound and its sub-compounds, do one of the following:

  • Choose Show Image:ac_menuaro.gif Hide All Port Values.
  • Right-click in the background of the ICE tree view, and choose Hide All Port Values.


To hide all values for the selected compounds

To hide all values shown for the selected compounds:

  • Choose Show Image:ac_menuaro.gif Hide Port Values for Selected Node(s).
  • Right-click in the background of the ICE tree view, and choose Hide Port Values for Selected Node(s).


To toggle port value display for a connection

You can now middle-click on a connection to quickly toggle the display of port values.

Get Action Source at Frame

The new Get Action Source at Frame node returns the value at a specific frame of an item stored in an animation source. This is especially useful for crowd simulations, but can be used with any animation data stored in a source. See Get Action Source at Frame (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/iceref_GetActionSourceAtFrame.htm).


Build Linearly Interpolated Array

The Build Linearly Interpolated Array compound has a new Valid output port. The Valid port returns false when Size is 1. In this case, the Result is halfway between Start and End.


Miscellaneous Changes and Fixes

  • When displaying port values, the arrowheads on vectors now scale.
  • Comment and Group Comment nodes can be copied and pasted.
  • The collapsed or exposed state of port layout groups is saved when you export a compound, and used by default when you create a new instance.
  • The File Path Sequence node has a browse button for the file name, as well as the folder.
  • The default number of Substeps in the Lagoa Setup Cloth Mesh compound has been increased to 4 to give better initial results.



ICE Modeling


Clone Topo Node

TheClone Topo (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/iceref_Clone_Topo.htm) node creates multiple copies of the input topology. No transformation is applied so all copies are superimposed. However, later in the ICE tree you can distinguish between components on different copies and apply different transforms by using Modulo (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/iceref_Modulo.htm) on the component indices, as done in Create Copies from Polygon Mesh (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/iceref_Create_Copies_from_Polygon_Mesh.htm).


Build Array from Set

The Build Array from Set node now supports location and topology-type attributes.


Set Materials from Library

The Set Materials from Library compound now stores the entire material name including the path.


Performance

The performance of many of the ICE modeling nodes and compounds has been improved.

ICE CrowdFX

What is CrowdFX? It's a dedicated environment for building sophisticated crowd simulations in Softimage. CrowdFX is designed for pedestrian and stadium type simulations that require a plane on which the actors move or stand. As such, it's not designed for flocking or schooling movements that can happen on any plane in 3D space, such as with flying or swimming.

Built on ICE, you can create complex effects with large numbers of characters that react intelligently to their environment and each other. And because it's ICE, you can use all the standard ICE nodes and compounds to customize the simulation as you like, in addition to using the special CrowdFX ICE nodes and compounds.

Image:GUID-F0550A3F-3014-443C-857F-CDBD4EA6C23B-low.png

CrowdFX is basically a point cloud-based ICE simulation. You choose one or more characters whose envelope geometries are instanced on each particle in the simulated point cloud. Although similar in some ways to regular ICE particle instances, CrowdFX is different because you can blend each character's animation sources in the simulation. You can even constrain parts of the character's rig to modify the animation within the simulation.

CrowdFX also allows you to modify the behavior of the actors to simulate intelligent collision avoidance with other actors, as well as obstacles (called walls). You can also make the actors move toward goals that you create, or follow a path.

While you might think that you can use only bipeds as the characters in a crowd, CrowdFX is designed for any type of rigged enveloped mesh in a model that has action sources. This can be a biped, quadruped, or any type of organism or object that you want to exhibit crowd behavior. Its rig can have any type of hierarchy made up of either nulls or bones, and have a polygon mesh assigned as its envelope. You can also import FBX files from other 3D programs to use as a model. Once a character is in CrowdFX, it's known as an actor.

One of the things that you usually want in a crowd is variation. You can do this in any number of ways in CrowdFX, from different source characters you use in the simulation to modifying the envelope geometry with different shape keys, using different materials and textures, or randomly changing the actor's size in the simulation.

Once you've finished a crowd simulation, you can export it in the familiar FBX format to send to Autodesk Maya and other 3D programs that can import FBX.

For more information about using CrowdFX, see ICE CrowdFX (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-D9626F65-5A99-4128-A38F-86B0637FF5E4.htm). For descriptions of the new CrowdFX compounds, see Task Tab - Crowds (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-671407CD-F1FE-49FD-8EAF-B70090ED323C.htm).


Quick Start on Creating a Crowd

You can quickly start creating crowd simulations for learning and testing by doing these two steps:

  1. Choose the CrowdFX Image:ac_menuaro.gif Actors Image:ac_menuaro.gif Get Actor Image:ac_menuaro.gif Default Pedestrian command on the ICE toolbar.This loads a low-resolution polygon mesh rigged character with several actions already set up for you to use.
  2. Choose the CrowdFX Image:ac_menuaro.gif Simulation Image:ac_menuaro.gif Create Image:ac_menuaro.gif Pedestrian or Stadium command to create the simulation using a default particle emitter.

Then follow the steps in Overview of the CrowdFX Workflow (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-BCEA193F-FF5D-45BA-8F6D-68AA6C41AF5B.htm) to get a sense of the different elements that are involved in creating a CrowdFX simulation.

Image:GUID-01E0524C-EBB6-4366-ABBF-486C462505E2-low.png

Loading the CrowdFX Sample Scenes

When you're ready to start exploring what can be done with CrowdFX, or need a good base for your own crowd simulation, check out the sample scenes that are shipped with Softimage.

Load a sample scene from the \Data\XSI_Samples\Scenes\ICE folder in your Softimage installation directory. All CrowdFX scenes have a CrowdFX_ prefix.

You can quickly open this folder by choosing User Tools Image:ac_menuaro.gif Browse Examples from the toolbar in the ICE Tree view.

Image:GUID-5349847B-1C94-4C67-A442-A20D96BA520B-low.png

Materials and Shaders


MetaSL Shaders

Softimage ships with many sample MetaSL shaders from NVIDIA. There are a wide range of shaders from high-level phenomena such as thin glass, to low-level nodes for building custom shading trees. They can be found in the MetaSL category of the preset manager.


New Shaders

The following shaders are now available in Softimage:

  • mental ray > Texture > mia_exposure_photographic_rev
  • mental ray > Material > misss_fast_shader2
  • mental ray > Material > misss_fast_shader2_x
  • mental ray > Material > misss_mia_skin2_surface_phen
  • mental ray > Material > misss_set_normal
  • mental ray > Lightmap > misss_lightmap_phen
  • mental ray > Material Phenomena > misss_mia_skin2_phen
  • mental ray > Material Phenomena > misss_mia_skin2_phen_d
  • Realtime > OpenGL > GLSL Actor Envelope (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/XSIRTCOMPOUND_GLSL_Actor_Envelope.htm) shader compound
  • Realtime > HLSL > ultimap preview
  • Realtime > CgFX > ultimap preview
  • Realtime > CgFX > mix_4_layers

For information on the mental ray shaders, see the mental ray Documentation at www.autodesk.com/mentalray-help-2013-enu.


Procedural Textures

The Cell, Fabric, Flagstone, Marble, Rock, Snow, Terrain, and Wood procedural texture shaders have a new Type option:

  • Legacy produces the same pattern as in versions prior to Softimage 2013.
  • Default produces the same pattern as shown in High Quality (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-0FDB9324-E19C-49E0-9780-6B0429DA29A8.htm) display mode.


Cubic Mapping 6

The Cubic Mapping 6 (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/shaderpresets660.htm) shader has a new option Invert YZ to match the Softimage scene's global reference frame (Y-up instead of Z-up).


Environment Shader

The Transformation parameter of the Environment (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/shaderpresets732.htm) shader is now texturable, so it can be driven by a connection such as from a Create Transform (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/SIUtilityShaders_CreateTransform.htm) shader.


Navigating Render Trees

You can quickly pan by clicking and dragging on the background of the view with the middle mouse button. Middle-clicking on a node still branch-selects.


Automatically Deleting Unused Nodes in the Render Tree

There is a new option Automatically Delete Unused Nodes on Refresh in the Render Tree Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/rendertree502.htm) that automatically deletes unconnected shaders whenever you refresh or close the render tree.


Texture Editor

There are a number of modifications to the texture editor:

  • The texture editor preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/uved9.htm) are now available from File Image:ac_menuaro.gif Preferences in the main Softimage window, as well as from File Image:ac_menuaro.gif Preferences in the texture editor itself.
  • The options on the Snap have been added to the texture editor preferences.
  • Snapping to sample points is on by default.

Updating Multiple Shader Files

The Shader Code Editor has a new Update All button to update all open shader files at once.

Rendering


Partial Frames

When specifying a frame set to render, you can now specify partial frames. For example, to render at a time 20% of the frame length from frame 7 to 8:

7.2

See Render Pass Property Editor (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/property4501.htm)

There is also a corresponding file name template token. When rendering partial frames, you should use the [PartialFrame] token in the file name template because the [Frame] token gets rounded to the nearest integer. See Tokens and Templates (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/rendering_props_OutputPathTemplates.htm).

Render Region Refreshing

There are now three possible settings to control when the render region refreshes: Interactive (the old Auto-Refresh = on), Camera, Time, and Region State (the old Auto-Refresh = off), and the new Manual mode. In Manual mode, render regions never refresh automatically and you must always refresh manually.


Other Render Region Preferences

The render region preferences have moved to their own Region (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/userprefs514.htm#SECTION_7A5B5FBB7DB247CA9F0315277A62DE5C) tab in the Rendering Preferences (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/userprefs514.htm). There are several new options: Draw Tile Borders, Clear Rendered Image on Interaction, and custom colors for various interface elements.


Hardware Renderer

You can now specify the new High Quality mode as the Render Type in the Hardware Renderer Property Editor (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/rendering_props_HardwareRenderOptionsPropertyEditor.htm). Framebuffers are not supported — you can only render the main channel.


Irradiance Particles and Final Gathering

You can now use irradiance particles together with final gathering. However, the final gathering settings take precedence over the irradiance particle settings. In particular, the irradiance particles' Intensity and Interpolation settings are not used. See Using Irradiance Particles with Final Gathering (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-2100C080-0D47-4643-B542-451EBE971843.htm).


AngularVelocity and Motion Blur

The AngularVelocity (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/iceref_attributes_AngularVelocity.htm) attribute works correctly with values beyond +/-360 when rendering motion blur.


Local Rendering Options

Local rendering options now show the label "Local" as well as appearing in Roman typeface in the explorer. This distinguishes them better from global settings in Italics. See Setting Global or Local Render Options (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/renderoptions_managing_SettingGlobalorLocalRenderOptions.htm).


Color Clipping

When rendering with mental ray and Premultiply with Alpha turned off on the Framebuffer tab of mental ray Render Options Property Editor (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/property4502.htm), RGB values no longer get clamped to 1.0 for floating-point images.

Similarly when using the PreMultiply (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/fxpresets9.htm) in the Fx Tree to unpremultiply, RGB values no longer get clamped to 1.0 for floating-point images.


Default Camera

The default camera for new scenes is now HD 1920x1080 (16x9) 30fps.


mental ray Rendering Software

Softimage 2013 uses version 3.10.1.4 of the mental ray rendering software.

Customization & SDK


Managing Workgroups with .wkg Files

You can store the workgroup paths to which you want to connect in one or more files with a .wkg extension, and then place these files in the Data folder of the Softimage installation (Factory) location or User location. Softimage automatically scans these locations at startup and if any .wkg files are found, Softimage will connect to the workgroup path of each entry.

A .wkg file is a simple text file that can contain multiple directory paths. Each path must be added on a separate line and each line must end with a newline character.

Note: The older method of using a single file called workgroup_path.data is still supported.

Layouts and Relational Views

Many more attributes have been made available for controlling layouts and relational views. In addition, they are all now available while editing a view by right-clicking in a pane and choosing Set View Properties.


Layouts in Workgroups

You no longer need to restart Softimage after connecting to a workgroup to use any layouts installed in it.


Toolbars

There's a new Toolbar Spacer in the Toolbar Widgets group that you can use to create a horizontal or vertical space in a toolbar. See Custom Toolbars (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/toolbars_shelves_CustomToolbars.htm).


Shelves

You can drag and drop to reorder tabs in a shelf. See Shelves (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/toolbars_shelves_Shelves.htm).


Synoptic Views and Python

You can now use Python for scripts in synoptic views. See Creating and Editing Synoptic Files (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/synviewed1.htm).


Unicode Support

The following file types are now saved as Unicode (UTF-8):

  • Layouts (.xsily)
  • Relational views (.xsivw)
  • Toolbars (.xsitb)
  • Synoptic views (.htm)
  • Preferences (.xsipref)

This means that they support multi-byte characters, including Japanese and other languages.


Environment Variables

In addition to new environment variables for controlling High Quality display mode (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/GUID-0FDB9324-E19C-49E0-9780-6B0429DA29A8.htm), there is a new environment variable SI_DISABLE_SHADERDEF_CACHE. Set this variable to any value to disable the shader definition cache. This can be useful if you are developing shaders and don't want to continually refresh the cache. See Environment Variables (http://download.autodesk.com/global/docs/softimage2013/en_us/userguide/files/config_envirovars.htm).


New Commands

  • AddPortToICENode2 - Adds a new port at the specified location and returns an XSICollection of new port objects.
  • HideAllPortValues - Hides all port values in specific container node(s).
  • SetCheckerboardMode - Sets the Checkerboard mode of a particular Texture Editor view.
  • TransferAllPropertiesAcrossGenOp - Added new IncludeAllClusters parameter to specify that clusters with no properties are included in the transfer

New Methods (C++)

  • CICEAttributeDataArray<T>::operator [] - Accessor to the encapsulated array. This operator is used for writing to the data array.
  • CICEAttributeDataArray<bool>::SetData - Accessor to the bool array for writing to the data array.
  • CICEAttributeDataArray2D::ResizeSubArray - Changes the size of the sub-array at a given index and returns a new array pointing to the resized sub-array.
  • Geometry::AddICEAttribute - Adds a new ICEAttribute object to this geometry and returns this object.
  • Geometry::RemoveICEAttribute - Removes an attribute from this geometry.
  • CMatrix3f::Get - Gets a pointer to the const version of the internal matrix.
  • CMatrix4f::Get - Gets a pointer to the const version of the internal matrix.
  • ProjectItem::AddICEAttribute - Adds a new ICEAttribute object to this ProjectItem and returns this object.
  • ProjectItem::RemoveICEAttribute - Removes an attribute from this ProjectItem.
  • CString::TrimLeft - Removes a character or a group of characters from the beginning of this string.
  • CString::TrimRight - Removes a character or a group of characters at the end of this string.
  • Camera::GetFrustum - Gets the camera frustum values of the near plane.
  • ViewContext::GetMetadata - Returns the user data stored in the Context.
  • ViewContext::GetView - Returns the View object associated with the Context.
  • Application::GetCustomPropertyCount - Returns the Custom Property count for a given type.
  • ShaderParamDef::SetReadOnly - Sets the ReadOnly capability of the Shader parameter.

New Methods (Object Model)

  • ICEAttribute.DataArray - Sets a 1D Array object containing the data defined by an attribute.
  • ICEAttribute.DataArray2D - Sets a 2D Array object containing the 2D data defined by an attribute.
  • XSICollection.Filter - Returns a subset of this collection as a new collection of objects matching the filter criteria.
  • Clip.AddProperty2 - Creates and adds a UserDataBlob or CustomProperty to a Clip object. This method is specific to the python language.
  • Geometry.AddICEAttribute - Adds and returns a new attribute data on a geometry.
  • Geometry.RemoveICEAttribute - Removes a non-built-in attribute from a geometry if not required by an ICETree.
  • Layout.CreateViewFromDefinitionFile2 - Creates a new View object given the path to its definition on disk. This method is similar to Layout.CreateViewFromDefinitionFile but specific to the python language.
  • Layout.FindView2 - Finds an existing View object given a name in this layout. This method is similar to Layout.FindView but specific to the python language.
  • Menu.AddItem2 - Adds a menu item at to end of the menu. This method is similar to Menu.AddItem but specific to the python language.
  • Menu.AddCommandItem2 - Adds a menu item at the end of the menu and attaches a command. This method is similar to Menu.AddCommandItem but specific to the python language.
  • Menu.AddCallbackItem2 - Adds a menu item to the end of the menu and attaches a callback function. This method is similar to Menu.AddCallbackItem but specific to the python language.
  • ICENode.GetPortFromName2 - Returns the ICENodePort object that matches a specific port name. This method is similar to ICENode.GetPortFromName but specific to the python language.
  • ICENode.GetPortFromIndex2 - Returns the ICENodePort object specified by a port index, group index and group instance index. This method is similar to ICENode.GetPortFromIndex but specific to the python language.
  • Operator.GetPortAt - Returns the specified Port object. This method is similar to Operator.PortAt but specific to the python language.
  • Operator.GetPort3 - Returns the specified Port object for the operator. This method is similar to Operator.GetPort2 but specific to the python language.
  • Override.AddParameterEntry2 - Adds a new entry to override the input parameter and returns the new overriding parameter. This method is similar to Override.AddParameterEntry but specific to the python language.
  • Primitive.GetGeometry3 - Returns a Geometry object containing the object's geometry. This method is similar to Primitive.GetGeometry2 but specific to the python language.
  • ProjectItem.AddICEAttribute - Adds and returns a new attribute data on this object.
  • ProjectItem.RemoveICEAttribute - Removes a non-built-in attribute from a geometry if not required by an ICETree.
  • SceneItem.GetPropertyFromName2 - Returns a property, given its scripting name. This method is similar to SceneItem.GetPropertyFromName but specific to the python language.
  • SceneItem.GetLocalPropertyFromName2 - Returns a local property, given its scripting name. This method is similar to SceneItem.GetLocalPropertyFromName but specific to the python language.
  • ShaderArrayParamDef.ItemDef2 - Returns the underlying ShaderParamDef or ShaderStructParamDef object for this array item. This method is similar to ShaderArrayParamDef.ItemDef but specific to the Python language.
  • ShaderArrayParameter.Item2 - Returns the specified ShaderParameter item in this array. This method is similar to ShaderArrayParameter.Item but specific to the Python language.
  • ShaderParamDefContainer.AddParamDef2 - This method is similar to ShaderParamDefContainer.AddParamDef but specific to the Python language.
  • ShaderParamDefContainer.GetParamDefByName2 - Returns the ShaderParamDef that matches the specified name from this container. This method is similar to ShaderParamDefContainer.GetParamDefByName but specific to the Python language.
  • ShaderParameter.Definition2 - Returns the shader parameter definition as a ShaderParamDef object. This method is similar to ShaderParameter.Definition but specific to the Python language.
  • View.FindView2 - Finds an existing View object given a name. This method is similar to View.FindView but specific to the Python language.
  • X3DObject.GetActivePrimitive3 - Returns the 3D object's active Primitive for a given frame. This method is similar to X3DObject.GetActivePrimitive2 but specific to the Python language.
  • XSIApplication.ActiveProject3 - Returns or sets the active XSIProject object. This method is similar to XSIApplication.ActiveProject2 but specific to the Python language.
  • XSIApplication.GetObjectFromID2 - Returns the object matching the specified ID. This method is similar to XSIApplication.GetObjectFromID but specific to the python language.
  • XSIFactory.CreateObjectFromPreset2 - Creates an object from a preset and optional preset family name. This method is similar to XSIFactory.CreateObjectFromPreset but specific to the Python language.
  • ShaderParamDefOptions.SetReadOnly - Sets the Read Only capability of the Shader parameter.
  • XSIApplication.GetCustomPropertyCount - Returns the Custom Property count for a given type.

New Enumerations

  • siHLEOperationAbsoluteOffset, siHLEOperationRelativeOffset, siHLEOperationAbsoluteScaling - Constants that define the high-level editing (HLE) operation used in the FCurve Editor, when the HLE tool is enabled.
  • siRenderRegionRefreshMode - This indicates the render region refresh mode to use for render regions.

New Events

  • siOnBeginScrubbing - Fired before setting a parameter value(s) with a PPG slider control.
  • siOnEndScrubbing - Fired after a parameter value(s) have been changed with a slider control.
  • siOnPreParseShaderDef - Fired after a shader definition is pre parsed.
  • siOnPreDefineShaderDef - Fired after a shader definition is pre defined.

New Anchorpoints

  • siMenuTbICECrowdFXActorsID
  • siMenuTbICECrowdFXSimulationID
  • siMenuTbICECrowdFXCrowdID
  • siMenuFCurveEditorTopLevelID
  • siMenuFCurveEditorFileID
  • siMenuFCurveEditorEditID
  • siMenuFCurveEditorViewID
  • siMenuFCurveEditorKeysID
  • siMenuFCurveEditorCurvesID
  • siMenuFCurveEditorSelectID
  • siMenuSchematicViewTopLevelID
  • siMenuMaterialManagerTopLevelID
  • siMenuAnimMixerEditID
  • siMenuAnimMixerViewID
  • siMenuAnimMixerTrackID
  • siMenuAnimMixerClipID
  • siMenuAnimMixerMixID
  • siMenuAnimMixerEffectID
  • siMenuShaderCodeEditContextID

View Attributes

  • MaterialManagerAttributes
    • selection - Returns a comma-delimited string containing the full name(s) of the selected materials currently displayed in the Material Manager
  • WeightEditorAttributes
    • invaliddeformers - Returns an XSICollection containing the invalid X3DObject deformer object(s) currently displayed in the Weight Editor.
    • selecteddeformers - Returns an XSICollection containing the selected X3DObject deformer object(s) currently displayed in the Weight Editor.
    • verticesnotfullyassigned - Returns a one-dimension SAFEARRAY containing the string expression of point components which are not full assigned weight.
    • verticesexceedingdeformerlimit - Returns one-dimension SAFEARRAY containing the string expression of point components which are exceeding the deformer limit.
    • painttoolactivated - Determine whether or not the paint tool is activated in Weight Paint Panel.
  • FCurveEditorAttributes / AnimationEditorAttributes
    • ripple - Determines whether or not existing keys are pushed ahead on the timeline when you parse keys on an fcurve or when you scale a region of keys
    • selectedcurves - Returns or sets the selected FCurve objects as a comma-delimited string containing the full name of the FCurve's parent
    • frameall - Frames all displayed fcurves
    • frameselection - Frames selection
    • frameplaybackrange - Frames all the fcurves within the time span specified by the timeline
    • frameselectedkeys - Frames selected keys
    • frameselectedcurves - Frames selected fcurves
    • frameregion - Frames a region
    • centercurrenttime - Centers the fcurve graph around the timeline cursor's position
    • autoframe - Determines whether or not animation editor will frame all fcurves automatically
    • interactiveupdate - Determines whether or not to see the effect of the changes in viewports as you edit the fcurves.
    • showbuffercurves - Determines whether or not to display a temporary copy of the original function curve that has been saved into a buffer.
    • displaynormalized - Determines whether or not to display the normalized fcurves.
    • classicmode - Switches between Suite and Classic Mode
    • hle - Determines whether or not to enable the high-level editing (HLE) tool.
    • hlecompensation - Determines whether or not to enable the high-level editing (HLE) compensation mode
    • hleoperation - Determines which high-level editing (HLE) operation the HLE tool uses
    • displayoptions - Determines which fcurves are displayed in the graph by default
    • isolatecurve - Determines whether or not to isolate the selected fcurves so that only they appear in the graph
    • clearallcurves - Hides all fcurves associated with the selected object without collapsing the animation explorer
    • hidecurve - Hides the selected fcurves
    • unhideallcurves - Displays all hidden fcurves
    • keysonunselectedcurves - Determines whether or not to display keys on all unselected curves
    • slopesonunselectedkeys - Determines whether or not to display the slope handles of all unselected keys on a selected curve
    • showlabels - Determines whether or not to display labels on all selected curves
    • keyscoordinates - Determines whether or not to display the X and Y coordinate values for each selected key
    • grid - Determines whether or not to display the X and Y axis grid lines
    • rulers - Determines whether or not to display the rulers on the horizontal X(time) and vertical Y(value) axes
    • timecursorvisible - Determines whether or not to display the red playback cursor in the fcurve graph
    • timecursorselectable - Determines whether or not the red playback cursor is selectable in the fcurve graph
    • metacurveregion - Determines whether or not to display a bar below the graph showing an overview representation of all the keys of the selected fcurves
    • localtime - Determines whether or not to display the corresponding time of the animation between the action in the animation mixer and the fcurve editor
    • framerange - Returns or sets the frame range in frame values
    • timerange - Returns or sets the frame range in time values
    • valuerange - Returns or sets the minimum/maximum values (Y axis) range
    • displayedcurves - Returns or sets the displayed FCurve objects as a comma delimited string containing the full name of the FCurve's parent
    • selectedkeysatframes - Returns or sets the selected keys of FCurve objects as a string
    • selectedkeysattimes - Returns or sets the selected keys of FCurve objects as a string
    • savebuffer - Saves the buffer copy of the edited curve, when buffer curves option is active
    • swapbuffer - Swaps between the edited curve and its buffer copy, when buffer curves option is active
  • DopeSheetAttributes
    • pasteoperation - The behavior when copied keys are paste into the current DopeSheet
    • frameall - Frames all the keys in the DopeSheet
    • frameselection - Frames the selected keys in the DopeSheet
    • frameplaybackrange - Frames the playback range in the DopeSheet
    • displayoptions - Determines which tracks are displayed in the DopeSheet
    • aligntrackswithtreeview - Determines whether the DopeSheet tracks align with its corresponding node in the tree view on the left
    • displayscenesummarytrack - Determines whether the scene summary track is displayed
    • displaydopesheetsummarytrack - Determines whether the DopeSheet summary track is displayed
    • phonemekeydisplay - Determines whether the phoneme keys display mode is active
    • phonemeshowinbetweens - Determines whether the shape key names between the shape keys are displayed in phoneme key display mode
    • phonemekeythreshold -Determines the weight threshold used by the phoneme key display mode
    • ripple - Determines whether ripple is enabled
  • AnimationMixerAttributes
    • targetcontent - The name of the object for which to display in the Animation Mixer
  • CustomDisplayHostAttributes
    • metadata - The string-based data associated with the Custom Display Host View
  • ObjectViewAttributes
    • holdselection - Controls whether to show the last selection when nothing is selected in Object View
  • TextureEditorAttributes
    • checkerboard - Enables/Disables the checkerboard mode
    • frameselection - Frames the selected components in the Texture Editor view
    • frameall - Frames all the vertices in the Texture Editor view
    • frameimage - Frames the image in the Texture Editor view
    • showselected - Show the selected components in the Texture Editor view
    • hideselected - Hide the selected components in the Texture Editor view
    • showall - Show all the components in the Texture Editor view
    • maxdisplayresolution - Sets/Gets the maximum display resolution of the image in the Texture Editor view
    • interpolateimage - Enables/Disables the interpolation of the image
    • dimimage - Enables/Disables the dimming of the image
    • overlaps - Enables/Disables the highlighting of overlaps in the Texture Editor view
    • oddoverlaps - Enables/Disables the highlighting of odd overlaps in the Texture Editor view
    • coverage - Enables/Disables the display of the coverage in the Texture Editor view
    • connectivity - Enables/Disables the display of the connectivity in the Texture Editor view.
    • statusbar - Enables/Disables the display of the statusbar in the Texture Editor view
    • clip - Sets/Gets the image clip in the Texture Editor view
    • projection - Sets/Gets the UV projection in the Texture Editor view
    • lock - Controls the lock selection state button in the toolbar
  • WeightPaintPanelAttributes
    • solo - Determine whether or not to display the weight map for only the current deformer in Weight Paint Panel

This page was last modified 03:44, 13 Apr 2012.
This page has been accessed 15454 times.

© Copyright 2009 Autodesk Inc. All Rights Reserved. Privacy Policy | Legal Notices and Trademarks | Report Piracy