New Features for Softimage 2012 (version 10.0)


Here is a detailed summary of the new features and enhancements available in Autodesk Softimage 2012:


UI & General

  • New Web-based Help and user preference for setting online or offline Help locations.
  • Added a STOP button to the playback control panel.
  • The Schematic View now shows links for custom and scripted operators and more hotkey options. See also the Schematic View API changes in the SDK.
  • Syflex and Polygonizer plug-ins are now fully translated into Japanese.
  • Added Primitive > Polygon Mesh > Empty for ICE Trees.
  • You can now use 32-bit Quicktime on 64-bit Windows.
  • Added Preferences > Display > Image Clip Thumbnail Size.
  • You can now load progressive JPEG in Windows XP with a limited account or on Windows with UAC enabled.


For a more detailed summary see What's New in "Interface and Tools" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_InterfaceandTools.htm) and "Viewing and Playback" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_ViewingandPlayback.htm)

ICE

  • New Simulation Settings property added to ICE simulated scene elements for controlling sub-frame calculations.
  • Lagoa scenes and compounds updated to comply with sub-frame interpolation.
  • Blast compound v.2.1 changed to properly respect end duration.
  • New ICE Nodes:
    • Get Orthogonal Basis
    • Build Array from Set
    • Reference To String
    • New FrameStep
    • New GetSetMedian
    • Create Strand From Curves
  • Modified ICE Nodes:
    • Cache On File
      • New input port that can use a string node to define the path
      • New input port to control the caching mode
      • New Subframe Mode to cache all simulation samples
      • New PPG logic to keep the path visible in all modes
    • Modifier Deformation > Modulate by Null
    • Modifier Deformation > Turbulize Around Value
    • Modifier Deformation > Turbulize Value by Range
  • New ICE Attributes:
Intrinsic Attributes
 EdgeID, EdgeToCCWPolygon, EdgeToCWPolygon, EdgeToNextEdgeCCW, EdgeToNodes, EdgeToVertices, 
 MaterialID, Materials, NodeID, NodeToEdges, NodeToPolygon, NodeToVertex, NodeUserNormal, 
 PointUserMotions, PolygonalDescription, PolygonID, PolygonToEdges, PolygonToNodes, PolygonToVertices, 
 Topology, VertexID, VertexIsBorder, VertexIsCorner, VertexToEdges, VertexToNodes, VertexToPolygons
Custom Attributes Exposed by Compounds
  Display_StrandToMesh_PackedPolygons, Display_StrandToMesh_PositionsPerObject
  IsOnSlicePlane, SlicePolyMesh_PlaneNormal, SlicePolyMesh_PlaneOrigin
  StrandToMesh_ExtrusionID, StrandToMesh_IsCapEnd
  StrandToMesh_IsCapStart, StrandToMesh_LastIDFirstExtrusion
  StrandToMesh_NbExtrudedSide, StrandToMesh_NbSections
  StrandToMesh_NbSides, StrandToMesh_PackedPolygons
  StrandToMesh_Polygon_U, StrandToMesh_Polygon_V
  StrandToMesh_SpacingRatio_U, StrandToMesh_SpacingRatio_V
  StrandToMesh_Texture_Projection
  • Topology Task tab in the Preset Manager now has a set of high-level compounds to help you quickly get to work with ICE Modeling:
Topology/Conditionals/Test Edge Index
Topology/Conditionals/Test Index Is Valid
Topology/Conditionals/Test Polygon Index
Topology/Conditionals/Test PolyNode Index
Topology/Conditionals/Test Polygon Inside Null
Topology/Conditionals/Test Vertex Index
Topology/Copy and Merge/Build Topology Array
Topology/Copy and Merge/Copy Default Rendering Attributes
Topology/Copy and Merge/Copy Edge Data from Source
Topology/Copy and Merge/Copy Material Attributes
Topology/Copy and Merge/Copy Polygon Data from Source
Topology/Copy and Merge/Copy PolyNode Data from Source
Topology/Copy and Merge/Copy Texture Projection from Source
Topology/Copy and Merge/Copy Vertex Data from Source
Topology/Copy and Merge/Merge Data Sets to Array
Topology/Copy and Merge/Merge Edge Data
Topology/Copy and Merge/Merge Material ID
Topology/Copy and Merge/Merge Polygon Data
Topology/Copy and Merge/Merge PolyNode Data
Topology/Copy and Merge/Merge Texture Projections
Topology/Copy and Merge/Merge Vertex Data
Topology/Copy and Merge/Random Material ID per Copy
Topology/Copy and Merge/Transform per Copy
Topology/Generators/Clone Polygon Mesh
Topology/Generators/Create Copies from Polygon Mesh
Topology/Generators/Create Extrusion Along Strands
Topology/Generators/Merge Polygon Meshes
Topology/Getters/Get Closest Edge Index from Null
Topology/Getters/Get Copy Index
Topology/Getters/Get Edge Index from Test
Topology/Getters/Get Edge Index
Topology/Getters/Get Edge is on Edge Loop
Topology/Getters/Get Edge Loop
Topology/Getters/Get Invalid Index
Topology/Getters/Get Material ID
Topology/Getters/Get Materials
Topology/Getters/Get Polygon Index from Test
Topology/Getters/Get Polygon Index
Topology/Getters/Get Polygon is on Edge Loop
Topology/Getters/Get Polygons Inside Null
Topology/Getters/Get PolyNode Index from Test
Topology/Getters/Get PolyNode Index
Topology/Getters/Get Topology
Topology/Getters/Get Vertex Index from Test
Topology/Getters/Get Vertex Index
Topology/Getters/Get Vertex is on Edge Loop
Topology/Getters/Get Vertices Index from Edge
Topology/Modifiers/Apply Collapse Edge
Topology/Modifiers/Apply Delete Polygon
Topology/Modifiers/Apply Delete Vertex
Topology/Modifiers/Apply Disconnect Component
Topology/Modifiers/Apply Extrude Polygon Along Axis
Topology/Modifiers/Apply Invert Polygon
Topology/Modifiers/Apply Merge Polygon
Topology/Modifiers/Apply Merge Vertices
Topology/Modifiers/Apply Slice PolyMesh
Topology/Modifiers/Apply Split Edge
Topology/Modifiers/Apply Subdivide Locally
Topology/Modifiers/Apply Triangulate Polygon
Topology/Setters/Set Material ID from Cluster
Topology/Setters/Set Material ID
Topology/Setters/Set Materials from Library
Topology/Setters/Set Materials from Strings
Topology/Setters/Set Texture Projection Camera
Topology/Setters/Set Texture Projection Planar
Topology/Setters/Set Texture Projection Spatial
Topology/Setters/Set Topology
Topology/Setters/Set Vertex Position on Edge Loop
Topology/Shattering/Build Slice Planes
Topology/Shattering/Create Basic Shatter from Point Cloud
Topology/Shattering/Set Data from Chunk


For a more detailed summary see What's New in "ICE Fundamentals" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_ICE.htm) and "ICE Simulations" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-B8729F95-9DDE-443C-9646-642ED70E9E3-8.htm)

ICE Modeling

New ICE Modeling Nodes

  • Merge Topo (takes any number of topology inputs and will output a merged topology command list of all inputs)
  • Merge Topo Array (Merges an array of topologies together)
  • Slice Polygon (includes Delete and Cap options)
  • Apply Slice Polymesh compound (now much faster and can do multiple slices, deletes, and caps using array inputs)
  • Extrude Polygon Island (uses a Transform input instead of a vector)
  • Apply Extrude Polygon Along Axis compound (supports cluster, filter, or string inputs to define the components to extrude)
  • Create Topo (generates polygon meshes from arrays)
  • Topo Transform
  • Apply Extrusion along Strand
  • Create Strand from Curve compound (generates strands from several curves)
  • Get Topology compound (gets topology similar to what GetPointPosition does)
  • Get Topology (can be used to grab the current topology state of a mesh and clone it with a Set Topology)
  • Set Topology
  • Apply Slice Polymesh
  • Add Edge
  • Add Polygon
  • Add Vertex
  • Delete Polygon
  • Delete Vertex
  • Disconnect Component
  • Extrude Polygon
  • Invert Polygon
  • Local Subdivide
  • Merge Disjoint Vertices
  • Merge Polygon
  • Primitive Mesh
  • Slice Polygon
  • Split Edge
  • Triangulate Polygon
  • For a complete list, see the Topology category in ICE > Tools tab.
  • String > String To Array (for example, used in the "Apply Extrude Along Axis" compound)
	Builds a 2D array of values given an input string formatted as a comma or whitespace separated list of values. 
	The output array type is inferred at connection-time from the output port type. The types supported are: 

	Type Note 
	siICENodeDataBool  
	siICENodeDataColor4 Input string must contain groups of 4 float values. 
	siICENodeDataFloat  
	siICENodeDataLong Values can be specified with a range syntax. 
	Example 1 Value: 1,2,3-5,6 Result:1 2 3 4 5 6 
	Example 2 Value: -3-1 2-4 7-5 8-10 -1 Result:-3 -2 -1 0 1 2 3 4 7 6 5 8 9 10 -1 
	Example 3 Value: -3--1 -5--3 Result:-3 -2 -1 -5 -4 -3 
	siICENodeDataMatrix33 Input string must contain groups of 9 float values. 
	siICENodeDataMatrix44 Input string must contain groups of 16 float values. 
	siICENodeDataQuaternion Input string must contain groups of 4 float values. 
	siICENodeDataVector2 Input string must contain groups of 2 float values. 
	siICENodeDataVector3 Input string must contain groups of 3 float values. 
	siICENodeDataVector4 Input string must contain groups of 4 float values. 
	siICENodeDataRotation Input string must contain groups of 3 float values. 
	Note: For complex types arrays such as siICENodeDataVector3 or siICENodeDataMatrix33, if the number 
	of items in the value string is wrong (for example, missing the Z coordinate), the output list will be empty.
  • Basic Math > Clamp
  • Statistics Math > Get Set And
  • New “Topology” attributes (for example, Self.Topology)

New Sample Scenes

  • XSI_SAMPLES/Scenes/ICE/Modeling_Basic_Shattering.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Columns_From_Strands.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Delete_Along_Edge_Loop.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Desks.scn" "Data/XSI_SAMPLES/Scenes/ICE/Modeling_Desks.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Road.scn" "Data/XSI_SAMPLES/Scenes/ICE/Modeling_Road.scn


For a more detailed summary see "What's New in ICE Modeling" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-E62C767F-6DFC-4DE8-AC3F-B99FD877EEA-9.htm)

Syflex on ICE

  • ICE > Task Tab > Syflex
  • New sample scenes
  • Syflex Curve compound
  • Syflex Curve Springs compound


For a more detailed summary see "What's New in Syflex" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-35A62A1B-4A7A-4150-9878-D1A226B59D7-10.htm)

ICE Flow and Suite Interoperability

Now supports:

  • Starting in Softimage and sending to Maya
  • 3ds Max workflow, starting from 3ds Max
  • Mudbox workflow, including Vector Displacement Maps rendering
  • Linux (for Maya and Mudbox)


For a more detailed summary see "What's New in Data Management" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_DataManagement.htm)

Animation

  • New shadow icons for bone primitives.

Animation Editor

  • New simplified “Suites” mode (return to Classic from View menu)
  • Updated icons
  • New Isolate F-Curve (View menu and Icon)


For a more detailed summary see "What's New in Animation" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-B4C51127-F5F4-45B8-B0CB-4692BDAD6FE-6.htm)

Cache Manager

  • Button to dump icecache header and attributes description into xml format.
  • Option to reset all transforms before applying caches to objects (useful when cache is in global space)
  • Cache ICE sub-sampling attributes (scale with the same factor when loading into the mixer)


For a more detailed summary see "What's New in Data Management" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_DataManagement.htm)

Scene Layers

  • Scene layer groups allow you to make a layer the child of another layer, so that you can, for example, toggle the visibility from the parent. This replaces the previous implementation of layer groups, but old scenes won't be upgraded. A script could be written to convert the old layer groups to the new layer structure. Previously, "layer groups" were only a way to toggle the check box of all layers of a group at the same time. The new implementation works like groups-within-groups so that making a parent visible lets the child control its own visibility instead of forcing it on.
  • Layer groups now retain their settings
  • A single click on a row no longer sets current layer
  • User interface changed for Explorer > Layers
  • Only one level of hierarchy is supported (for example, a child layer cannot itself have a child)
  • Scene Layer Manager > Check/Uncheck All Menu


For a more detailed summary see "What's New in Scene Elements" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-1C5B156B-17C9-4791-BCBA-C7657815D89-4.htm)

Texture Editor (TE)

  • UV pinning
    • UV pinning is not used within the TE for operations such as Heal, Collapse, etc. Only operations launched from the TE are supported. Commands such as Translate and Rotate will not take UV pinning into consideration. Other TE commands related to projections such as the ones in Planar and Cubic Subprojections are also not considered.
    • New selection mode for selecting pinned UV components. Pinned UV components cannot be selected in the TE unless the UV pinning selection mode is on. When turned off, UV components are ignored by the selection. UV pinning is supported by Heal, Island Heal, Flip, Relax, Match, Cycle, Paste UVW, Transform tools and Move Component.


For a more detailed summary see "What's New in Textures and Maps" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-6EF2387E-1681-475C-895E-0C333840886-12.htm)

Weight Editor

  • The weight editor can now be used to edit any weight map or color-at-vertices map, and not just envelop weight maps.


For a more detailed summary see What's New in "Scene Elements" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-1C5B156B-17C9-4791-BCBA-C7657815D89-4.htm) and "Interface and Tools" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_InterfaceandTools.htm)

Rendering

  • mental ray 3.9.1.38 integration
  • New User Motion Cluster Property: A new vertex cluster property, named User Motion, allows you to control the motion vectors of each vertex of a polymesh object. When the User Motion cluster property is applied to an object, the motion blur is no longer computed and instead uses the motion data from this property. The simpler way to write on the User Motion cluster property is by using ICE.
  • Unified Sampling: The unified sampling is a vast improvement on the previous sampling algorithm. You can select the exact number of samples, rather than in increments of power-of-four. It also does away with the generic QMC sampler, and uses a new computation that doesn't suffer from the same diagonal artifacts as before. This only applies to scanline/raytracing however. For rasterizer, the unified sampling controls are just mapped into the existing rasterizer settings. Unified Sampling is turned off by default.
  • ICE attributes on meshes can now be accessed in the Render Tree by using the texture/weightmap/CAV shaders or the Get Attribute shaders. This is very useful when doing procedural modelling, because you don't have to create clusters in advance for all the attributes that you want to access from the Render Tree.
  • Ability to choose the Vertex Color Display property from the Brush properties property editor.
  • Control UV Wrapping and UV Smoothing when using ICE attribute as UV: Added a mechanism to look for specific constant ICE attributes based on name. If you have a vector3 per sample named "MyUV1" doing a set data on "MyUV1_u_wrap" will enable you to control the texture wrapping mode used by the projection in the same way you do in the texture projection property editor.
  • Versioning support in contextual menus of shader compounds
  • Ability to set default file format for saved Preview image (last used format is remembered in a user preference)
  • Added a compression slider for .jpg in Viewport Capture. Also set default JPG quality to 100%.


For a more detailed summary see What's New in "Motion Blur" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_Cameras.htm), "Rendering" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/GUID-58D083CC-CA4A-48CD-A48E-751CE75CE1F-14.htm), "Materials and Shaders" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_MaterialsandShaders.htm)

FBX

  • Stereo camera I/O
  • Importing of Vector Displacement Maps from Mudbox
  • Support FBX SDK 2012
  • Added "Import Fbx..." under "File > Import" menu and "Export Fbx..." under "File > Export" menu
  • Added scripting commands to create the import/export options
  • Import *.3ds, *.dxf, *obj, *.dae formats
  • Ability to select target .fbx version such as 2010 (Motion Builder compatible), 2011, and 2012
  • Multiple UVs supported in the FBX Importer/Exporter
  • Supports the import of CgFX materials
  • Supports neutral poses
  • FBX Single-step workflow to Mudbox
    • Materials: Phong, Lambert and Blinn are supported
    • Textures: normal, displacement, vector displacement map, ambient, specular, shiny, incandescence, bump, reflectivity and diffuse are supported


For a more detailed summary see "What's New in Data Management" (http://download.autodesk.com/global/docs/softimage2012/en_us/userguide/files/new_DataManagement.htm)

Customization & SDK

For a more detailed summary see "What's New in the SDK" (http://download.autodesk.com/global/docs/softimage2012/en_us/sdkguide/files/new.htm)

New Features

  • Getting and Setting Size and Position for PPGs: New methods and functions were added to PPGLayout in the Object Model and the C++ API to allow for setting and getting the size and position of a modal property editor (also known as a PPG). See SetViewSize , SetViewPosition, ViewSize, and GetViewPosition in Object Model and C++ API.
  • Undo API: New methods and functions were added to Application in the Object Model and the C++ API to allow for opening and closing undo complexes and return true if a command is undoing or redoing. See OpenUndo, EndUndo, and IsUndoing in Object Model and C++ API.
  • UVProperty Pinning API: New C++ and Object Model API for marking cluster components as pinned or unpinned. This API is mainly used by the UVUnfold feature. See UVProperty in Object Model and C++ API.
  • Schematic View and Nodes API:
    • New C++ and Object Model API for manipulating the schematic view nodes. See Schematic and SchematicNode in Object Model and C++ API.
    • New menu anchor points: siMenuSchematicViewID, siMenuSchematicViewContextID, and siMenuSchematicNodeContextID.
    • New SchematicDemo example added to the SDK Examples Workgroup.
  • Scene Layer Manager API:
    • New menu anchor points: siMenuSceneLayerManagerLayersID and siMenuSceneLayerManagerContextID.
    • New view attribute selectedlayer. Available for View.GetAttributeValue only.
  • New Events:
    • siOnBeginCommand: Fired when a command is about to be executed. The event can be used to abort the command execution, modify the command argument values or launch other commands.
    • siOnEndCommand: Fired when a command has been executed. The event can be used to access the command return value or output argument values. Contrary to other event types, this event is always fired when the current command has been aborted by a previous event.
    • siOnRenderAbort: Fired when a render sequence has been aborted by the user. The event can also be sent when a render region job is re-executed as a result of a scene change.
    • Added ActionSource support for siFileTypeAction to siOnBeginFileImport and siOnEndFileImport events. Now siOnBeginFileExport/siOnEndFileExport and siOnBeginFileImport/siOnEndFileImport events support Action and Shape actions.
  • Interactive Tool SDK:
    • New ToolContext class added to the C++ API for building plug-in tools that can be used in 3D views.
    • New Math classes CLine and CPlane used by the Tool SDK.
    • Tool Wizard in the Plug-in Manager.
    • New CustomTool example added to the SDK Examples Workgroup.
  • Image Clip and Bitmap Controls:
    • New Image Clip Control in PPGLayout (siControlImageClip): A control that shows an Image Clip. A string parameter sets the Image Clip full name. Supported attribute is siUIShowClip Set to True to show the thumbnail of the Image Clip control. The control toolbar is always displayed, regardless of this attribute value.
    • Static Bitmap control (siControlBitmap): Use siUIFilePath to set the bitmap to show.
    • For an example of both, see PSetUIDemo in the SDK Examples Workgroup.
  • Support for Menu Checkmarks: A new method and two functions where added to MenuItem in the Object Model and the C++ API to support menu checkmarks. See MenuItem.Checked, MenuItem::IsChecked, and MenuItem::PutChecked in Object Model and C++ API.
  • Scripting Shortcuts for Python: New Object Model shortcuts were added to siutils.py to facilitate python scripting.
  • Behavior Changes in the SDK:
    • The Layout.CreateView method and the Layout::CreateView function now display the name (in the titlebar) of the created view.
    • Scripts can no longer change the number of undo levels permanently. This prevents problems that occured when scripts set the number of undo levels to 0 to increase performance, and then failed to set it back or terminated abnormally.

Object Model Changes

  • New Objects
    • Schematic
    • SchematicNode
    • UVProperty
  • New Methods
    • Application.OpenUndo
    • Application.EndUndo
    • Application.IsUndoing
    • MenuItem.Checked
    • PPGLayout.SetViewSize
    • PPGLayout.SetViewPosition
    • PPGLayout.ViewSize
    • PPGLayout.GetViewPosition
  • New Constants
    • siControlImageClip
    • siControlBitmap

C++ API Changes

  • New Classes
    • CLine
    • CPlane
    • Schematic
    • SchematicNode
    • ToolContext
    • UVProperty
  • New Functions
    • Application::EndUndo
    • MenuItem::IsChecked
    • Application::IsUndoing
    • Application::OpenUndo
    • PPGLayout::GetViewPosition
    • MenuItem::PutChecked
    • PPGLayout::SetViewSize
    • PPGLayout::SetViewPosition
    • PPGLayout::ViewSize

Scripting Command Changes

  • New Commands
    • CreateLayerGroup
    • FBXGetPluginVersion
    • FBXGetSDKVersion
    • PinAllUVComponents
    • PinUVComponents
    • UnpinAllUVComponents
    • UnpinUVComponents

This page was last modified 00:55, 8 Apr 2011.
This page has been accessed 15491 times.

© Copyright 2009 Autodesk Inc. All Rights Reserved. Privacy Policy | Legal Notices and Trademarks | Report Piracy