Autodesk Softimage 2012 (JP)

ここでは、Autodesk Softimage 2012 の機能、修正、既知の問題点の概要について説明します。


Table of contents

新機能

UI と全般的な機能

  • 新しいウェブベースのヘルプを利用でき、ユーザプリファレンスでヘルプの場所をオンラインかオフラインに設定できます。
  • 再生コントロールパネルに停止ボタンが追加されました。
  • Schematic ビューでカスタムオペレータ、スクリプトオペレータのリンクを表示できるようになり、多数のホットキーオプションが追加されました。SDK ドキュメントの Schematic ビュー API の変更に関するトピックも参照してください。
  • Syflex と Polygonizer のプラグインが完全日本語化されました。
  • ICE Tree 用の [プリミティブ] > [ポリゴンメッシュ] > [エンプティ] メニューが追加されました。
  • 32 ビット版 Quicktime を 64 ビット Windows で使用できるようになりました。
  • [プリファレンス] > [ディスプレイ] > [サムネイル] > [イメージクリップサイズ] プリファレンスが追加されました。
  • Windows XP の制限付きアカウント、または UAC を有効にした Windows でプログレッシブ JPEG をロードできるようになりました。

ICE

  • ICE シミュレーションされたシーン要素に、サブフレームの計算を制御するための新しいシミュレーション設定プロパティが追加されました。
  • Lagoa シーンとコンパウンドが更新され、サブフレーム補間に対応するようになりました。
  • Blast コンパウンド v.2.1 が変更され、デュレーションの終了を正しく反映するようになりました。
  • 新しい ICE ノード:
    • Get Orthogonal Basis
    • Build Array from Set
    • Reference To String
    • New FrameStep
    • GetSetMedian
    • Create Strand From Curves
  • 変更された ICE ノード:
    • Cache On File
      • string ノードでパスを定義できる新しい入力ポート
      • キャッシングモードを制御する新しい入力ポート
      • すべてのシミュレーションサンプルをキャッシュする新しい[Subframe Mode]
      • あらゆるモードでパスを表示できる新しい PPG ロジック
    • [Deformation] > [Modifiers] > [Modulate by Nul]
    • [Deformation] > [Modifiers] > [Turbulize Around Value]
    • [Deformation] > [Modifiers] > [Turbulize Value by Range]
  • 新しい ICE アトリビュート:
固有のアトリビュート
 EdgeID, EdgeToCCWPolygon, EdgeToCWPolygon, EdgeToNextEdgeCCW, EdgeToNodes, EdgeToVertices, 
 MaterialID, Materials, NodeID, NodeToEdges, NodeToPolygon, NodeToVertex, NodeUserNormal, 
 PointUserMotions, PolygonalDescription, PolygonID, PolygonToEdges, PolygonToNodes, PolygonToVertices, 
 Topology, VertexID, VertexIsBorder, VertexIsCorner, VertexToEdges, VertexToNodes, VertexToPolygons
コンパウンドによってエクスポーズされるカスタムアトリビュート
  Display_StrandToMesh_PackedPolygons, Display_StrandToMesh_PositionsPerObject
  IsOnSlicePlane, SlicePolyMesh_PlaneNormal, SlicePolyMesh_PlaneOrigin
  StrandToMesh_ExtrusionID, StrandToMesh_IsCapEnd
  StrandToMesh_IsCapStart, StrandToMesh_LastIDFirstExtrusion
  StrandToMesh_NbExtrudedSide, StrandToMesh_NbSections
  StrandToMesh_NbSides, StrandToMesh_PackedPolygons
  StrandToMesh_Polygon_U, StrandToMesh_Polygon_V
  StrandToMesh_SpacingRatio_U, StrandToMesh_SpacingRatio_V
  StrandToMesh_Texture_Projection
  • プリセットマネージャの [タスク] タブの [Topology] カテゴリに高度なコンパウンドのセットが追加され、ICE モデリング作業がすばやくできるようになりました。
Topology/Conditionals/Test Edge Index
Topology/Conditionals/Test Index Is Valid
Topology/Conditionals/Test Polygon Index
Topology/Conditionals/Test PolyNode Index
Topology/Conditionals/Test Polygon Inside Null
Topology/Conditionals/Test Vertex Index
Topology/Copy and Merge/Build Topology Array
Topology/Copy and Merge/Copy Default Rendering Attributes
Topology/Copy and Merge/Copy Edge Data from Source
Topology/Copy and Merge/Copy Material Attributes
Topology/Copy and Merge/Copy Polygon Data from Source
Topology/Copy and Merge/Copy PolyNode Data from Source
Topology/Copy and Merge/Copy Texture Projection from Source
Topology/Copy and Merge/Copy Vertex Data from Source
Topology/Copy and Merge/Merge Data Sets to Array
Topology/Copy and Merge/Merge Edge Data
Topology/Copy and Merge/Merge Material ID
Topology/Copy and Merge/Merge Polygon Data
Topology/Copy and Merge/Merge PolyNode Data
Topology/Copy and Merge/Merge Texture Projections
Topology/Copy and Merge/Merge Vertex Data
Topology/Copy and Merge/Random Material ID per Copy
Topology/Copy and Merge/Transform per Copy
Topology/Generators/Clone Polygon Mesh
Topology/Generators/Create Copies from Polygon Mesh
Topology/Generators/Create Extrusion Along Strands
Topology/Generators/Merge Polygon Meshes
Topology/Getters/Get Closest Edge Index from Null
Topology/Getters/Get Copy Index
Topology/Getters/Get Edge Index from Test
Topology/Getters/Get Edge Index
Topology/Getters/Get Edge is on Edge Loop
Topology/Getters/Get Edge Loop
Topology/Getters/Get Invalid Index
Topology/Getters/Get Material ID
Topology/Getters/Get Materials
Topology/Getters/Get Polygon Index from Test
Topology/Getters/Get Polygon Index
Topology/Getters/Get Polygon is on Edge Loop
Topology/Getters/Get Polygons Inside Null
Topology/Getters/Get PolyNode Index from Test
Topology/Getters/Get PolyNode Index
Topology/Getters/Get Topology
Topology/Getters/Get Vertex Index from Test
Topology/Getters/Get Vertex Index
Topology/Getters/Get Vertex is on Edge Loop
Topology/Getters/Get Vertices Index from Edge
Topology/Modifiers/Apply Collapse Edge
Topology/Modifiers/Apply Delete Polygon
Topology/Modifiers/Apply Delete Vertex
Topology/Modifiers/Apply Disconnect Component
Topology/Modifiers/Apply Extrude Polygon Along Axis
Topology/Modifiers/Apply Invert Polygon
Topology/Modifiers/Apply Merge Polygon
Topology/Modifiers/Apply Merge Vertices
Topology/Modifiers/Apply Slice PolyMesh
Topology/Modifiers/Apply Split Edge
Topology/Modifiers/Apply Subdivide Locally
Topology/Modifiers/Apply Triangulate Polygon
Topology/Setters/Set Material ID from Cluster
Topology/Setters/Set Material ID
Topology/Setters/Set Materials from Library
Topology/Setters/Set Materials from Strings
Topology/Setters/Set Texture Projection Camera
Topology/Setters/Set Texture Projection Planar
Topology/Setters/Set Texture Projection Spatial
Topology/Setters/Set Topology
Topology/Setters/Set Vertex Position on Edge Loop
Topology/Shattering/Build Slice Planes
Topology/Shattering/Create Basic Shatter from Point Cloud
Topology/Shattering/Set Data from Chunk

ICE モデリング


新しい ICE モデリングノード

  • Merge Topo(任意の数のトポロジ入力を取り、すべての入力のコマンドリストのマージしたトポロジを出力する)
  • Merge Topo Array(トポロジの配列をマージする)
  • Slice Polygon(削除とキャップのオプションを含む)
  • Apply Slice Polymesh コンパウンド(処理速度が大幅に向上し、配列入力を使用した複数のスライス、削除、キャップが可能)
  • Extrude Polygon Island(ベクトルの代わりに変換入力を使用する)
  • Apply Extrude Polygon Along Axisコ ンパウンド(クラスタ、フィルタ、文字列入力をサポートして押し出すコンポーネントを定義する)
  • Create Topo(配列からポリゴンメッシュを生成する)
  • Topo Transform
  • Apply Extrusion along Strand
  • Create Strand from Curve コンパウンド(複数カーブから髪束を生成する)
  • Get Topology コンパウンド(GetPointPosition による操作のようにトポロジを取得する)
  • Get Topology(現在のメッシュのトポロジ状態を把握してトポロジの設定でクローンできる)
  • Set Topology
  • Apply Slice Polymesh
  • Add Edge
  • Add Polygon
  • Add Vertex
  • Delete Polygon
  • Delete Vertex
  • Disconnect Component
  • Extrude Polygon
  • Invert Polygon
  • Local Subdivide
  • Merge Disjoint Vertices
  • Merge Polygon
  • Primitive Mesh
  • Slice Polygon
  • Split Edge
  • Triangulate Polygon
  • 詳細なリストについては、[ICE Tree] ウィンドウ >[ツール] タブの Topology カテゴリを参照してください。
  • [String] > [String To Array](たとえば、「Apply Extrude Along Axis」コンパウンドで使用)
	値をカンマまたはスペースで区切ったリスト形式の入力文字列を指定して値の 2D 配列をビルドします。
	出力配列タイプは、接続時に出力ポートタイプから推定されます。以下のタイプがサポートされています。

	Type Note
	siICENodeDataBool  
	siICENodeDataColor4 Input string must contain groups of 4 float values. 
	siICENodeDataFloat  
	siICENodeDataLong Values can be specified with a range syntax. 
	Example 1 Value: 1,2,3-5,6 Result:1 2 3 4 5 6 
	Example 2 Value: -3-1 2-4 7-5 8-10 -1 Result:-3 -2 -1 0 1 2 3 4 7 6 5 8 9 10 -1 
	Example 3 Value: -3--1 -5--3 Result:-3 -2 -1 -5 -4 -3 
	siICENodeDataMatrix33 Input string must contain groups of 9 float values. 
	siICENodeDataMatrix44 Input string must contain groups of 16 float values. 
	siICENodeDataQuaternion Input string must contain groups of 4 float values. 
	siICENodeDataVector2 Input string must contain groups of 2 float values. 
	siICENodeDataVector3 Input string must contain groups of 3 float values. 
	siICENodeDataVector4 Input string must contain groups of 4 float values. 
	siICENodeDataRotation Input string must contain groups of 3 float values. 
	注意: siICENodeDataVector3 または siICENodeDataMatrix33 などの複雑な配列の場合、
	値文字列の項目数が正しくなければ(Z 座標の欠落など)、出力リストは空になります。
  • [Math] > [Basic] > [Clamp]
  • [Math] > [Statistics ] > [Clamp]
  • 新しい「トポロジ」アトリビュート(Self.Topology など)

新しいサンプルシーン

  • XSI_SAMPLES/Scenes/ICE/Modeling_Basic_Shattering.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Columns_From_Strands.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Delete_Along_Edge_Loop.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Desks.scn" "Data/XSI_SAMPLES/Scenes/ICE/Modeling_Desks.scn
  • XSI_SAMPLES/Scenes/ICE/Modeling_Road.scn" "Data/XSI_SAMPLES/Scenes/ICE/Modeling_Road.scn

ICE の Syflex

  • [ICE Tree] ウィンドウ > [タスク] タブ > [Syflex]
  • 新しいサンプル シーン
  • Syflex Curve コンパウンド
  • Syflex Curve Springs コンパウンド

ICE フローとスイートの相互運用性

新たに以下をサポートしました:

  • Softimage で作業して Maya に送信
  • 3ds Max から始める 3ds Max のワークフロー
  • ベクトルディスプレイスメントマップのレンダリングなどを含む Mudbox のワークフロー
  • Linux(Maya と Mudbox用)

アニメーション

  • ボーンプリミティブのシャドウアイコンが新たに追加されました。

アニメーションエディタ

  • 新しいシンプルな「スイート」モードが追加されました([ビュー] メニューからクラシックモードに戻れます)。
  • アイコンが更新されました。
  • 新しいFカーブの分離表示オプションが追加されました([ビュー] メニューとアイコン)。

Cache Manager

  • icecacheヘッダーとアトリビュートの説明を xml 形式にダンプするためのボタンが追加されました。
  • キャッシュをオブジェクトに適用する前にすべての変換をリセットするオプションが追加されました(キャッシュがグローバルな空間にある場合に便利です)。
  • ICE サブサンプリングアトリビュートのキャッシュが可能になりました(ミキサへのロード時と同じ係数でスケールします)。

シーンレイヤ

  • シーンレイヤのグループでは、レイヤを別のレイヤの子にすることができるため、親の表示を切り替えるといったことが可能です。これは、レイヤグループの以前の実装に代わるものですが、古いシーンの構造アップグレードされません。スクリプトを記述して、古いレイヤグループを新しいレイヤ構造へ変換することができます。以前は、グループのすべてのレイヤのチェックボックスを一度に切り替える唯一の方法が「レイヤグループ」でした。新しい実装はグループ内のグループのように動作するため、親を表示すると子も強制的に表示されるのではなく、子が自身の表示を制御できます。
  • レイヤグループが設定を保持するようになりました。
  • 行をシングルクリックしてもカレントレイヤは設定されなくなりました。
  • [Explorer] ウィンドウ > [レイヤ] ユーザインターフェイスが変更されました。
  • サポートされている階層のレベルは 1 つのみです(たとえば、子レイヤにさらに子を設定することはできません)。
  • [Scene Layer Manager] > [すべてチェック/チェック解除]メニューオプションが追加されました。

Texture Editor (TE)

  • UV 固定の新機能
    • UV の固定は TE 内のヒール、集約などの操作には使用されません。サポートされているのは、TE から開始される操作のみです。移動や回転などのコマンドでは、UV の固定は考慮されません。平面やキュービック部分投影など投影に関するほかの TE コマンドも考慮されません。
    • 固定された UV コンポーネント選択の新しい選択モードUV の固定選択モードがオンでなければ、TE で固定された UV コンポーネントを選択することはできません。オフにすると、UV コンポーネントは選択項目から無視されます。UV の固定は、ヒール、アイランドヒール、反転、リラックス、マッチ、サイクル、UVW の貼り付け、変換ツール、移動コンポーネントでサポートされています。

Weight Editor

  • Weight Editor で、エンベロープのウェイトマップだけでなく、任意のウェイトマップや頂点カラーマップも編集できるようになりました。

レンダリング

  • mental ray 3.9.1.38 が統合されました。
  • 新しいユーザモーション クラスタプロパティ: ユーザモーションという名の新しい頂点クラスタプロパティにより、ポリメッシュオブジェクトの各頂点のモーションベクトルを制御できます。ユーザモーション クラスタプロパティをオブジェクトに適用すると、モーションブラーは計算されなくなり、代わりにこのプロパティからモーションデータが使用されます。ユーザモーション クラスタプロパティに書き込む簡単な方法は ICE を使用することです。
  • 統一されたサンプリング: 統一されたサンプリングは以前のサンプリングアルゴリズムを大きく改善したものです。4 の累乗ではなく、サンプルの正確な数を選択できます。また、汎用の QMC サンプラを排除し、以前のような斜めのアーチファクトが生じない新しい計算を採用しています。ただし、これはスキャンラインとレイトレースにのみ適用されます。ラスタライザの場合、統一されたサンプリングのコントロールは既存のラスタライザ設定にマッピングされるだけです。[統一されたサンプリング]はデフォルトではオフになっています。
  • テクスチャ/ウェイトマップ/CAV シェーダまたは Get Attribute シェーダを使用して、レンダツリーでメッシュの ICE アトリビュートにアクセスできるようになりました。これは、レンダツリーからアクセスするすべてのアトリビュートのクラスタを前もって作成する必要がないため、プロシージャル モデリングを行うときに非常に便利です。
  • [ブラシプロパティ] プロパティエディタから頂点カラー表示プロパティを選択できるようになりました。
  • UV として ICE アトリビュートを使用する場合のコントロール UV ラッピングと UV スムージング: 特定の ICE アトリビュートを名前で検索するメカニズムを追加しました。「MyUV1」という名前のサンプルごとに vector3 があれば、「MyUV1_u_wrap」のデータを実行することで、テクスチャ投影プロパティエディタと同じ方法で投影で使用するテクスチャラッピングモードを制御できます。
  • シェーダコンパウンドのコンテキストメニューでバージョン管理できるようになりました。
  • 保存したプレビューイメージにデフォルトのファイルフォーマットを設定できるようになりました(最後に使用したフォーマットがユーザプリファレンスに記憶されます)。
  • ビューポートキャプチャの .jpg 用圧縮スライダを追加しました。デフォルトの JPG 画質も 100% に設定します。

FBX

  • 立体視カメラ I/O
  • Mudbox からのベクトルディスプレイスメントマップを読み込めるようになりました。
  • FBX SDK 2012 をサポートします。
  • 「ファイル > 読み込み」メニューに「FBX の読み込み...」、「ファイル > 書き出し」メニューに「FBX の書き出し...」が追加されました。
  • 読み込み/書き出しオプションを作成するためのスクリプティング コマンドが追加されました。
  • *.3ds、*.dxf、*obj、*.dae フォーマットの読み込みをサポートします。
  • ターゲットの .fbx バージョンを選択できます。2010(Motion Builder 互換)、2011、2012 をサポートしています。
  • FBX 読み込み/書き出しウィンドウで複数の UV をサポートしています。
  • CgFX マテリアルの読み込みをサポートします。
  • ニュートラルポーズをサポートします。
  • FBX シングルステップワークフローにより簡単に Mudbox へ書き出しできます。
    • マテリアル: Phong、Lambert、Blinn がサポートされています。
    • テクスチャ: 法線、ディスプレイスメント、ベクトルディスプレイスメントマップ、アンビエント、スペキュラ、輝き度、白熱、バンプ、反射率、ディフューズがサポートされています。

SDK

新機能

  • PPG のサイズと位置の取得と設定: オブジェクトモデルの PPGLayout と C++ API に新しいメソッドと関数が追加され、プロパティエディタのサイズと位置の設定と取得ができるようになりました(PPG)。オブジェクトモデルと C++ API の SetViewSize、SetViewPosition、ViewSize、GetViewPosition を参照してください。
  • Undo API: オブジェクトモデルと C++ API のアプリケーションに新しいメソッドと関数が追加され、undo コンプレックスを開閉できるようになりました。コマンドを取り消すか再試行する場合に TRUE を返します。オブジェクトモデルと C++ API の OpenUndo、EndUndo、IsUndoing を参照してください。
  • UV プロパティ固定 API: クラスタコンポーネントを固定または固定解除するための新しい C++ とオブジェクトモデル API です。この API は主に UVUnfold 機能で使用します。オブジェクトモデルと C++ API の UV プロパティを参照してください。
  • Schematic ビューとノード API:
    • Schematic ビューを操作するための新しい C++ とオブジェクトモデル API です。オブジェクトモデルと C++ API の Schematic と SchematicNode を参照してください。
    • 新しいメニューアンカーポイント: siMenuSchematicViewID、siMenuSchematicViewContextID、siMenuSchematicNodeContextID。
    • SDK サンプルワークグループに新しい SchematicDemo サンプルをが追加されました。
  • Scene Layer Manager API:
    • 新しいメニューアンカーポイント: siMenuSceneLayerManagerLayersID と siMenuSceneLayerManagerContextID。
    • 新しいビューアトリビュート selectedlayer が追加されました。View.GetAttributeValue のみで利用可能です。
  • 新しいイベント:
    • siOnBeginCommand: コマンドを実行しようとするときに発生します。このイベントを使用すると、コマンド実行の中断、コマンド引数の値の修正、またはほかのコマンドの起動を行うことが可能です。
    • siOnEndCommand: コマンドが実行されたときに発生します。イベントを使用すると、コマンドの戻り値または出力引数の値にアクセスできます。ほかのイベントタイプとは異なり、このイベントは、カレント コマンドが前のイベントで中断されると必ず発生します。
    • siOnRenderAbort: ユーザがレンダシーケンスを中断したときに発生します。シーンを変更した結果レンダ領域のジョブを再実行した場合、このイベントも送信されることがあります。
    • siFileTypeAction のための ActionSource のサポートが siOnBeginFileImport イベントと siOnEndFileImport イベントに追加されました。siOnBeginFileExport/siOnEndFileExport イベントと siOnBeginFileImport/siOnEndFileImport イベントが、アクションとシェイプアクションをサポートするようになりました。
  • インタラクティブなTool SDK:
    • 3D ビューで使用可能なプラグインツールをビルドするための新しいToolContext が C++ API に追加されました。
    • Tool SDK で使用する新しい計算クラス CLine と CPlane
    • プラグインマネージャにツールウィザードが実装されました。
    • 新しいカスタムツールサンプルが SDK サンプルワークグループに追加されました。
  • イメージクリップとビットマップコントロール:
    • PPGLayout の新しいイメージクリップコントロール(siControlImageClip): イメージクリップを表示するコントロールが追加されました。文字列パラメータでイメージクリップの完全名が設定されます。サポートされているアトリビュートは TRUE に設定した siUIShowClip で、イメージクリップコントロールのサムネイルが表示されます。このコントロールのツールバーは、アトリビュートの値にかかわらず常に表示されます。
    • スタティックビットマップコントロール(siControlBitmap): siUIFilePath を使用してビットマップを表示するように設定します。
    • どちらのサンプルも、SDK サンプルワークグループの PSetUIDemo を参照してください。
  • メニューチェックマークのサポート: オブジェクトモデルと C++ API のメニュー項目に、メニューのチェックマークをサポートするための新しいメソッドと 2 つの関数が追加されました。オブジェクトモデルと C++ API. の MenuItem.Checked、MenuItem::IsChecked、MenuItem::PutChecked を参照してください。
  • Python のスクリプティングショートカット: 新しいオブジェクトモデルのショートカットが siutils.py に追加され、python のスクリプティングが簡単になりました。
  • SDK での動作変更:
    • Layout.CreateView メソッドと Layout::CreateView 関数で作成したビューの名前が表示されるようになりました(タイトルバー)。
    • 元に戻す回数をスクリプトで恒久的に変更することはできなくなりました。これにより、スクリプトで元に戻す回数を 0 に設定してパフォーマンスを上げると戻せなくなり、異常終了する問題を回避できます。

オブジェクトモデルの変更点

  • 新しいオブジェクト
    • Schematic
    • SchematicNode
    • UVProperty
  • 新しいメソッド
    • Application.OpenUndo
    • Application.EndUndo
    • Application.IsUndoing
    • MenuItem.Checked
    • PPGLayout.SetViewSize
    • PPGLayout.SetViewPosition
    • PPGLayout.ViewSize
    • PPGLayout.GetViewPosition
  • 新しい定数
    • siControlImageClip
    • siControlBitmap

C++ API の変更点

  • 新しいクラス
    • CLine
    • CPlane
    • Schematic
    • SchematicNode
    • ToolContext
    • UVProperty
  • 新しい関数
    • Application::EndUndo
    • MenuItem::IsChecked
    • Application::IsUndoing
    • Application::OpenUndo
    • PPGLayout::GetViewPosition
    • MenuItem::PutChecked
    • PPGLayout::SetViewSize
    • PPGLayout::SetViewPosition
    • PPGLayout::ViewSize

スクリプティングコマンドの変更点

  • 新しいコマンド
    • CreateLayerGroup
    • FBXGetPluginVersion
    • FBXGetSDKVersion
    • PinAllUVComponents
    • PinUVComponents
    • UnpinAllUVComponents
    • UnpinUVComponents


修正事項

これは Softimage 2012 の開発中に行われた修正です。

ユーザインターフェイス

FELX-1392	file browsers defaulting to desktop
FELX-1198	Weight editor does not refresh on object selection on newly duplicated objects
FELX-788	"Grow Selection" command buttons on custom toolbars doesn't work
FELX-605	Regression | Key properties have disapeared from the Profile curves PPG
FELX-799	Flipbook doesn't make LZW compressed Tiff files
ACSO-25		Animation Editor | Freeze with an animated boolean parameter
ACSO-213	Animation Editor | Freeze with an animated boolean parameter
ACSO-55		Crash with TortoiseSVN on File Browser
ACSO-65		Hiding the Netview toolbar twice through scripting crashes Softimage
ACSO-73		A preference for Help Language Japanese is not kept
ACSO-105	Draggin some workgroup shaders in the render tree can create a different one	
ACSO-126	Save scene without RedrawUI kills collapse info of schematic.
ACSO-121	A radius of 0.01 is not small enough during paint brushing
FELX-1259	Exporer | Operators no more shown under Camera Primitive
FELX-991	Loading a scene not in a project will create an invalid entry in the Recent Scenes menu
FELX-142	Request for a STOP button in playback

テクスチャリング

FELX-953	ACSO-166 - TextureSpaceWidget does not differenciate objects under Models
FELX-992	one-click interop: Softimage should respect TIFF tag to avoid upside down images
FELX-1493	UV Pinning undo problem
ACSO-64		Multiple Image Properties cannot edit at a time


モデリング

ACSO-22		Crash when transferring in a single step all properties between meshes
ACSO-58		Camera-view display is corrupt when using Tweak User Normals Tool and Add Edge Tool

リアルタイムシェーダ

ACSO-21		RTS | Annotations with indices (e.g."sas.directionallight[2].color") are not supported properly
ACSO-74		PPGLayout update problem in 2011 RT shader
ACSO-75		siNotInspectable flag update problem in 2011 RT shader
ACSO-77		Crash setting camera mode to OpenGL with ultimaper scene
FELX-1624	artifacts when painting vertex colors in realtime shader opengl viewport on meshes using custom realtime shaders.


リファレンスモデル

FELX-1670	FELX-1386 (Expressions on a material lost when you rename a reference model ) not fully fixed
FELX-1506	Texture map in reference models breaks upon delta creation
FELX-1778	Import Reference Rig and Import REferenced Skinned mesh causes Softimage to Crash
FELX-1883	Crash persisting scenes
FELX-1813	Shaders don't always connect or display properly upon loading scene
FELX-1558	RefModel : Setting resolution and apply constraint child objects will not update correctly
FELX-1555	RefModel : Expression is not updated when merge scene
FELX-1289	RefModel : Primitive is shifted incorrectly to another layer after applying MoveObjectToLayer
FELX-1750	Scene Material Corruption with Ref Models - Continued
FELX-1702	Disconnected shaders when importing Referenced Model
FELX-1686	Expression on Material of a Model is lost after Importing the Model
FELX-1651	Scene Corruption in Felix due to Material

キャッシュ

FELX-749	Cache - Load shape attribute (that reference object in the scene) might be bound to the wrong object
FELX-726	Caching - Load cache doesn't create attributes definitions if the first frame in the timeline isn't cached
FELX-718	Cache manager - Read -> Apply All should load the cache in the mixer with a scale corresponding to the subframe sampling
FELX-1365	ICE Cache: Can't read all Lagoa attributes (crash)
FELX-1361	Cache Manager: Start End Frames never persisted
FELX-1360	Cache Manager: Two caches loaded instead of one

FBX

FELX-1836	FBX warnings shouldn't pop UI when imports occcur at cmd line.
FELX-1772	objects sent from 3ds Max do not update
FELX-1064	FBX: Node conecting to the reflectivity port of Lambert is missing during export
FELX-1024	FBX scriptings commands missing in Help and softimage.wiki.softimage.com
FELX-1884	OneClick Maya: Need a Send Entire Scene Option
FELX-1842	Mudbox OneClick: Different updates from Mudbox have the same results in Softimage.
FELX-316	Ability to import and export stereo camera rigs in FBX plug-in and ICEFLOW.
FELX-1576	ICEFLOW - Need better warning when sending stuff from XSI to Max without having sent nothing from Max first.

ICE

FELX-1142	Corrupt frame numbers with "String File Path Sequence" ICE node
FELX-363	SDK ICE: Multi-Phase Node fails to pull Data
FELX-373	ICE 'Cache on File' node: File Name & co parameters not visible when 'Read Cache'
FELX-1148	setdata to envelope map problem
FELX-1209	ICE | New node to get per element data into a singleton array
FELX-1771	Lagoa Crash | Rotating Object that has a child emitter
FELX-996	Lagoa scenes and compounds should be updated to comply with sub-frame interpolation.
FELX-377	Lagoa Collision Add Passive Body
FELX-364	Lagoa Preset images path is wrong
FELX-1323	ICE and lights: "Get data" node the "This." statement doesn't always work.
FELX-1283	ICE | Get Data with self.kine.global works no more on Camera Primitive (compared to Softimage 2010)
FELX-1112	crash connecting stuff up that shouldn't be
FELX-959	ICE | GetSetAnd acts like GetSetOr



レンダリング

FELX-1741	Frame token padding behaves differently than documented. Docs are inconsistent.
FELX-1358	More than one dash (-) in a frame set, crashes Softimage
FELX-1838	Saving a rendered frame from the Preview Window without setting a file format results in .avi file
FELX-1634	Texture projections do not render correctly if named "color"
ACSO-110        Add the possibility to choose the Vertex Color Display Property from the Brush Properties PPG
FELX-1649	PPG Logic OnChanged can't be use for Color parameters.
FELX-183	Ability to set default fileformat for saved Preview image
FELX-1803	Texture Editor: Add UV pinning to TE operations
FELX-677	Allow users to set maximum OpenGL texture width to values greater than 2048
FELX-1419	Problem loading scene if rendertree Node name and ports are the same
FELX-1545	MR Notification Problem | render region refreshes but does not render is not updated
FELX-1430	Discrepancy between OGL and Mental ray display of ICE Color Attribute
FELX-549	Using Geometry based Area Lights Dampens other lights
FELX-792	CRASH Rendering With Irradiance Particles
FELX-1239	Notification filtering through connections is missing scalar ouptut nodes in the renderer process callback
FELX-1235	Scene render options reports wrong frame range with getValue()
ACSO-31		Invalid render region dimensions after being resized interactively
ACSO-35		3rd party renderers (e.g. Arnold) crash on Linux
ACSO-44		Custom renderer DirtyList isn't cleared properly
ACSO-45		AbortEvent breaks 3rd party renderers
ACSO-46		libsiutilityshaders shader dependency

キャプチャと合成

FELX-190	Default value for preferences.Compositing.MaxCPUThreads to 8
FELX-1441	Missing compression slider for .jpg in Viewport Capture. Also set default JPG quality to 100%

SDK

FELX-1719	SDK Doc: OneClick commands not documented
FELX-1776	SDK Example: New python TCP server example
FELX-1463	SDK: Csharp plugin items stop working after NewScene
FELX-1654	BoxTransformTool example manipulator fails on objects without geometry (lights, nulls, ...)
FELX-1284	Crash when opening a Scintilla instance once the PythonWin Debugger has been opened
FELX-1903	Can't set GUID_PropertyMappingAttribute with the ShaderParamDef API.
FELX-562	More Menu anchor Points and Access to View Attributes
FELX-1562	Custom Property Wizard is buggy
FELX-1596	When uninstalling Softimage XSIPython removes python from all previous Softimage installations
ACSO-130	PlotConstrainedTransforms command always popup dialog.
ACSO-175	FCurve.RemoveKeys and FCurve.RemoveKeysAtIndex don't refresh the FCurve Editor and the timeline
ACSO-72		SDK: "ClassName" of assigned material does not get expected class.

This page was last modified 23:08, 7 Apr 2011.
This page has been accessed 9962 times.

© Copyright 2009 Autodesk Inc. All Rights Reserved. Privacy Policy | Legal Notices and Trademarks | Report Piracy