New Features for Softimage 2010 (version 8.0)


Here is a detailed summary of the new features and enhancements available in Autodesk Softimage 2010:



Interface and Tools

Essential Skills Movies

If you are new to Softimage, watching the Essential Skills movies is a great place to start. Each movie provides an introduction to the basic Softimage concepts you need to know before trying more complex projects. These movies launch the first time you start Autodesk Softimage, but you can refer to them again from the Help menu.

Autokeying Camera Navigation

You can set up specific cameras and spotlights so that their parameters get keyed automatically during navigation.

See Autokeying Camera Navigation (http://softimage.wiki.softimage.com/xsidocs/view_viewing.htm).

Display Type Menu

Middle-clicking on the Display Type menu at the upper right of viewports no longer re-opens the Camera Display options or Rotoscopy Options property editor if that was the last action you performed on the menu. Now, middle-clicking only switches between the last two display modes or toggles other options, depending on the last action you performed.

Hide on Playback

There is a new visibility option: View Playback Visibility determines whether objects are visible in the 3D views during playback. For example, you may want to hide bones and controllers to show only geometry on a character. Hiding objects can also increase playback speed. This option is available in the Visibility property editor of individual objects, as well as in group, layer, and partition property editors.

New Scintilla Features for Text-Based Editors

Various text editors in Softimage are now based on Scintilla. This includes the script editor, scripted operator editor, and expression editor, as well as the text control in the property editors of programmable realtime shaders. Some of the Scintilla features that are available include:

  • syntax highlighting (language-specific keywords appear in unique colors)
  • folding (allows you to hide or show code blocks, such as functions or other syntactic blocks, by clicking on a collapse/expand widget)
  • shared text editing preferences
  • standard search tools
  • standard and alternative key mappings for copy, cut, paste, etc.

For more information, see Using the Script Editor (http://softimage.wiki.softimage.com/sdkdocs/script_editor.htm).

Preset Manager

The preset manager now refreshes automatically when you connect to a workgroup.

Scene Search View and Quick Filter Box

The Quick Filter box and Scene Search view are both tools to help you find elements in your scene:

  • The Quick Filter box appears in the menu bar of the main Softimage window. It is useful for quickly finding objects in the scene by name.
  • The Scene Search view is a floating window with more options. You can search the scene or the current selection, find elements by type, and filter the results.

See The Quick Filter Box and Scene Search View (http://softimage.wiki.softimage.com/xsidocs/ui_windows.htm).

Shelves

Shelves now display scroll bars automatically when their contents don’t fit in the available space.

Showing and Hiding Manipulators

You can hide the tool manipulators, such as the Transform manipulator and others, in a viewport. This lets you see the final result in one viewport unobstructed by any manipulator, while still being able to work with manipulators in the other viewports.

Undoing Changes to Color Values

You need to press Ctrl+Z only once to undo changes to color values in HLS and HSV modes. You no longer need to press Ctrl+Z once for each of the RGB channels.

Netview

You can drag and drop links to shader compounds into the render tree to add them to the workspace.

Scene Elements

Deleting Elements Permanently

If you a certain that you want to delete something, you can delete it permanently using Shift+Delete. This is quicker than deleting in the usual way, but it removes the possibility of undoing the deletion and anything else you did previously.

Note also that Edit > Delete All is no longer mapped to Shift+Delete.

For more information, see Deleting Elements (http://softimage.wiki.softimage.com/xsidocs/scel_basics.htm).

Layer Groups

Scene layers are organized into groups. Scene layer groups let you easily set the visibility and other settings of multiple layers at once.

For more information, see Scene Layers (http://softimage.wiki.softimage.com/xsidocs/scel_layers.htm).

Data Management

Scalability and Performance

Improved scalability and performance of many commonly used tools has significantly improved the user experience and workflow within the application.

Many core areas have been optimized:

  • Loading and saving
  • Selecting
  • Deleting
  • Undoing and redoing
  • Freezing
  • Using referenced models
  • Duplicatiing
  • Removing animation
  • Usingt the function curve editor
  • Hiding and unhiding
  • Opening property editors that display the properties of many objects
  • Switching between transform tools
  • Changing marked parameters

Analyzing Scene Performance

You can analyze the performance of a scene using the Scene Debugger. This can tell you the processing time and memory consumed by the elements in your scene, and help you to find and correct things that are slowing it down. See Analyzing Scene Performance and Memory (http://softimage.wiki.softimage.com/xsidocs/data_scenes.htm).

Getting Version Information

You can get the version of Softimage used to create a particular scene using various methods: on scene load, from the scene TOC, programmatically, or using the printver standalone utility.

In all cases, the version information is specified in the format of Major.Minor.BuildNumber.UpdateNumber (for example, “8.0.114.0”). Prior to Softimage v.7.5, the format of the version information was Major.Minor.YYYY.MMDD (for example, "6.02.2007.0605").

It is important to note that Softimage’s internal version number may not match the one used in its product display name. For example, 8.0 is the internal version number for Autodesk Softimage 2010. Version 2010 is used in the product name for the splash screen and install path, but the scene information and the Softimage SDK will return the version number as 8.0.

For more information, see Methods for Getting Version Information (http://softimage.wiki.softimage.com/xsidocs/data_scenes.htm).

Referenced Models

There have been numerous bug fixes and optimizations for referenced models. In particular, several issues involving animation layers and constraints have been resolved.

Converting Referenced Models to Local

If Softimage determines that the referenced model contains a material that already exists in the scene, you are asked whether you want to copy or share it. For more informatioon, see Converting Referenced Models to Local (http://softimage.wiki.softimage.com/xsidocs/data_models.htm).

Crosswalk 4.0

Softimage 2010 ships with Crosswalk v.4.0. These are the new features and improvements that have been incorporated into the Crosswalk toolset since the last release of Softimage.

Crosswalk for Softimage

dotXSI Export

The version of Crosswalk used to export a dotXSI (*.xsi) file is now included as part of the SI_FileInfo template:

SI_FileInfo { 
   "My_Project", 
   "My_Username", 
   "Mon Jun 01 15:58:46 2009", 
   "Autodesk Softimage version 8.0.96.0 - Crosswalk 4.0", 
}

COLLADA Export

The version of Crosswalk used to export a COLLADA (*.dae) file is now included as part of the <contributor> element:

<asset>
   <contributor>
       <authoring_tool>Autodesk Softimage version 8.0.96.0 - Crosswalk 4.0</authoring_tool>
   </contributor>
       <created>2009-06-01T20:06:26Z</created>
       <modified>2009-06-01T20:06:26Z</modified>
       <revision>1.4.1</revision>
       <unit meter="0.1" name="decimetre"></unit>
       <up_axis>Y_UP</up_axis>
</asset>

FBX Import and Export

Crosswalk for FBX now uses FBX 2010.0.

Crosswalk for Max

Supported versions of 3ds Max

Crosswalk for Max supports 3ds Max 2008, 3ds Max 2009, and 3ds Max 2010.

Crosswalk for Maya

Supported versions of Maya

Crosswalk for Maya supports Maya v8.5, Maya 2008, Maya 2009, and Maya 2010.

Modeling

User Normals

There is a new interactive Tweak User Normals tool as well as several new commands for setting user normals (also known as explicit normals) on polygon mesh objects. See Setting User Normals on Polygon Meshes (http://softimage.wiki.softimage.com/xsidocs/poly_shading.htm).

Transferring Attributes

You can now transfer user normals when generating a polygon mesh from other meshes or by applying GATOR. See Attribute Transfer (http://softimage.wiki.softimage.com/xsidocs/modef_building.htm).

Changing the Display Size of Normals

You can change the display size of shading normals in the 3D views. This affects normals on NURBS surfaces as well as polygon meshes.

The size is controlled by the Normal Scaling parameter on the Component Display tab of your Display preferences.

Controlling Polygon Tessellation

You can see how quads and n-gons get tessellated into triangles for display and rendering, and you can control the placement of the internal edges by “turning” them using the new Turn Polygon Internal Edges command. This is useful for avoiding long, thin triangles that deform and shade poorly. See Controlling Polygon Tessellation (http://softimage.wiki.softimage.com/xsidocs/poly_shading.htm).

Lattice Deformations

The new Amplitude parameter controls the strength of the deformation. You can also connect a parameter map to modulate the strength of the deformation across the surface of an object. For more about lattices in general, see Lattices (http://softimage.wiki.softimage.com/xsidocs/modef_deforms.htm).

Animation

Fcurve Editor Performance

Performance improvements span multiple areas:

Selection: Selecting curves, keys, and tangents has been dramatically improved.

Drawing of Tangents: Each key can show tangental controls allowing even more detail to be displayed.

Memory Management: The amount of memory the function curve editor uses has been reduced to its minimum. Also the memory usage has been improved when changing the selection.

Curve Processing: Smooth, Fit and Resample with many curves now performs better.

Open/Close: When the function curve editor is opened, all the function curves, keys, and objects populate the view. This one time operation is now much faster. The same is true for closing the view.

Fcurve Spline Slope Command

If you liked the automatic spline slope from versions of Softimage previous to v7.0, there’s a command and preference for you!

The Keys > Spline Slope command in the fcurve editor works in the same way as the Automatic Slope option worked in versions previous to v7.0: it computes the orientation and length of a key’s slope based on the interpolation of the fcurve between the previous key and the next key (neighboring keys), but with no plateau influence.

You can also set a preference to have this as the default slope behavior when adding new keys to a curve: select the Keys > Slope Computation Constraint > Automatic Spline (from neighboring keys) option in the Animation Preferences property editor.

For more information about fcurve slopes, see Editing a Function Curve’s Slope (http://softimage.wiki.softimage.com/xsidocs/ani_fcurves.htm).

Animation Layers and Applying Actions and Plotting

There has been a change in the behavior of animation layers and applying actions or plotting animation:

  • When you apply action sources back to an object that also has animation layers, the layers now remain intact (they are not deleted).
  • When you plot the base animation of an object that also has animation layers, the animation layer’s keys are deleted over the same frames as those of the plotted base animation.

Character Animation

Approximate Envelope Operator

There is a new performance feature for approximate envelope deformations that gives as much as double the performance of standard envelopes when interacting and playing back in the 3D views. See Approximate Envelope Deformations (http://softimage.wiki.softimage.com/xsidocs/char_envelopes.htm).

Weight Paints Panel

The Weight Paint panel embedded in layouts now supports narrow width.

Autodesk® Motion Builder® Template Rig

If you work a lot with Motion Builder, try out the new Get > Primitive > Character > Motion Builder Template biped rig. This rig shows you the typical hierarchy and naming conventions that are used in Motion Builder.

Any biped animation you import from Motion Builder can then seamlessly drive this rig. You can then constrain a Softimage character to this template and plot the animation from the template to your Softimage character. See Character Rigging (http://softimage.wiki.softimage.com/xsidocs/char_rig.htm).

Using the Viewport's Display Mode to Display Bones

In a bone’s Chain Bone property editor, you can select the new Use Display Mode option to display chain bones and their shadows using whatever is the current display mode set in the viewport—Shaded, Constant, DepthCue, or Hidden Line mode, as well as Wireframe. This is a visual reference only—the bones are not rendered. See Displaying Chain Elements (http://softimage.wiki.softimage.com/xsidocs/char_skel.htm).

Behavior Export Tool

The Behavior Export tool that was automatically installed as an add-on with Softimage has been removed from the software.

The Behavior Export section of the Softimage User's Guide is available for reference on the Legacy documentation page.

Face Robot

Say hello to the new kid on the block, Softimage® Face Robot®! The Face Robot product has been integrated into this version of Softimage. What is Face Robot, you may ask? It is a suite of tools that work together to help you easily rig and animate life-like faces, no matter what that face looks like!

Image:aa1101e4.jpg

With Face Robot, you can:

  • Create realistic, expressive facial animation for games, film, and television productions.
  • Develop ultra realistic real-time facial animation for games. Even at low resolutions, the quality is amazing.
  • Bring a Face Robot rigged and animated head into the Autodesk® Maya® or other 3D software for use in your projects.

Face Robot realistically and consistently simulates how the soft tissue of the human face slides and deforms. Instead of building shapes for each facial expression, the soft tissue of the face can be manipulated directly through the salient features of facial anatomy, such as the corners of the mouth, the eyebrows, the jaw, and so on.

Face Robot lets you quickly set up a facial rig by taking you through several stages. Once you have a facial rig, you can animate the facial controls and sculpt and tune the facial tissue using familiar Softimage tools, as well as some Face Robot-specific ones.

To enter into Face Robot mode, choose Face Robot > Enable Face Robot from the main menu at the top of the Softimage window.

To get started with Face Robot, see:

  • The Face Robot (http://softimage.wiki.softimage.com/xsidocs/face_cover.htm) guide
  • Face Robot Learning Movies
  • Face Robot sample scenes that are installed with Softimage. There are scenes for each of the six Face Robot stages, as well as others that include applied mocap and tuned heads.

Using Face Robot on Linux

The Face Robot layout interface is not currently available on Linux, so you cannot edit Face Robot scenes. However, you can load, play back, and render Face Robot scenes.

This is what happens when you load a Face Robot scene into Softimage on Linux:

  1. A message box informs you that Face Robot will be enabled to continue. Face Robot is never enabled automatically when starting Softimage.
  2. The scene is loaded again in Face Robot mode, but the Face Robot layout is not displayed.
  3. When closing the scene, Face Robot mode is automatically disabled.

Note that you cannot enable/disable Face Robot mode from the Softimage interface because there’s no Face Robot menu, but you can use a script command (EnableFaceRobot or DisableFaceRobot).

Texturing

Normal Maps

The new XSI Normal Map 3 shader replaces XSI Normal Map 2.

  • There is an option to specify unbiased normals. Together with the previously existing option to specify unbiased tangents, this means that you can use biased normals with unbiased tangents and unbiased normals with biased tangents.
  • The Advanced tab lets you repeat and alternate the normal map across a surface.

RenderMap

Previously, when setting View to Scene Camera, the perspective used was still orthographic. Now the perspective of the scene camera is used. This corrects a slight shift in specular highlights.

Ambient Occlusion and Bent Normal Maps

Both RenderMap and Ultimapper support the output of bent-normal maps, as well as all the options available in the Ambient Occlusion shader (previously only a subset of the options were available).

For more information about RenderMap and Ultimapper in general, see Baking Surface Attribute Maps (http://softimage.wiki.softimage.com/xsidocs/tex_baking.htm) and Transferring Surface Attributes (Ultimapper) (http://softimage.wiki.softimage.com/xsidocs/tex_transfer.htm).

Texture Editor

There is a new item on the Clips menu: Auto displays the image clip associated with the UV coordinates currently selected for editing. If this is on when you select a different object in the scene and update the texture editor, the texture editor automatically displays the appropriate clip. Explicitly selecting a different clip toggles the Auto option off, but you can choose Auto again to toggle it back on.

Support for DDS Output Format

Softimage can now output the DirectDraw Surface (*.dds) file format from the Render Channel (Framebuffer) Property Editor, the RenderMap Property Editor, and the Ultimapper Property Editor.

The following uncompressed subformats are supported:

  • A8R8G8B8 Unsigned
  • A16B16G16R16F Half float
  • A32B32G32R32F Float

SI_OGL13TEXTURE_FLOAT_INTERNAL_FORMAT

If you are having difficulty displaying float or half-float texture images defined in a realtime render tree using the OGL13Texture node, you can manually set a size-specific internal texture format with the SI_OGL13TEXTURE_FLOAT_INTERNAL_FORMAT environment variable. You must specify an integer value for the format that you require. For example:

 set SI_OGL13TEXTURE_FLOAT_INTERNAL_FORMAT=34836

Where GL_RGBA_FLOAT32_ATI 0x8814 is expressed as the integer 34836 (this is the default setting).

Note that not all OpenGL implementations support all the available internal texture formats. Requesting a format does not mean that your texture is guaranteed to be stored in this format. Your OpenGL implementation will give the most appropriate internal texture format available and this may result in a size-specific format that provides less or more precision than you requested.

Rendering, Shaders, and Materials

mental ray Renderer

Softimage 2010 integrates mental ray version 3_6_53_23.

Render Tree View

  • Several improvements have been made to the render tree view. These are the same as have been done for the ICE tree view—see [#Raa17556 ICE Tree View Improvements].
  • You can now drag a material preset from the preset manager (with Materials selected) into the render tree. This adds the material’s shader tree into the workspace without connecting it to the object’s current Material node. You can then hook it up as you like.
  • You can now drag and drop links to shader compounds from the Netview into the render tree workspace. You can then hook up the compound in the tree as you like.

Nested Shader Property Editors

A single property editor can display multiple property sets (also referred to as nested property editors). This behavior has changed for property editors displayed for nodes in a render tree. When you open the property editor of a node in a render tree, the property editors of other connected nodes are nested (or not) as follows:

  • Opening the property editor of the material node in a render tree will display the nested property editors of the shaders connected directly to the material node’s input ports. This behavior has changed from the previous version of Softimage where all connected shaders in a render tree were displayed in the material node’s property editor.
    • In this render tree example the property editor for the Glass_and_Label material node (A) displays the Mix_2colors (B) and Phong (C) shader property editors which are connected directly to its input ports. The same is true when you open the property editor of the light node in a render tree: only those shaders that are connected directly to the light node’s input ports will appear nested in its property editor.

Image:aa11023b.jpg Image:aa110248.jpg


  • Opening the property editor of any shader node in a render tree will not display the property editors of other connected shaders or image clips. A shader node displays only its own properties.
  • Opening the property editor of a shader compound in a render tree will not display the property editors of other connected shaders or image clips. A shader compound displays only its own properties.

Material Manager Favorites and User Tabs

The new Favorites tab in the material manager lets you create and collect shortcuts to materials that you want to keep handy. When you drag and drop a material from a library onto this tab, it creates a shortcut to where it is in the material library.

You can also create your own custom “favorites” tabs to collect and sort the material shortcuts as you like. In the material manager, choose the Libraries > New User Tab command, then drag material presets from the libraries onto this tab. Select the tab and choose Libraries > Delete User Tab to delete it.

The Favorites and custom user tabs aren’t “real” material libraries: they’re simply tabs where you can collect shortcuts to the materials. Dragging materials to these tabs doesn’t make copies of the materials.

Image:aa110254.jpg

Exporting Material Libraries

  • When you’re exporting a material library, you can select the new Export Used Image Clips Only option in the export browser. This exports only the image clips that are used by the materials of the material library that you are exporting. If this option is off, all image clips in the scene are exported with the library.
  • You can now import and export material libraries as material library files (.xsiml). Material library files are the same basic format as dotXSI files except that they contain only material library information. The .xsiml extension helps you easily distinguish these files from regular .xsi files.

See Importing and Exporting Material Libraries (http://softimage.wiki.softimage.com/xsidocs/mat_materials.htm).

Material Manager Preferences

The following options relating to shaderball and image clip thumbnail display performance and keywords have been added to the Material Manager Preferences :

Performance


Turn Off Rendering of Shaderballs

Turns off the rendered display of the shaderballs for shaders displayed in the material shelf. This helps optimize the performance of the material manager.

If you select this option, shaderballs are shown as either just the color square of the material or else the last rendered shaderball version.

If you are working with the render tree and it has shaderballs turned on, the material’s shaderball there is updated as usual, but the shaderball in the material manager shelf doesn’t update until you click on it. This lets you turn off the shaderballs for all shaders except the ones that you are working with in the render tree.

Turn Off Image Clips Thumbnails

Turns off the display of thumbails for the image clips in the Image Clip explorer on the left side of the material manager.

Save Image Clip Thumbnails in a Sub-Folder

Saves image clip thumbnails in a subfolder that’s defined with the Images > Generate Thumbnail option in the Rendering Preferences.

It generates a thumbnail along with an image proxy, which is a scaled-down copy of the images that you use in your scenes. The thumbnails are stored in their own subdirectory alongside the proxies’ directories.


Material Shelf


Match Keywords

Sets the options for displaying materials in the shelf based on the keywords you select in the Keywords list:

  • With Match Any Keywords (OR), any materials that match the selected keywords are displayed in the shelf. For example, if you select “blue” and “striped” in the keyword list, any materials that have either (any) of these keywords are displayed.
  • With Match All Keywords (AND), only the materials that match all the selected keywords are displayed in the shelf. For example, if you select “blue” and “striped” in the keyword list, only materials that have both (all) of these keywords are displayed.


Bottom Tabs


Image Clips

Sets the size for the thumbnails used in the Image Clips tab in the lower pane of the material manager: Small, Medium, or Large Icons. The List View displays the clips in a list with very small icons.

Who Uses?

Sets the size for the thumbnails used on the Who Uses? tab in the lower pane of the material manager: Small, Medium, or Large Icons. The List View displays the shaders in a list with very small icons.

Multi-Column List Views

If you select List View for either the Image Clips or Who Uses? tab, it displays the thumbnails in multiple columns instead of one list that you need to scroll.


DirectX Support

If you start Softimage without DirectX installed, you get the following warning: “WARNING : Unable to load D3DX9.DLL. DirectX 9 is not properly installed. Support for HLSL shader disabled.”

If you do not use the DirectX realtime shaders then you can ignore this warning. However, to use and display DirectX realtime shaders you must have DirectX 9.0c installed and your graphics hardware must support DirectX 9.0c.

Simulation

Legacy Particles

The legacy (non-ICE) particles are gone, gone, gone! This includes the ParticlesOp operator, the FluidOp operator, and the ExplosionOp operator and their related shaders: Particle Renderer, Particle Billboard, Particle Sphere, Particle Blob, Particle Sprite, Particle Shape, Particle Color, Particle Gradient, Particle Vector, Particle Scalar, and Particle Explosion.

The particles are, however, available for backward compatibility when you load in particle scenes from previous versions of Softimage.

The help topics for legacy particle-related property editors and particle shaders are still available when you click the ? icon in any of these property editors. As well, the Particles section of the Softimage user guide is available for reference from the [Legacy Documentation|legacy documentation page].

Commands on the Simulate Toolbar

Because of the removal of the legacy particles, the commands that were in the Modify > Environment menu on the Simulate toolbar now live with their simulation object types. The commands’ new homes are:

  • Cloth > Modify > Apply Force
  • Cloth > Modify > Set Obstacle
  • Cloth > Modify > Disconnect Obstacle/Force
  • Soft Body > Modify > Apply Force
  • Soft Body > Modify > Set Obstacle
  • Soft Body > Modify > Disconnect Obstacle/Force

Note that the Modify > Environment menu on the Hair panel is unaffected by this change.

ICE

ICE Tree View Improvements

There are several improvements to the interface and workflow of the ICE tree view:

  • Dragging a connection to the edge of the workspace automatically scrolls the view.
  • You can press Ctrl+F to quickly put the cursor in the preset manager’s text box so that you can start typing a search string. Pressing Ctrl+F will also temporarily display the preset manager if it is hidden.
  • Changes to the interface when editing compounds make it easier to see that the Name, Category, and Tasks strings can be modified.
  • When editing compounds, the side panels showing the exposed input and output ports can be collapsed for more screen space or expanded to show the port names. When there are more exposed ports than can be displayed at the same time, scrollbars appear.
  • Hover the mouse pointer over a connection to highlight the connected ports. If a port is not visible because it has been collapsed or because the view is zoomed out too far, information about the port is displayed in a pop-up. This also works when exposed ports of compounds are collapsed.

Performance Profiling

The ICE runtime message viewer has been removed. Instead, you can profile the performance of ICE trees by displaying execution times directly on nodes in the ICE tree viewer.

See Profiling the Performance of ICE Trees (http://softimage.wiki.softimage.com/xsidocs/ICE_trees.htm).

Blobs

There is a new attribute BlobStrength that controls how strongly the surfaces of blobs are pulled toward each other. At 0.0, there is no attraction and at 1.0, blob surfaces are pulled together regardless of distance. If this attribute is undefined, the default value is 0.5.

The BlobStrength parameter has also been added to the Blobs compound.

See ICE Particle Blobs (http://softimage.wiki.softimage.com/xsidocs/ipart_particles.htm).

Strands

The behavior of the StrandDeform attribute has changed. For instance shapes, if StrandDeform is true then the instances are deformed in Y along the length of the strands. If it is false or undefined, then the instances are simply placed at the discrete StrandPosition values.

Previously, if StrandDeform was true then instances were placed at the discrete StrandPosition values and if it was false or undefined then a single instance was drawn at the PointPosition only.

The behavior of StrandDeform has not changed for other supported shapes (Box, Capsule, Cone, and Cylinder).

Passive Rigid Body Particles

The new IsPassiveRigidBody attribute allows you to make ICE particles in a rigid body simulation into obstacles. If this attribute is true, the Simulate Rigid Bodies node treats the corresponding particles as passive. This attribute is necessary to use particles as obstacles, because all particles must be in the same point cloud to interact in a rigid body system.

The PointVelocity and AngularVelocity of a passive rigid body are not taken into account during a collision, and are unchanged after a collision. It’s as if the passive rigid body has infinite mass. However, the DynamicFriction and Elasticity of both the active and passive particles are taken into account during a collision.

Note also that the Simulate Rigid Bodies node does not update PointVelocity based on Force if IsPassiveRigidBody is true. If required, you can filter these particles and calculate a new velocity for them based on F = ma.

See Making ICE Rigid Body Particles Passive (http://softimage.wiki.softimage.com/xsidocs/ipart_rigidbody.htm).

Rotational Motion Blur for Particle Instances

The rotation of instanced shapes for ICE particles can now be rendered with motion blur. The motion blur is calculated using the particle’s AngularVelocity attribute.

See ICE Particle Instances (http://softimage.wiki.softimage.com/xsidocs/ipart_instances.htm).

Image:aa1102f8.jpg

Point Index to Location

There is a new basic node that converts a point index on a geometry to a location. You can then look up attributes at that location. For example, this makes it possible to get data at an index offset. For more information, see Point Index to Location (http://softimage.wiki.softimage.com/xsidocs/iceref_nodes.htm).

Wind Force

The Wind compound has been updated to be more physically accurate.

If you want to use the updated version of this compound in an existing ICE tree, you can either replace the old Wind compound manually in the ICE tree view or update its version with the Compound Version Manager.

See ICE Simulation and Forces (http://softimage.wiki.softimage.com/xsidocs/ice_simulation.htm) and Versioning Compounds (http://softimage.wiki.softimage.com/xsidocs/ICE_compounds.htm).

Uploading ICE Compounds

The ability to upload compounds directly from within the ICE Tree view has been removed because the ICE Compound Exchange section of Softimage|NET is in transition.

ICE Custom Node Creation in C++

Geometry Accessors: The Softimage SDK exposes access to geometry and sub-components. Custom ICE nodes can now query more attributes found on objects, such as edge lengths.

Multi-Phase Execution: The Softimage SDK exposes the execution of ports in custom nodes. Technical directors can now control which ports (or parts of a node) get executed and in which order.

Local Attributes

Each ICE graph can now store local attributes.

Documentation Updates

Layout and View XML Syntax

A section has been added describing the XML-based syntax used for layouts and views. See Layout and View XML Syntax (http://softimage.wiki.softimage.com/xsidocs/custom_layouts_views.htm).

Polygon Shading

There’s a new section on polygon shading. This is the new home for all the information about controlling automatic normals, including via geometry approximation, as well as new sections on setting user normals and turning internal edges, plus improved and expanded background information. See Polygon Shading (http://softimage.wiki.softimage.com/xsidocs/poly_shading.htm).

Legacy Particles

The Particles section for the non-ICE legacy particles has been removed from the Softimage User Guide. This section included information about using the legacy particles, fluid, and explosion operators.

This Particles section of the user's guide is available for reference from the [Legacy Documentation|legacy documentation page].

Note that help topics for legacy particle-related property editors and particle shaders is still available when you click the ? icon in any of these property editors.

Behavior Export Tool

The Behavior Export Tool section has been removed from the Softimage User Guide. This section included information about setting up a Softimage character so that it could be exported and used in the Behavior program.

The Behavior Export Tool section of the guide is available for reference from the Softimage wiki (http://softimage.wiki.softimage.com/index.php/Main_Page).

Motion Blur Shutter Settings

It is important to note that the Scene Motion Blur Settings (http://softimage.wiki.softimage.com/xsidocs/cam_motion_blur.htm) are the primary parameters for defining the motion blur effect. In particular, the Speed and Offset options are used to specify the shutter interval during which the geometry’s motion is evaluated for each frame. This motion data is then pushed to the renderer. If your renderer is mental ray (it is by default), you can use the mental ray Shutter and Delay options to further modify the size and length of the motion blur trails (without re-evaluating the geometry and its motion data). Do not use the mental ray Shutter and Delay options to define the motion blur, these options should only be used for tweaking the motion blur trails.

See Specifying the Shutter Interval (http://softimage.wiki.softimage.com/xsidocs/cam_motion_blur.htm) and the mental ray Shutter Settings (http://softimage.wiki.softimage.com/xsidocs/cam_motion_blur.htm).

ICE Cache on File Node

The information about specifying ICE attributes for the Cache on File node has been corrected. It was previously stated that attribute names specified in the Attribute List in the node’s property editor were cached in addition to the required attributes that Softimage automatically cached.

Instead, when you enter attributes in this list, they are the only attributes that are cached. By specifying only the attributes you want to cache, you can make the cache files quite a bit smaller in some cases.

See Caching ICE Simulations (http://softimage.wiki.softimage.com/xsidocs/ice_simulation.htm).

This page was last modified 19:41, 9 Dec 2010.
This page has been accessed 8778 times.

© Copyright 2009 Autodesk Inc. All Rights Reserved. Privacy Policy | Legal Notices and Trademarks | Report Piracy