Cleaning up Imported Meshes

Polygon meshes imported from other software can sometimes have problems like disconnected polygons, or even corrupt geometry like vertices that are not attached to any polygon. In turn, this can lead to other problems, especially when rendering.

Here are some techniques for fixing polygon meshes with problems:

  • To fix disconnected polygons, use Modify > Poly. Mesh > Filter Points.
  • To remove disconnected vertices, select all the polygons, select the adjacent points, invert the selection, and then delete the selected points. You could alternatively translate all the polygons to one side, select and delete the points that are left behind, and then return the polygons to their original position by deleting the MoveComponent operator in the stack.
  • A good way to fix many types of problem is to select all polygons, extract them to a new mesh using one of the Create > Poly. Mesh > Extract Polygons commands, and then freeze the result.


This page was last modified 17:14, 24 Oct 2005.
This page has been accessed 9164 times.

© Copyright 2009 Autodesk Inc. All Rights Reserved. Privacy Policy | Legal Notices and Trademarks | Report Piracy