Visual Studio (XSISDK)

This page is for tips related to the usage of Microsoft Visual Studio for compiling XSI C++ API Plug-ins. See also C++ Compilation. For 64-Bit compilation see Cpp 64 bit (XSISDK)

Table of contents

Visual Studio 6 (msdev)

For v4.2 and before this was the recommended compiler. It continues to work with v5 but the focus is moving to Visual Studio .Net (2003)

Visual Studio .Net 2003

This is the recommended compiler for XSI version 5.0. It should also be usable for previous versions but this was not tested.

Visual Studio 2005

XSI 5.0 was released before Visual Studio 2005 and was not tested or certified with that compiler.

However Daniel Collin on the XSI list reports success using Visual C++ 2005 Express (http://lab.msdn.microsoft.com/express/visualc/default.aspx).

The express product is interesting because it is Free/low cost, and offers all the basic features needed to compile C++ plugins for XSI.

For XSI 6.0, we recommend to use Visual Studio 2005. For compiling 64 bit dll, you need Visual Studio .NET 2005 Standard or greater package.

Visual C++ 2008 Express

Added info: With Microsoft Visual C++ 2008 Express, compiling 64 bit dlls is possible, using the method outlined [here (http://softimage.wiki.softimage.com/index.php/Cpp_64_bit_Visual_CPP_Express(XSISDK))]

Important: Fixing Link errors with the C++ API

By default with Visual Studio 2005 you will have link errors related to CString. These can be fixed by setting the option "Treat wchar_t as Build-in Type" to "No" (in the Configuration Properties -> C/C++ -> Language tab).

Ideally the XSI wizards will be updated to automatically set this new 2005 setting.

This page was last modified 02:46, 13 Dec 2010.
This page has been accessed 11667 times.

© Copyright 2009 Autodesk Inc. All Rights Reserved. Privacy Policy | Legal Notices and Trademarks | Report Piracy