Version 7.01

In addition to numerous bug fixes, XSI version 7.01 includes some new features and documentation updates:

Import Changes

Crosswalk 3.1

ICE

Realtime Shaders

Customization

Environment Variables

Documentation Updates

 

Import Changes

Importing Autodesk 3DS Files

The File > Import > Import 3ds feature has been removed from XSI.

Instead, you can use the File > Crosswalk > Import feature to import scenes that have been output from a Crosswalk-enabled 3ds Max installation using the dotXSI file format.

Importing a Face Robot Shape Animation Rig

You can now import a Face Robot rig into XSI. This is supported only on Windows platforms.

If you have a Face Robot animation rig already imported into an XSI version 6.x scene, you can load that scene into XSI version 7.x, but Softimage does not officially support this workflow. Additionally, you will not be able to take advantage of the ICE architecture that was introduced in v7. It’s recommended that you re-export the animation rig from Face Robot and then import it directly into XSI v7.x instead of opening the XSI v6.x rig scene in XSI v7.x.

To import the Face Robot rig into XSI

1. Using the Animation Rig Export tool in Face Robot, export the solved head as a shape-based rig in a .dotxsi file.

2. In XSI, choose File > Import > Face Robot Shape Animation Rig.

3. In the dialog box that appears, select the .dotxsi file you exported from Face Robot and then click the Import button.

The rig with its animation controls (represented as small green boxes) is imported into XSI in a model called Face_Animation_Rig.

If you exported the animation on the controls, you’ll see red ticks in the timeline at each frame, which represent the keys on the controls. To check the control’s fcurves, select a control and open the animation editor.

You can select the head and open the animation mixer to check that each control has a shape compound clip on a track that contains all its shape clips. Double-click on the shape compound clip to open it and see the shape clips.

Crosswalk 3.1

XSI v.7.01 ships with Crosswalk v.3.1. These are the new features and improvements that have been incorporated into the Crosswalk toolset since the last release of XSI.

Crosswalk for XSI

Export Options

• The Export options group has been renamed to Exported Data.

• The new options in the Exported Data group allow you to further specify the type of data you want to export:

Materials

When this option is on, all materials defined in the scene are exported, regardless of whether you are actually exporting the entire scene or just a selection.

When this option is off, the Image Clips and Used Materials and Image Clips Only options are no longer available. The reason for this is because when Crosswalk removes all the materials, all the image clips are also removed.

To export all materials (whether they are being used or not) without any image clips, select the Materials checkbox and deselect the Image Clips and the Used Materials and Image Clips Only checkboxes.

To export all used materials only (without any image clips), select the Materials and Used Materials and Image Clips Only checkboxes and deselect the Image Clips checkbox.

To export all materials and all image clips (whether they are being used or not), select the Materials and the Image Clips checkboxes and deselect the Used Materials and Image Clips Only checkbox.

Image Clips

When this option is on, all materials and all image clips defined in the scene are exported, regardless of whether you are actually exporting the entire scene or just a selection.

When this option is off, none of the image clips defined in the scene are exported.

Note that you cannot export image clips only without materials. When the Materials option is off, the Image Clips and Used Materials and Image Clips Only options are no longer available. The reason for this is because when Crosswalk removes all the materials, all the image clips are also removed.

Animation

When the Animation option is on, all animation defined in the scene is exported.

When the Animation option is off, none of the animation defined in the scene is exported. In addition, the Animation > Shapes, Animation Plotting, Animation Resampling, and Action Sources option groups are no longer available.

IK animation is still exported as long as the Preserve IK Chains option is on. If the Preserve IK Chains option is off, the automatic conversion of IK to FK cannot take place because it requires animation plotting (which is not available when the Animation option is disabled).

• The Geometry options group has been renamed Exported Polygon Mesh Data.

• Some of the options in the Exported Polygon Mesh Data group have been renamed to emphasize the fact that they apply only to polygon mesh objects (the generic term geometry has been replaced).

• The new Polygon Meshes option allows you to choose whether or not you want to export the polygon meshes in your scene:

Polygon Meshes (Nulls exported when off)

When the Polygon Meshes option is on, all polygon mesh objects in the scene are exported.

When the Polygon Meshes option is off, none of the polygon mesh objects defined in the scene are exported. Nulls are exported in their place.

The Used Materials and Image Clips Only option is no longer available. This is because when Crosswalk removes all the geometry, all the associated materials and image clips become unused.

In addition, the remaining options in the Exported Polygon Mesh Data group and the Animation > Shapes option group are no longer available.

• The Shapes, Animation Plotting, and Animation Resampling option groups have been moved to their own tab, appropriately named Animation.

• The Exported Data > Animation option is also available on the Animation tab for ease-of-access.

• The new Action Sources options group provides options which allow you to export all action sources in your scene or choose the action sources to export on a per model basis:

Export All Action Sources

When this option is on, all action sources defined in the scene, including their associated action clips and tracks, are exported.

When this option is off, the Models drop-down list becomes available and you can choose to export the actions for a specific model in your scene.

Models

From the Models drop-down list, choose the model whose action sources you want to export.

Note that the Scene_Root appears in the list because it is considered a model, although in most cases it will not have its own Mixer with action sources defined.

Refresh

Updates the items listed in the Action Sources table. Click the Refresh button when you have removed, renamed, or created new actions for the specified model.

Reset All

Selects all the items in the Action Sources table for export.

[action sources table]

Lists the action sources defined in the Mixer folder of the specified model. A checkmark in the Export column indicates that the action will be exported.

Note that if you skip (deselect) even one of the action sources for a given Mixer, none of the action tracks for that Mixer will be exported. In other words, you must export (select) all the actions for a specific model in order to get all of its action tracks exported as well.

 

To export action sources

1. Deselect the Export All Action Sources checkbox.

2. Select from the Models drop-down list the model whose action sources you want to export.

3. In the Export column of the table, select (or deselect) the action sources to be exported.

Newly Supported Scene Elements and Attributes for dotXSI

Element

XSI Export vs. XSI Import

Comments

Spot

Yes

In XSI, when you create a spotlight it always has an interest (null) which is direction constrained to the spotlight. But if you create another light type and then change it to a spotlight, no interest gets created. Crosswalk expects all spotlights to have a properly defined interest. If not, the spotlight’s interest position will be automatically computed based on the spotlight’s rotation.

Keep in mind that this solution does not handle the case where the spotlight’s rotation is animated. You can use the following workaround to avoid this issue:

1. Make the spotlight the child of a null.

2. Set the spotlight’s translation relative to this null (0,0,0).

3. Animate the null in rotation (instead of the spotlight directly) and it will be exported.

New dotXSI Templates

XSI_ClipToParent

Stores the options that allow you to link a clip to its parent’s time information.

Newly Supported Scene Elements and Attributes for COLLADA

Element

XSI Export vs. XSI Import

Comments

Ambient

Yes

Prior to Crosswalk 3.1, ambient lights were imported at the scene origin and converted to point lights.

Envelopes

Yes

Including bind pose matrices and envelope weights.

In addition, Crosswalk adds type="JOINT" on all nodes (envelope deformers) that are a part of a skeleton’s hierarchy. This is done to support applications that rely on the type="JOINT" description to import envelopes/skins properly. This applies only to the export of envelope deformers from Crosswalk.

Newly Supported Scene Elements and Attributes for FBX

Element

FBX Import vs. FBX Export

Comments

UVs

Yes

Exports multiple UV sets. Import supports only one UV coordinate set.

Crosswalk for Maya

Maya to XSI: Newly Supported Scene Elements and Attributes

Element

Maya Export vs. XSI Import

Comments

Shapes

Yes

Maya shape animation export:

• Export All and Export Selection modes are supported.

• The Maya Envelope value is a global scaling factor applied to all the weight values in the blend shape deformer and it can be used to increase or decrease the effects of all the targets at the same time. On export, the Envelope value is baked into the weight function curve. If the Envelope value is animated, the weight function curve is plotted along with the baked-in Envelope value animation.

• Support for blend shapes that use targets whose objects exist in the scene as well as targets whose objects have been deleted from the scene.

ICE

Attribute Display

You can now use the Display Attribute property to display the values of any ICE attribute, even if that attribute would normally not be calculated because of optimization (in other words, it is not otherwise required for displaying the scene).

Simulation Environments

You can now merge simulation environments that contain ICE simulations. However, you cannot currently merge an ICE simulation environment that does not contain non-ICE rigid bodies together with a simulation environment that does contain non-ICE rigid bodies.

A workaround is to create a non-ICE rigid body and include it as part of the ICE simulation environment you want to merge. This automatically creates the Rigid Bodies folder that is missing in the ICE simulation environment. You can then hide or delete that rigid body if you don’t want to use it.

Arrays

If you get an array before it has been initialized, the default array that is returned is empty instead of having a single default item.

Realtime Shaders

Hardware Attribute-to-Register Mapping Using tspace_id

When a material is shared by several objects, an attached shader with texture projections is said to have shader instance data. The instance data allows you to specify to the shader which texture projection to use for each object that shares the material.

You can write shader code that can reference the instance data value directly by specifying the name of the tspace_id parameter between brackets as [MyRTSNodeThatHasATexture.tspace_id]. Conveniently, the GLSLProgram node’s hardware attribute mapping table lists the tspace_id as an attribute when it is present in the current realtime shader tree.

For example, in a shader tree that looks like this...

 

And a hardware attribute mapping table that looks like this...

 

The GLSLProgram shader references the tspace_id of the OGLTexture shader and maps whatever texture projection is specified in that tspace_id to a texture coordinates hardware register named texcoord0.xyz.

Customization

Custom Paramaters

The new Keyable option in the New Custom Parameter dialog box determines whether the new parameter appears in the keying panel. By default, it is on.

Environment Variables

 

Environment variable

Description

Platforms

Type

XSI_EMULATE_OPENGL

Specifies the version of OpenGL to use when starting XSI. For example:

XSI_EMULATE_OPENGL=1.4

Runs XSI without support for Vertex Buffer Objects.

XSI_EMULATE_OPENGL=1.5

Runs XSI with support for Vertex Buffer Objects (as for all versions above 1.5).

XSI_EMULATE_OPENGL=2.1

The highest OpenGL version supported by XSI 7.01.

All

XSI

XSI_NO_VSYNC

Disables any attempt by XSI to set or query the vertical synch option for your graphics card.

The Sync Redraw to Display (v-sync) preference instructs XSI to query the video card and switch the vertical sync on or off. For more information about v-sync and display performance, see Troubleshooting Viewing Problems on page 208 [Interface and Tools].

The Synch Redraw to Display (v-synch) preference is available on Windows systems only, and does not work with all display cards and drivers. If you are experiencing problems with your video card, you can disable the Synch Redraw to Display (v-synch) preference by setting the XSI_NO_VSYNC environment variable. Set the variable to any value (XSI will check for its existence).

Note that if XSI detects an NVIDIA GeForce-based video card, the Sync Redraw to Display (v-sync) preference is automatically disabled: XSI will not attempt to switch the video card’s v-sync on or off regardless of the preference or environment settings.

Windows

XSI

Documentation Updates

• Information about material libraries and the explorer has been updated.

ICE

Small corrections and additions have been made throughout parts of the ICE section in the guides, but the following sections represent more significant updates:

• Information has been added about spawning particles into different clouds—see Spawning ICE Particles.

• Information has been added about different Collision attributes and about removing the Simulate Particles node when using the Simulate Rigid Bodies node—see ICE Rigid Body Dynamics.

• Information has been added for the Particle Gradient Control shader—see Particle Gradient Control.

• Information has been added about resetting the initial state—see Creating an Initial State for ICE Simulations.

• Information about simulation environments has been updated—see The ICE Simulation Environment.



Autodesk Softimage Documentation Archives