Version 6.01

In addition to numerous bug fixes and performance improvements, XSI version 6.01 includes some new features and options:

New Path for SPM License Server

On Windows, the SPM license server software files are now installed to the %SYSTEMDRIVE%\spm folder. On most Windows systems this will be c:\spm.

If you are upgrading from XSI 6.0 to XSI 6.01, the SPM Setup program copies the SPM key database and any key (*.key) files from their original location under c:\WINDOWS\system32\spm to the new path defined by %SYSTEMDRIVE%\spm. All other binaries are deleted from the “old” spm folder location.

Site Deployment on Microsoft Vista

If you are deploying the installation of XSI 6.01 on client machines running the Microsoft Vista operating system, uncomment the line with the UserRoot option in the SiteDeploy.ini file. This creates the users folder in the location specified by the %USERPROFILE% environment variable. If this line remains commented out, the users folder is created by default in c:\users\%USERNAME% which is compatible with Windows operating systems prior to Vista.

[Setup]
Type=Custom
; Destination folder
InstallPath=c:\Softimage
; User Directory
UserRoot=%USERPROFILE%

Hierarchies

When you parent an object that is already in a hierarchy to a different hierarchy, the child’s entire hierarchy is no longer parented. Only the selected object and its children are moved to the new hierarchy.

Scene TOC Files

The updated render options are now included in Scene TOC files, and the syntax version has been updated to 2.0. For scenes created in earlier versions of XSI, the previous syntax still works when opening scenes.

Referenced Models

The new command Modify > Model > Add Empty Delta on the Model toolbar makes it easier to work with multiple deltas.

Crosswalk Setup

A typical installation of XSI includes all the components for the Crosswalk integrations and the Crosswalk SDK. You can use the Crosswalk integration plug-ins available with XSI to enable data transfer between XSI and your Maya and/or 3ds Max installations.

 

In 6.02, the Crosswalk integration plug-ins for Maya and 3ds Max are not included in the XSI installation. You must download and run the standalone Softimage|Crosswalk setup program to obtain these plug-ins.

Crosswalk FBX

The Crosswalk for XSI integration, which is available with a typical installation of XSI v.6.01, now includes the ability to import and export scene data using the FBX (*.fbx) file format. You can access the XSI FBX plug-in from File > Crosswalk > Import FBX and File > Crosswalk > Export FBX in the XSI main menu.

Crosswalk Documentation

Documentation on how to use the Crosswalk integrations has been updated for XSI v.6.01.

For information on the Crosswalk SDK, choose Help > SDK Guides > Crosswalk for Developers from the XSI main menu.

Function Curve Slope Handles

• When you select multiple keys on an fcurve, you can now drag one of the slope handles to change all keys’ handles accordingly. No need to select the slope handles first.

• When you press Shift and drag an fcurve’s tangent handle, the handle’s change is now restricted to either length or angle, depending on the direction in which you drag:

- Press Shift while you drag up or down (or perpendicular to the handle) to change only the handle’s angle.

- Press Shift while you drag to the left or right (or along the handle’s tangent) to change only the handle’s length.

Function Curve View Modes

• You can now set a preference for which View command is active by default in the fcurve editor by setting the Display Options on the Editor page in the Fcurve Editor Preferences property editor.

• When you choose the View > Marked Parameters command in the fcurve editor or the dopesheet, the marked parameters are now highlighted in yellow in the animation explorer.

• When you choose the View > Selected Parameters command in the fcurve editor and select a parameter in the animation explorer, its fcurve is now automatically selected in the graph. This makes it easy to edit and manipulate the fcurve immediately.

If you want to only display the fcurves, but not select them, deactivate the Display > Allow selecting curves from the tree in Selected Mode option on the Editor page in the Fcurve Editor Preferences property editor.

Function Curve Paste Options

• The Insert option in the Paste Options page in the Fcurve Editor Preferences property editor has been renamed to Ripple and works the same as does the Ripple in the dopesheet.

• A new Merge Keys option has been added to the Paste Options page so that you can merge pasted keys with the existing keys on an fcurve over the same frames.

• If you want to cut/copy and paste fcurves and keys across multiple sessions of XSI (as you could with previous versions of XSI), you can select the new Legacy Cut/Copy/Paste option on the Paste Options page. With this option on, however, you can cut/copy and paste using only one fcurve at a time.

Architectural Shaders

• Most parameters in the Physical_Sky and Physical_Sun shaders now accept connections in the render tree.

• The architectural shader can now return results into render channels (ambient, diffuse, specular, reflection, refraction, irradiance, translucency and occlusion). It also obeys the diffuse and specular options of the lights.

• The Frost parameter (in the Refraction section) of the Architectural Material shader has been renamed Glossiness to better reflect its function. The lower the Glossiness value, the rougher the material is for refracted rays.

• The mental ray Architectural Library PDF document is now installed in the XSI install path\Doc\mental_ray\tutorials folder. You can also find it in the Rendering section on the XSI wiki. This document includes examples for simulating specific material qualities (such as glass, stone, and wood), as well as details on the architectural shader parameters.

Bump Maps

The Bumpmap shader is entirely new. The old Bumpmap is still used in render trees created in previous versions. The Bumpmap Generator shader should now be used only if you want to use its projection options.

Vertex Colors

• Vertex color properties now support 16-bit (half-float) HDR RGBA values. In addition, the Vertices Only (RenderVertex) sampling option in RenderMap handles HDR values properly. This means that, for example, you can bake the results of HDR image-based lighting into an object’s vertex color property.

• When painting vertex colors, you can right-click to pick a color from the scene. Actually, you’ve always been able to do this, but now it’s documented.

Passes

You can now apply lens shaders to passes.

Render Channels

The output of the Motion render channel is now in screen (raster) space instead of world space. In addition, if there is any motion in a pixel, the Z value of the motion will be 1.0; otherwise, it will be 0.0. If you output the motion buffer to a color file format, this allows you to process the Blue channel to create a matte for compositing.

Render Manager

The various pass and global options in the Render Manager have been reorganized.

Render Region

There is a new menu item for setting the render region options of the last view you clicked in (highlighted with a white border): Render > Regions > Active Viewport Options. The existing command Render > Regions > Active Viewport Options has been renamed to All Options.

Render Preview

The render preview window always shows the main channel, instead of a specific framebuffer.

Output Format Preferences

The Field Rendering options have been added to the Output Format preferences. These options control the default settings for new scenes.

Batch Rendering

The command line options for batch rendering have been updated to make them simpler and more consistent with the new organization of rendering options in XSI. The most common options are available directly from the command line, while other options can be changed using a script.

 

The previous syntax for batch rendering using the -r switch has been deprecated and is no longer recommended. Use render events in place of the -prescript and -postscript options,

Environment Variables

Environment Variables for Microsoft Vista

On Microsoft Vista, the default value of XSI_USERROOT is %USERPROFILE%.

Other Environment Variables

XSI_CUSTOM_BUFFERED_IO is an environment variable that controls how data is buffered when saving files. It can have an effect on performance.



Autodesk Softimage Documentation Archives