Version 6.0

Here is a detailed summary of the new features and enhancements available in XSI version 6.0.

Commands and Interface

Working with Scene Elements

Transformations

Data Management

Basic Modeling and Deformations

Polygon Mesh and Subdivision Modeling

Animation

Nonlinear Animation

Character Animation

Rigid Bodies

Hair

Materials and Shaders

Texturing

Rendering

Compositing and Effects

Customizing

Documentation Updates

 

 

Commands and Interface

Viewing

There is a new Transparent option for Hidden Line Surface Color. It allows you to see rotoscopy images, as well as non-geometric objects like nulls and bones, that are behind hidden-line objects, but geometric objects will still occlude each other properly.

Net View

Net View has a new File menu. File > Open lets you use an XSI file browser to select an HTML page, and File > Preferences lets you view or set your Net View preferences.

Navigation

The transform and tweak tool manipulators no longer disappear when navigating the camera in supra mode. This applies to zooming, orbiting, panning, and so on.

Rotoscopy

There are a number of changes to rotoscopy:

• Fixed image planes are supported. They can be displayed in other views such as Camera and User.

• Frame and Frame All no longer exit Pixel Zoom mode.

• If an image is larger than the viewport, it displays at 1:1 when Pixel Zoom mode is first activated instead of being scaled to fit.

Wireframe Color

The wireframe color set in Display properties no longer uses a specially-indexed palette. It now uses a standard 24-bit RGB color.

Explorer

You can now use + and – on the numeric keypad to expand or collapse the selected node by one level.

Working with Scene Elements

Selecting

• The new option Surround Polygons under Rectangle Select Option in the Tools > Selection preferences controls whether you need to completely surround a polygon or not to select it using the Rectangle and Lasso tools.

• When you are using either the Rectangle or Lasso tools, the Click to deselect option in your Tools > Selection preferences controls whether you need to simply click or click and drag slightly in an empty area of a 3D view to deselect.

• You can now use the Shift key to multi-select a range of elements in transient explorers, such as the one displayed by the Cluster button on the Select panel. Select the first element in the range, and then Shift+click on the last.

• When using the Shift key to multi-select a range of elements in any explorer, you no longer need to select the first element in the explorer itself.

• You can also use Ctrl+Shift to select multiple ranges in the explorer. To add ranges to the selection, Ctrl+click on the first element in a new range and then Ctrl+Shift+click on the last element.

Layers

What used to be known as layers are now referred to as scene layers. Layers have been renamed to avoid confusion with animation layers, which have been introduced in this version, as well as texture layers.

Scene layers can still be accessed by pressing 6 to open the scene layer manager (what used to be called the layer control), and can also be found on the Scene tab on the KP/L panel on the right side of the interface.

Transformations

Reference Modes and COG

The Scale, Rotate, and Translate tools each now remember the last reference mode used for objects and components separately. For example, this makes it possible to use View for objects and Local for components without having to continually reset the reference mode. Similarly, XSI remembers whether COG is on or off separately for objects and components.

Manipulator Handle Highlight

The manipulator handle under the mouse pointer is highlighted to give greater feedback about which axes or planes will be used when you click and drag.

Manipulator Handle Options

In the Tools > Transform preferences, there is a new option for Translate/Scale Interaction Style: Axes + Plane Handles provides explicit handles for the planes as well as the axes. This makes it easier to grab a plane’s handle when you are looking at an object from behind.

Manipulator Display Preference

In the Tools > Transform preferences, there is a new option called Keep Manipulator Visible in 3D View. When the object’s center or pivot is off-screen, the manipulator is displayed at the edge of the screen closest to the object’s center (as long as the object is in front of the camera). This allows you to translate an object even if its center is not visible in a 3D view.

Mini Transform Panel

There is a new mini version of the Transformation panel available at the top of the KP/L panel. This makes it easier to access transformation values as you are keying using the tools in the keying panel and animation layers that are also on the KP/L panel.

Snapping

The Snap to Unselected Objects Only and Snap to Tagged Components Only options have been removed from the Snap menu to make them harder to activate by mistake. They are still available on the Snap Option property editor.

Data Management

Referenced Models

Referenced models have been completely overhauled. Some of the major changes include:

• Referenced models no longer rely on sources and clips.

• All changes made to any resolution are stored in a model’s delta. You can modify and delete items in the delta. You can also export deltas and import them into other scenes.

• You can change the name of referenced models.

• Referenced models can have as many resolutions as you like.

• The name of the current resolution is shown in the explorer.

• You can convert a local model to a referenced model “in place”.

• You can commit the local changes to a referenced model and save them back to the external file.

• You can nest referenced models inside each other as deeply as you like.

• You can assign existing materials from the scene to objects in referenced models.

• The PostLoad and PreModSave scripts have been replaced with model-specific events.

• You can now import Collada files as referenced models.

• You can apply scripted operators to referenced models.

Crosswalk

Crosswalk is an ongoing initiative to help seamlessly transfer XSI content into and out of any previously established 3D pipeline. You can transfer assets using the latest dotXSI and COLLADA standards, and take advantage of enhanced import/export tools to get assets in and out of Autodesk® 3ds Max® and Maya® pipelines.

Scene TOC

The way that referenced models are listed in the Scene TOC file has changed. Instead of being listed in the <Sources> section, they are now listed in the new <Models> section.

Preferences

Use UNC paths when saving files in the Data Management preferences now works for the recent files lists, in addition to the project list and scene TOC files.

Migrating from a Previous Installation

You might have noticed that you weren’t prompted to migrate your preferences and other customizations from a previous installation of XSI during setup. You can now migrate from within XSI using File > Migrate Preferences. You can also migrate using the command line as before.

Basic Modeling and Deformations

Proportional Modeling

The Tagged Points Only option of the Proportional property editor has been moved to a new Move Point Tool tab to reflect the fact that it does not apply to the Tweak Component tool.

Symmetry

Sym mode now works “live”, without the need for a symmetry map. In addition, there are new options in the Symmetry preferences.

You can still use a symmetry map if you need to establish a correspondence between points even if the object is no longer symmetrical, for example, if an envelope, a twist, or any other deformer has been applied. Symmetry maps are also still used when mirroring envelope weights.

Polygon Mesh and Subdivision Modeling

Merging Meshes

The new Normalize envelope weights upon transfer toggle allows you to turn off the automatic normalization of weights when transferring envelopes. This is useful if you deliberately want to leave some points completely or partially unweighted.

Animation

KP/L and Animation Panel Changes

• The KP/L panel on the main command panel has changed to include a new mini transform panel and the Animation Layer panel. As well, the Layer panel from previous versions has changed names to become the Scene (layer), but is still available on the KP/L panel.

• The Animation panel at the bottom of the interface now includes a new Save Key command button and a new Character Key Set menu.

 

Animation Layers

Animation layering lets you add keys on top of the existing base animation, which can be either action clips or fcurves. You can easily add keys on top of the action clip is currently in the mixer without needing to actually work in the mixer, or add keys on top of existing fcurves.

Animation layers are non-destructive, meaning that they don’t alter your base animation in any way: the keys in the layer always remain a separate entity.

Layering allows you to experiment with different effects on your animations and build several variations of a move, each in its own layer. Animation layers are especially useful for adding keys on top of motion capture (mocap) data.

Character Key Sets

Character key sets are sets of keyable parameters that you create for an object or hierarchy for quick and easy keying. Once you have created key sets, you don’t need to select an object first to key its parameters—just press K or click the keyframe icon and whatever is in the current character key set is keyed.

You can think of character key sets as “keyable groups” for a whole hierarchy (such as a character), as well as for the individual objects within that hierarchy. They let you keep the same set of parameters available for any object for easy keying, such as only the rotation parameters for the upper body control in a rig.

Keying Preferences

There are new options for saving keys in the Animation Preferences property editor and in the Animation menu:

• There is a new Save Key Command option for character keys sets: Key Character Key Set. This sets keys only on parameters in the current character (or subcharacter) key set when you save a key by pressing K, by clicking the keyframe icon in the Animation panel or the keying panel, or by choosing the Save Key command from the Animation menu or Character Key Set menu.

• There is a new Save Key button in the Animation panel that makes it easy to see and select the desired Save Key preference.

• The new Save Keys on Modified Parameters Only option sets keys only on modified parameters that already have fcurves instead of setting keys on all parameters. This is off by default for regular keys, but on by default for autokeying.

Dopesheet

The dopesheet has changed in a number of ways that make it easier to use. This is a summary of the most significant changes.

• There is a new Scene Summary track, in addition to the Dopesheet Summary track

• The parameters in the animation explorer and their tracks are now aligned by default (View > Align Tracks with Tree View is on).

• The timeline is now displayed at the top of the dopesheet.

• The Select tool (press space bar) is now active by default.

• When you click a key to select it, it turns white. You can then simply drag it to move it, or press Ctrl+drag it to copy it.

• Marquees are displayed around the frames as you move or copy keys or regions.

• There are icons for the Select and Region tools in the command bar.

• The regions look a little different now.

• You can now customize the colors of the dopesheet in the dopesheet’s preferences property editor.

• There are icons for the Cut, Copy, Paste, and Delete commands in the command bar.

• There is a new Deselect All button in the command bar and Edit > Deselect All command that deselects all tracks, keys, and regions.

• There are new Edit > Select All Keys and Select All Tracks commands.

• You can no longer mark parameters in the dopesheet.

Animation Editor

Select Tool

The Select tool (press Y) in the fcurve editor has been updated to make it easier to use the animation editor when you have many fcurves and keys. As well, if you’re switching to XSI from other 3D software, these options make the workflow similar to them.

There are two new options in the Animation Editor Preferences property editor for this tool:

Prevent movement on LMB: With this on, you can select fcurves, keys, and slope handles with the left mouse button (LMB), but you cannot move them. This makes it easier to select or rectangle-select fcurves or keys without accidentally clicking on a slope handle.

If this is off, you can move keys and slope handles with the left mouse button.

This option is off by default for the XSI interaction model, but on by default for the QWERTY interaction model.

Translate on MMB: With this on, you can use the middle mouse button (MMB) to move fcurves, keys, or slope handles. To constrain movement horizontally or vertically, hold down the Shift key as you drag.

This tool doesn’t use the position where you click, so you don’t need to actually click on the selection to move it. This makes it impossible for you to lose your selection by mistake in case you didn’t click precisely.

This option is on by default for the XSI and QWERTY interaction models.

Animation Explorer

• The animation tree in the animation editor is now referred to as the animation explorer.

• The new On Multiple Selection options in the Animation Editor preferences determine whether the nodes in the animation explorer are Expanded or Collapsed when multiple objects are selected. There are separate options for the fcurve editor and the dopesheet.

• The View menu that was on the furthest left of the animation editor command bar has been renamed to Explorer and has been simplified a great deal.

• A Collapse All command has been added to the Explorer menu.

• The Marked Parameters Only, Activation Parameters Only, Hide Locked Parameters, and Tagged Parameters filters have been moved into the new Parameter Filters submenu in the Explorer menu.

• The Explorer > Flattening submenu contains all commands for flattening the nodes in the animation explorer.

• The Explorer > Display submenu contains the commands for parameter display and sorting in the animation explorer, such as Use Wire Colors, Use Script Names, Alphabetical sort, and so on.

• The Properties filters (Modeling, Rendering, Animation, etc.) in the Explorer menu have been moved into a submenu called More. Although these filters are still available, it is recommended to use the Keyable Parameters command instead to filter for parameters to edit in the animation editor.

• Parameters are now highlighted in white when they’re selected in the animation explorer. When the dopesheet is the active editor, the highlight color is light beige.

• There are three new options in the Animation Editor Preferences property editor for the animation explorer:

- Auto Select Marked Params automatically selects the object’s marked parameters in the animation explorer when you open the animation editor.

- Auto Select Newly Keyed Params automatically selects the object’s parameters in the animation explorer as they are keyed. This also selects the parameter’s fcurves in the graph or tracks in the dopesheet. As you key more parameters, they are added to the current selection.

- Always Show Root Objects displays the selected object’s root node at all times in the animation explorer, even if they don’t match the filters in the Explorer menu. For example, if a selected object has no keyable parameters, its object node is still displayed in the animation explorer.

Function Curves

Copy/Paste Multiple Keys on Fcurves

You can now copy and paste multiple keys on multiple fcurves in the fcurve editor.

Fcurve Editor Preference for Interpolation

On the Keys page of the Fcurve Editor Preferences property editor, there is a new option called Apply spline/linear interpolation to both sides of selected keys. When you select keys on a curve and select either spline or linear as the interpolation type, the same interpolation is used on the slopes on both sides of the selected keys.

Icons for Slope Orientation Commands

Choosing one of the Slope Orientation commands in the Keys menu in the fcurve editor now enables that command and applies it to the selected slopes.

There is also a new set of icons in the fcurve editor’s command bar to let you easily choose these commands.

 

Slope Handles on Fcurves

With the updated Select tool, you can now click anywhere on a slope handle to select it. The handle turns yellow to indicate it’s selected, and remains selected even if you select another key.

Displaying Fcurves in the Graph

The View > Selected Parameters has changed so that it now displays only the fcurves of the parameters that you select in the animation explorer. As well, this command only displays the fcurve, but does not select it. This mode makes it easy to quickly isolate one or just a few fcurves in the graph.

Autoframing Fcurves in the Graph

When you choose View > Auto Frame Curves and the View > Selected Parameters filter is active, you can change the selection of one or more parameters in the animation explorer and their fcurves are now automatically framed in the graph.

Transform Group Null Location

There is a new preference in the Preferences property editor for the Transform Group Options. This preference is called Group Pivot and determines where the transform group null (pivot) is located when you create a transform group. You can set it to:

Bounding Box Center: Positions the transform group null in the geometrical center of the selection bounding box of the objects that will be in the transform group. This is the default.

or

Parent Origin: Positions the transform group null at origin of the selected objects’ parent. If the objects have no parents, or have different parents, the transform group null is placed at the scene’s origin.

Nonlinear Animation

Mixing Fcurves with Action Clips in the Mixer

Previously, an action clip in the animation mixer would override any animation that you had on an object at the same time. You can now directly mix fcurves on an object’s parameters over the same frames as there is an action clip that animates the same parameters.

Remove Items from Action Sources

You can now remove one or more items from animation that is stored in an action source. To do this, right-click on an action clip in the animation mixer and choose Source. In the Action Source property editor, select the items you want to remove and click the Remove Item button.

Character Animation

Retargeting Animation (MOTOR)

Retargeting allows you to transfer the animation between characters, regardless of their size or proportions. Retargeting involves first tagging (identifying) the elements of both the target and source (animated) rigs, then transferring the animation from the source to the target rig.

• While you can retarget any type of animation between characters, it is especially useful when you want to reuse motion capture data to animate many different characters with the same movements, such as you would for a game.

• You can also retarget animation from a BVH or C3D mocap file to a rig in XSI, as well as save the mocap data in a generic motion file that can be reuse on any tagged rig.

• You can save any type of animation in a normalized motion format so that it can be retargeted on any rig, making it easy for you to build up libraries of animation that can be used across all your rigs.

• Plot the retargeted animation on a rig into fcurves while preserving the original keyframes and fitting the curve.

Enveloping

There have been several additions to enveloping and the weight editor:

• If a point is not fully weighted (that is, its weights do not add up to 100), its row is displayed in red. The envelope's name is also displayed in red if some of its points are not completely assigned — hover the mouse pointer over the envelope name to see how many points are not fully weighted. This lets you see at a glance which points and objects are not fully assigned.

• You can limit the number of deformers to which each point’s weight is assigned. This can be especially important for game characters, because some game engines have a limit on the number of deformers.

• The weight editor now updates when you select polygons and edges in the 3D views, in addition to points and deformers.

• You can double-click on an envelope’s name in the weight editor to expand or collapse its list of points.

Rigid Bodies

Compound Rigid Bodies

You can now apply rigid bodies to a hierarchy of objects to create compound rigid bodies. You can:

• Have both parent and children rigid bodies (compounds).

• Have a non-rigid body parent with rigid body children.

• Have a rigid body parent with non-rigid body children.

 

Because of the support for parenting and compound rigid bodies, you can no longer animate the scaling of rigid bodies. This has been disabled because it can cause cycles.

Convex Hull Geometry Display

• When you select Convex Hull as the collision type for a rigid body, a yellow wireframe is now displayed around the rigid body to show the extents of its collision volume.

You can toggle the visibility of the collision geometry with the Collision Primitives settings on the Attributes page in the Visibility Options property editor (press Shift+S).

• You can change the color of the collision geometry wireframe (yellow by default) for each individual rigid body using the CollisionShapeColorR, G, and B parameters in the Rigid Body Properties, which are available only via scripting or the SDK. This may be especially useful to do for the convex hull, which can have many lines and obscure the actual rigid body.

Choose Help > SDK Guides to get for more information about these parameters.

Hair

Proportional Splaying for Hair Multiplicity

There is a new option for the Hair Multiplicity parameters in the Hair property editor: Splay type. You can now choose whether the duplicated hairs are splayed in a Proportional way according to the hair strand’s length, or splayed according to Absolute values.

The Proportional option is selected by default and should give you better effects on hair that is of different lengths, especially for shorter hairs. If you are loading older scenes into this new version of XSI, the Absolute option is selected by default.

Hair Thickness Change

You may notice that the thickness of hair has changed in scenes that were created with previous versions of XSI. You may need to tweak the Thickness parameters’ values in the Hair property editor to achieve results similar to what you had.

Materials and Shaders

Material Manager

The material manager is a convenient tool for managing and editing all your materials and libraries.

Shaderballs

There are now shaderballs in the render tree and elsewhere. Shaderballs let you display the result of any part of your shader tree.

Car Paint Shaders

The mental ray Car Paint shader simulates the unique characteristics of car paint:

• Diffuse reflection in the pigmentation layer producing color shifts at edges due to viewing angle and incident light angle.

• Specular highlights from metallic flakes suspended in the pigmentation layer. Including optional ray traced reflections in the metallic flakes.

• Clearcoat layer with mirror or glossy reflections and specular highlights with an optional glazing mode.

• All topped with a Lambertian dirt layer, if needed.

See also the other shaders in the Car Paint shader library:

Glossy Reflection

Metallic Paint

Bump Flakes

Architectural Shaders

The mental ray architectural library contains a set of shaders designed for architectural and design visualization.

The most important are the Architectural Material, the Physical Sun, and the Physical Sky shaders, but the library also contains minor tool shaders to create render-time Rounded Corners, and Simple Tone Mapping.

Store In Channel Shaders

Built-in and preset render channels extract specific data for all objects that are rendered in a pass. If you wish to isolate data for particular objects in your scene.

Texturing

Tearing and Bleeding

In the texture editor, vertex bleeding has been removed. In its place is the new tearing mode.

• When tearing mode is off, connected and coincident UV samples are automatically affected by any manipulation even if they are not explicitly selected.

• When tearing is on, it’s possible to separate samples into discontinuous islands.

If you want the old behavior of vertex bleeding, you must choose Tools > Bleed Selection after selecting samples and before manipulating them. Polygon bleeding has not changed.

Auto Sync

In the texture editor, the Sync Method preference controls the type of component selected in the 3D views when samples are selected in the texture editor:

Samples selects samples.

Components selects the type of component specified by the current filter on the Select panel, for example, Point, Edge, Polygon, etc.

Transforming Sample UV Coordinates Precisely

In the texture editor, Tools > Transform UVs allows you to transform the U (horizontal) and V (vertical) coordinates of the selected texture sample points precisely. This feature was removed in v. 7.0 because of the new ability to edit multiple UV texture coordinates simultaneously.

Supported Image Formats

XSI supports new file formats as textures:

• Valve texture format (*.vtf)

• RGBE subformat of memory-mapped files (*.map)

Clip Menus

Clips are now sorted alphabetically in all Clips menus (render tree, Fx tree, image clip viewer, texture editor, etc.).

Component Selection

When the Rectangle Select tool is active in the texture editor, a single click (as opposed to a click-and-drag) performs a raycast selection and selects a single sample, edge, or polygon.

MAT Panel

The MAT (Material) panel is an alternative interface for working with texture layers. It provides similar controls to the texture layer editor, but in a different arrangement.

Importing Clips and Sources

The behavior for dragging and dropping images into XSI has changed. Instead of simply creating a source, it now creates a source and clip. If you want to create a source only, drop an image onto the Sources folder in the explorer.

Get > Texture

When the selected object uses the default Scene Material and you choose an item from the Get > Texture menu, you are no longer prompted about modifying shared properties. A local copy of the Scene Material named MaterialN is created automatically.

Rendering

Rendering Options and the Render Manager

The rendering options have been significantly restructured. In particular, the rendering options have been divided into scene options, pass options, and renderer-specific options.

The Render Manager provides one-stop-shopping for setting all of your rendering options,.

Render Channels and Framebuffers

Render channels and framebuffers unify into a single concept what was previously split up into image output paths; motion, tag, and normal channel toggles; and pass channels. A render channel is a named description of image data for a given data type, and a framebuffer specifies where and how each channel's image data should be written out.

The Render Region

There have been a number of changes to the render region.

• You can now display multiple render regions, one in each view.

• Each render region has memo-regions that allow you to store, compare, and recall settings.

• You can display render pass channels in the render region.

• Track Selection has changed behavior. Instead of moving and resizing the region itself, it draws a box of pixels containing the selected elements inside the region. You should therefore draw a region that is large enough to contain the elements’ movements over the frame range.

Compositing and Effects

Image Compare

The Fx Viewer can now preview two nodes at once. You can switch between them, or display them split-screen and wipe to show more of one or the other.

Warper and Morpher

XSI Illusion includes new Warper and Morpher effects based on Elastic Reality.

OpenEXR HDR Support

Many nodes in the Fx Tree support unclamped 16-bit floating-point color values.

Image Formats

XSI Illusion supports new file formats:

• Valve texture format (*.vtf)

• RGBE subformat of memory-mapped files (*.map)

Shape Wireframe Color

You can set the color of shapes’ wireframes.

Customizing

Parameters

Proxy parameter names are now based on the original parameter’s source name. This avoids excessively long names based on the parameter’s description.

Custom Filter Wizard

You can easily generate code for custom filters using the Filter Wizard. Open the Plug-in Manager (File > Plug-in Manager), and then choose File > New > Filter from the Tree, Plug-ins, or Items tab.

XSI_PLUGINS

The path specified by the XSI_PLUGINS environment variable can now be used to load SPDL files. Previously, it was used for self-installing plug-ins only.

Batch Scripting

You can now run Python scripts and specify arguments directly from the command line using the standard syntax. You no longer need to use a second script written in JScript or VBScript to call the desired procedure with the desired argument values.

Documentation Updates

• The XSI reference help has been converted from WinHelp (*.hlp) format to MS HTML Help (*.chm).

• The XSI user and reference guides have been merged together.

• The Help Language setting in the General preferences now affects both the merged XSI guides and the SDK guide.

• The XSI help has a new button on the toolbar that connects to the XSI Wiki. The SDK help has a similar button that connects directly to the SDK portion of the XSI Wiki.



Autodesk Softimage Documentation Archives