Versions 5.1 and 5.11

The SOFTIMAGE|XSI version 5.1 release contains many fixes and updates to the software as well as to the documentation. This following section provides a detailed summary of the new features and enhancements introduced in XSI version 5.1:

Commands and Interface

Data Management

Basic Modeling and Deformations

Animation

Hair

Rendering

Realtime Shader Support

Compositing and Effects

Customizing

GATOR for 3ds Max

In addition, the following miscellaneous changes have been added in version 5.11:

• You can now use dotXSI 5 (.xsi) and COLLADA (.dae and .xml) files as referenced models. Previously, this was possible only with .emdl files as well as dotXSI 3.6 and earlier.

• You can now drag and drop dotXSI 5 and COLLADA files to import them into the scene.

• Some of the backup and recovery options in the Data Management preferences have been reorganized and renamed.

• There is a new command in the viewports’ camera icon menu: Update Isolated allows you to quickly isolate the currently selected objects when Isolate Selection is already on. In addition, on-screen controls indicate when objects are isolated and allow you to toggle it off or update.

Commands and Interface

Autodesk 3ds Max-Compatible Key Map

There is a new Autodesk 3ds Max-compatible key map available. It’s not a full interaction model like XSI or QWERTY, but instead it can be used in conjunction with any interaction model. Choose File > Keyboard Mapping and then set Key Map to Autodesk 3ds Max-Compatible.

Isolate Selection

The Isolate Selection item in the viewports’ camera icon menu is now a toggle. The Isolate All command has been removed.

Grid Plane

You can now choose which Plane to use as the floor grid on the Visual Cues tab of the Camera Visibility properties (eye icon menu > Visibility Options, or Shift+s over a view).

Explorer

In addition to changing the order of a parent object’s children, the Reorder tool in to explorer now allows you to reorder:

• Objects in a group.

• Passes in the pass list. Note that the order of passes in the Pass Selection menu on the Render toolbar and main menu bar is based on the sort order set in the explorer.

• Layers in the layers list.

• Clusters in a cluster container.

Data Management

Importing and Exporting COLLADA 1.4.0 Files

COLLADA is an XML-based digital asset exchange schema. You can import and export a file saved to the COLLADA 1.4.0 file format natively in XSI. Choose File > Import > COLLADA 1.4.0 or File > Export > COLLADA 1.4.0 from the main menu.

• The import and export for COLLADA 1.4.0 and dotXSI5 have been unified:

- In scripts, both formats use the ExportFTKOptions and ImportFTKOptions commands. To create the options, use CreateExportFTKOptions and CreateImportFTKOptions.

- The import and export parameters are also shared by both formats.

• The Ignore Unsupported Objects checkbox was removed from the export options dialog box. Unsupported objects are always exported as nulls with the element name for reference purposes.

• Added COLLADA 1.4.0 support in the FTK. See Help > SDK Guides > FTK Developer’s Guide for detailed information on the File Transfer Toolkit.

• New COLLADA FX CG profile realtime shader.

Importing and Exporting Max 8 Files

If you have 3ds Max version 8, SOFTIMAGE|XSI can import and export .max files. The conversion is accomplished using plug-ins for 3ds Max that XSI launches in the background. The converter is available only for 32-bit Windows systems.

Importing and Exporting With Point Oven

Point Oven is a suite of plug-ins available from within XSI that allow you to simplify your XSI scenes by baking in vertex and function curve data, and streamline your pipelines by providing data transfer between different applications that also use Point Oven.

The XSI Point Oven plug-ins let you load and save various types of data: you can import and export Lightwave Object (LWO2) files, bake vertices to MDD files, import and export Point Oven scenes (PSC), export Lightwave scenes (LWS), export Messiah scenes (FXS), and import MDD files.

Basic Modeling and Deformations

Generalized Attribute Transfer (GATOR)

The Generalized Attribute Transfer operator (GATOR) has a new option. Raycast Along Normals casts a rays along a point's normal in both directions and interpolates a value based on where the ray hits the source object. If the ray hits the source at multiple locations, the shortest distance is used. If there is no hit, a value is calculated using the Closest Surface method.

Shrinkwrap

There are some new options for the Shrinkwrap deformation:

Closest surface if no intersection uses the Closest Surface projection method for points that do not hit the target object when using the selected projection. This ensures that all points of the wrapper object are deformed to the target.

• When shrinkwrapping along an axis, you can now choose the reference: Target object, Deformed object, or Global.

Animation

Storing Keyable Parameters

You can now store an object’s keyable parameters, which are the parameters that are displayed in the keying panel. Keyable parameters let you keep a specific set of parameters always available for an object, without needing to mark them first.

Keyable parameters can be any type of parameters you choose, but by default they include an object’s local transformation parameters. You can set which parameters are keyable or not for an object using the keyable parameters editor.

Choose the appropriate command from the Animate toolbar for the type of animation you want to store:

Actions > Store > Keyable Parameters - Fcurves

Actions > Store > Keyable Parameters - Current Values (stores a pose with no animation)

Hair

Hair Instance Options

There are several new options to be found on the new Instancing tab in the Hair property editor.

• You can now choose to replace the guide hairs (instead of render hairs) with instances by selecting the Instances on Guide Hairs option.

• You can now control how the instances are assigned to the hair using the Object Assignment method: Random or Using Weight Map. Random does as advertised, and the weight map option uses the different values on a weight map to assign the instances in the group to the hair.

With the weight map, you can also set the Fuzziness (%) option, which uses a percentage value (0 to 100) to blend the values of the weight map so that the division between instanced objects is less distinct.

• You can now control the orientation of the instanced geometry in two ways using the Orientation options: Tangent Map or Follow Object.

- When instances are oriented according to a Tangent Map, the map gives each instance a local XYZ coordinate system based on the RGB values of the emitter object’s VertexColor property. Tangent maps orient the instance so that its X axis follows the U direction of the hair emitter. This can be useful when the hair emitter’s surface is constantly deforming and you need to keep the hairs oriented in the same direction.

- With Follow Object, the orientation of the instances change as they follow the location of one or more objects.

- In addition to setting the type of orientation, you can set a Spread value in degrees (0 to 360) to locally rotate each instance. A distribution method (linear or Gaussian) is used to allow for some randomization of rotation values among the instances.

Rendering

Rasterizer Sampling Options

The Rasterizer is mental ray’s scanline rendering algorithm for accelerating motion blur rendering. It replaces the Rapid Motion scanline algorithm from previous mental ray releases.

There are two new sampling options for the Rasterizer: Shading Samples and Motion Samples, both available from the Aliasing tab in the Render Options property editor. Also, the Collect Rate option has been renamed to Pixel Samples to better describe what it actually does.

Pass Order

The order of passes on the Pass Selection menu on the Render toolbar and main menu bar is determined by the general sort order set in the explorer, for example, Alphabetical, None (creation), and so on. You can modify the creation order using the Reorder tool in the explorer.

Realtime Shader Support

CGFX 1.4 Realtime Shader

The new CgFX 1.4 realtime shader provides support for nVIDIA’s CgFX file format, Microsoft’s FX file format, and COLLADA’s FX file format with the Cg profile. CgFX and FX files can be dragged and dropped onto objects and clusters and automatically generate property pages based on their content. The shader supports external file referencing as well as inlined code compilation for rapid prototyping.

SAS 1.0 Support in the Realtime Shader API

XSI now supports a more complete subset of Microsoft’s DX SAS 0.8x and 1.0 at the SDK level. As a result, DXHLSLProgram, CgProgram, CgFX and FX also benefit from it. The list of semantics and annotations is as follows:

world

worldi

worldt

worldit

worldinverse

worldtranspose

worldinversetranspose

model

modeli

modelt

modelit

modelinverse

modeltranspose

modelinversetranspose

simodel

simodeli

simodelt

simodelit

view

viewi

viewt

viewit

viewinverse

viewtranspose

viewinversetranspose

siview

siviewi

siviewt

siviewit

projection

projectioni

projectiont

projectionit

projectioninverse

projectiontranspose

projectioninversetranspose

siproj

siproji

siprojt

siprojit

worldview

worldviewi

worldviewit

worldviewinverse

worldviewtranspose

worldviewinversetranspose

modelview

modelviewi

modelviewt

modelviewit

modelviewinverse

modelviewtranspose

modelviewinversetranspose

simodelview

simodelviewi

simodelviewt

simodelviewit

worldviewprojection

worldviewprojectioni

worldviewprojectiont

worldviewprojectionit

worldviewprojectioninverse

worldviewprojectiontranspose

worldviewprojectioninversetranspose

modelviewprojection

modelviewprojectioni

modelviewprojectiont

modelviewprojectionit

modelviewprojectioninverse

modelviewprojectiontranspose

modelviewprojectioninversetranspose

simodelviewproj

simodelviewproji

simodelviewprojt

simodelviewprojit

cameraposition

sieyepos

sas.camera

sas.time

sas.numambientlights

sas.numdirectionallights

sas.numpointlights

sas.numspotlights

sas.ambientlight

sas.directionallight

sas.pointlight

sas.spotlight

 

DDS File Format Support

XSI now supports the Microsoft DDS file format as a native image format. You can load and use DDS files as you would normal image clips. Note that cubic surfaces are tiled horizontally when loaded.

Compositing and Effects

Crop

The Move Image Back To (0,0) Coordinate option automatically repositions the image in the bottom left corner after cropping the bottom or left sides. This means that you do not need to combine the Crop operator with a Transform3D operator in this situation. If this option is off, a white border shows the extent of the image that the node will output.

By default, this option is on for newly created Crop nodes. For nodes created in an earlier version of XSI, this option is off to preserve backwards-compatibility.

Resize

A bug that sometimes caused the output of the Resize node to be off by one pixel has been fixed. New Resize nodes will display the correct behavior, but old ones will continue to behave as before for backwards-compatibility in case you fixed the problem by cropping. To get the new behavior in an old scene, simply delete and reapply the Resize operator.

Customizing

Menus

A variety of new anchor points have been added for placing custom items on the XSI menus. You can now add items to the menus in the main command panel as well as the menus in the viewports.

Script Editor

The new Autofocus on the Script Editor preference controls the script editor’s rude and annoying habit of popping to the front of other windows as soon as the mouse pointer moves over it.

Synoptic Views

Procedures in synoptic view scripts have two new variables:

• The in_mousebutton variable is an integer that indicates which mouse button was used to click the hotspot.

• The in_keymodifier variable is an integer that indicates which key modifiers were pressed when the hotspot was clicked.

Self-installing Custom Operators

XSI nows supports self-installing custom operators. There is a wizard that can generate a template for the appropriate callbacks, which you can access from the Plug-in Manager. For more information, see the SDK Guides.

Custom Shaders

Custom shaders no longer need to be registered. For more information, see the SDK Guides.

GATOR for 3ds Max

SOFTIMAGE|GATOR (General Attribute Transfer Operator) is a plug-in for 3ds Max 8 that transfers and merges texture coordinates, skin weights, and vertex colors from one or more source objects to a target object, even if there are topological differences. For example, you can transfer texture coordinates from a high-resolution object to a low-resolution object, or copy skin weights between two characters that share a skeleton.

This features is available for 32-bit Windows systems only.

To install SOFTIMAGE|GATOR

1. Locate the files GATORUtility.dlu and GATORUtility.chm in the Application\Plugins subfolder of your XSI installation directory.

2. Copy these files to the plugins directory of your 3ds Max installation.

To access SOFTIMAGE|GATOR in 3ds Max

1. Select the Utilities command panel.

2. In the Utilities roll-out, click More.

3. Select GATOR and click OK.

For information about using the GATOR plug-in, click Help (at the bottom of the roll-out).



Autodesk Softimage Documentation Archives